Results 1 to 2 of 2

Thread: Help needed to debug ACPI critical shutdown

  1. #1
    Join Date
    Sep 2008
    Location
    Reading.UK.EU
    Posts
    17

    Default Help needed to debug ACPI critical shutdown

    I have recently built a SuSE 11 based system, Abit A-S78H mobo, 4850e CPU etc. In short I run 24/7, sometimes I get a critical shutdown 3 times a day, sometimes I run for days with no problem. The extract from /var/log/messages is
    Code:
    Oct  1 20:43:50 dukla kernel: ACPI: Critical trip point
    Oct  1 20:43:50 dukla kernel: Critical temperature reached (122 C), shutting down.
    Oct  1 20:43:50 dukla kernel: ACPI: Unable to turn cooling device [ffff81011fa88ed0] 'on'
    Oct  1 20:43:50 dukla powersaved[3671]: WARNING (checkTemperatureStateChanges:217) Temperature state changed to critical.
    Oct  1 20:43:50 dukla shutdown[12356]: shutting down for system halt
    The question - how can I find out which sensor is reaching the critical temp, and how can I ignore it? I know my machine has no components near 100C - CPU is running in 30s, hdds are in 20s etc (I am a case & cooling fetishist!)
    Thanks
    Last edited by dukla2000; 01-Oct-2008 at 15:21. Reason: correct typo in title

  2. #2
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    405

    Default Re: Help needed to debug ACPI critical shutdown

    I had the same problem on suse 10.2, when the thermal module was loaded together with the lm_sensors module, like i2c_i801 . It caused a mess because there was no mutual exclusion lock on the access to the hardware info. Therefore the thermal module had some inconsistent info like 127C temperature for the cpu . Such huge temperature causes an immediate system shutdown, which is a safe reaction.
    The only way to avoid such unexpected shutdown was to force unload of the thermal module. But it is also unsure because system will then not be able to shutdown if there a real temperature burst...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •