Results 1 to 10 of 10

Thread: Printing from OpenOffice

  1. #1
    Join Date
    Jun 2008

    Default Printing from OpenOffice

    I am using openSUSE 11.0 with KDE 4.1 and OpenOffice 2.4.1.
    I used the CUPS printer setup stuff provided on the Brother Solutions site to set up CUPS for my Brother HL5280DW printer.
    I can print with no problems from a variety of applications (basically, every application I tried - except for OpenOffice.) When I try to print from any of the OpenOffice programs I get pages and pages of printout (even when trying to print a page with only 10 characters on it). The pages of printout seem to contain some 'technical' information about the print job, and also a good deal of garbage. I can see that OpenOffice recognizes my Brother5280 as the default printer and tries to print to it, but why do the print jobs fail for OpenOffice but not for other applications.
    Thanks for the help.

  2. #2
    Join Date
    Jul 2008
    United Kingdom

    Default Re: Printing from OpenOffice

    Hi, it might help diagnose the issue if you posted the 'garbage' from the printouts. I am not an expert with cups but it may help others help you!!!

  3. #3
    Join Date
    Jun 2008

    Default Re: Printing from OpenOffice

    Hi, thanks for the interest...
    The reason I didn't post the 'garbage' is because I didn't know how, and I thought it would be pretty useless anyways. The garbage does not consist of error messages. It's pages and pages (I cut off my printer after 10 pages) of what I presume to be printer commands...things like specifying fonts to use, toner save mode, sleep mode, strings, resolution, etc.
    The 'garbage' does start with %!PS-Adobe-3.0, which I suppose might be referring to something PostScript, but I have no idea of whether that would be correct or not.
    I'll repeat that this only occurs when I print from OpenOffice. So far, all of my other applications seem to be printing just fine.
    I'd be happy to post this garbage if someone could tell me how to do it, but since it only seems to appear as printed (hard copy) output, I could not figure out how to capture it electronically to post. It's way too much to try retyping.
    Thanks again.

  4. #4

    Default Re: Printing from OpenOffice

    many would advise with printing problems in linux, to refer to Open Printing

    OpenPrinting - The Linux Foundation

    They list those printers that are known to work on linux: your printer is unlisted

    OpenPrinting database - All Brother Printers

    the nearest listed to yours is the HL-5270DN
    OpenPrinting database - Printer: Brother HL-5270DN

    you may find some of their comments useful;

    We should ask you: where did you get the drivers from?

    if you get your printer running well, you could very valuably contribute an entry on your particular printer to the OpenPrinting database

    You might be able to talk directly to Brother Solutions Centre: Brother Solutions Center : Brother Driver for Linux Distributions

    or join the Brother printer forum at OpenPrinting, OpenPrinting User Forums

    previous reports of installing Brother printers HowTo Install a Brother Laser Printer HL-2040 in Suse 10.x + User Notes

    describe downloading and installing an lpr driver first and then a cups wrapper second;

    was that the format that you followed?

    I note on the Brother website, where they give advice on things to do before installation,

    Brother Solutions Center : Brother Driver for Linux Distributions

    that they say
    Creating a symbolic link is required before the installation
    that for your printer, on an OpenSuse system to issue the command

    # ln -s /etc/init.d/cups /etc/init.d/lpd
    which is issued as root: were you aware of this command?

    You may well find a variety of useful information on this Brother link: they seem to be well regarded for their linux support, and this page, on advice before installation, is tailored to individual distros ........

  5. #5
    plztalkgentle NNTP User

    Default Re: Printing from OpenOffice

    good very nice.... but i nver had provlem of printing in open office

    My Personal Blog

    You May loose yours Tender Till You Not Connected To Tender News International

  6. #6

    Default Re: Printing from OpenOffice

    and I see the Brother help page has two references to OpenOffice printing problems, but I am not sure either would be of help to you; they talk of editing the ppd file

    Brother Solutions Center : Brother Driver for Linux Distributions

  7. #7
    Join Date
    Jun 2008

    Default Re: Printing from OpenOffice

    Thanks to everyone who contributed some help.

    A couple of months ago, I had successfully set up my Brother HL5280DW using the CUPS and LPR files obtained from the Brother Solutions site. (these were specific files for that model printer.)But I was having trouble getting the same to work on a new Linux machine.

    Based on a suggestion in this thread above, I revisited the Brother Solutions site (Brother Solutions Center : Brother Driver for Linux Distributions) and found that they had revised their assistance. I followed everything as instructed there (including the 'Before Installation' link) and am happy to report that the printer is now working fine, including for my OpenOffice apps. I guess I should have checked back at the Brother Solutions site first, but I thought that what I already had from before should have worked (not sure why it didn't.)

    Anyways, I'm happy now, so thanks again.

  8. #8

    Default Re: Printing from OpenOffice

    delighted to hear that the installation of the Brother HL5280DW has gone well, and is printing well;

    if you had the time at some stage, it would be valuable if you could visit the openprinting site, and make an entry for your HL5280DW: currently, that model is not listed at all; you could very reasonably register your printer as working perfectly with the Brother drivers?

    Adding new printer

    best wishes

  9. #9
    johann-tennis NNTP User

    Default Re: Printing from OpenOffice

    I'm a new user of opensuse 11.0 and it installed just fine from opencd but when I try to install the drivers (or any software), I get an error message "cannot access installation media" though I am on the internet just fine with everything there. "download failed" and it gives the source /moarch/openoffice_org templates-en- not found on medium" This thread has been very helpful but I am getting infuriated that none of the packages are "seemlessly" being incorporated into my operating system files as I read about Linux and Opensuse. Why can't I download and install the packages necessary for the printer? (or any packages?)

  10. #10

    Default Re: Printing from OpenOffice

    sorry that your enquiry of the 2nd Oct got missed;

    by installing from the CD, rather than say a DVD, you only get some of the packages; so you need to install the repositories; have you had guidance on that?

    If not, if you open YaST; are you using Gnome or KDE?

    If you can get into YaST, having given your root password, if you click on "Software Repositories" in the Software Section;

    and then click on "ADD" in the bottom left hand corner;

    and then at the TOP of the next page that opens, click on "Community Repositories"; oldcpu, one of the forum administrators, recommends you only add four: which I think are main repository (OSS); main repository (NON-OSS); packman and main update repository; hmmmmmmmmm; hope I got that right;

    if you accept those, and click finish, they should be added;

    and if you then close that sofware repository box, and instead open the software management one, you should be able to select some packages and get some downloading done;

    I hope some of this may be helpful;

    let us know how you get along .........

    by the way, for such a post as yours, you might well get more notice by posting a NEW THREAD; your topic warranted that; you entered under "printing from openoffice";

    if you get the above working, you should be able to download the 2.4version of OO, which I think is current latest stable

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts