Results 1 to 9 of 9

Thread: display does not update or "refresh" when mouse is idle

  1. #1
    dameatman NNTP User

    Unhappy display does not update or "refresh" when mouse is idle

    Folks,

    I'm hoping someone out there can help with this issue. I've noticed that after installing OpenSuse 11.0 my display does not seem to update or refresh it's contents while the mouse is idle and not moving for a couple of seconds. Let me clarify the behavior:

    If performing a download you normally see the download speed/progress displayed on the screen, this is updated and changes in real time every second or so. However when i am not moving the mouse, i noticed that this does not update and it seems as if it has frozen, if i move the mouse again then immediately the display updates showing the new progress and speed.

    I notice exactly the same behaviour with any kind of screen movement or activity such as a progress bar, the little rotating "hour glass icon" on the mouse, all will stop updating when the mouse is not moving, when moving the mouse they all seem to update ok.

    What could be the cause of this, it seems as if the screen is only being redrawn when the mouse is not moving, is this some type of power saving feature that can be disabled? It is extremely annoying and really my only major complain with OpenSuse so far.

    Hope you can help

    Regards,

    Joe Marques

  2. #2
    dameatman NNTP User

    Default Re: display does not update or "refresh" when mouse is idle

    I just realized i should have provided more detail about what desktop environment i'm using.

    X Server is KDE 4.1, but also noticed this issue with the default KDE 4.0 before updating to 4.1.

  3. #3
    dameatman NNTP User

    Default Re: display does not update or "refresh" when mouse is idle

    I'm pretty sure i'm not the only one out there having this problem, can't anyone offer some help with this??

  4. #4
    dameatman NNTP User

    Default Re: display does not update or "refresh" when mouse is idle

    Bump..

    Can someone please help?

  5. #5
    Join Date
    Oct 2008
    Location
    Choctaw, OK
    Posts
    66

    Default Re: display does not update or "refresh" when mouse is idle

    I can make a stab at it. Keep in mind I know nothing of KDE4 and that may be where the problem lies.

    So let's start with the obvious: What mouse are you using and what does your config call it? You can check via YaST or by looking directly at /etc/X11/xorg.conf. If the actual pointing device is unusual, you may need to google for proper settings.

    A related issue may be the screen refresh rate or some other settings in your xorg.conf. SUSE's SaX is pretty smart, but it seldom gets every detail correct. I've got quite a bit of experience messing the X setup, and my current machine (G4 eMac) running SUSE 11.0 offered me some really new behavior issues. For example, so applications don't work properly unless I run it at the max 24-bit color setting.

    Screen repaint relies on so very many things, it's hard to know where to start. Any help?
    Ed Hurst
    Open for Business (ofb.biz)

  6. #6
    odalcet NNTP User

    Default Re: display does not update or "refresh" when mouse is idle

    I have the same problem using Fedora Core 8, Gnome 2.20.3, Logitech wireless mouse m-rm67a and an IBM 19" monitor.
    Doing what? For example, playing "wars" on Facebook. The screen doesn't freeze completely but game runs veeeeery slooooow. When I move the mouse, program "wakes up"...

  7. #7
    odalcet NNTP User

    Default Re: display does not update or "refresh" when mouse is idle


    I have the same problem using Fedora Core 8, Gnome 2.20.3, Logitech
    wireless mouse m-rm67a and an IBM 19" monitor.
    Doing what? For example, playing "wars" on Facebook. The screen doesn't
    freeze completely but game runs veeeeery slooooow. When I move the
    mouse, program "wakes up"...


    --
    odalcet
    ------------------------------------------------------------------------
    odalcet's Profile: http://forums.opensuse.org/member.php?userid=4940
    View this thread: http://forums.opensuse.org/showthread.php?t=396412


  8. #8
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: display does not update or "refresh" when mouse is idle

    Sounds like a X/window-manager (compiz, kwin) communication issue.

    First I'd try disabling desktop effects, if it is enabled, and see if it works. Also update the video driver, if nvidia or ati.

    Beyond that, I have no ideas.

  9. #9
    brunomcl NNTP User

    Default Re: display does not update or "refresh" when mouse is idle


    Sounds like a X/window-manager (compiz, kwin) communication issue.

    First I'd try disabling desktop effects, if it is enabled, and see if
    it works. Also update the video driver, if nvidia or ati.

    Beyond that, I have no ideas.


    --
    brunomcl
    ------------------------------------------------------------------------
    brunomcl's Profile: http://forums.opensuse.org/member.php?userid=8892
    View this thread: http://forums.opensuse.org/showthread.php?t=396412


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •