Results 1 to 4 of 4

Thread: VirtualBox OpenSuse Problem

  1. #1

    Unhappy VirtualBox OpenSuse Problem

    Hi everyone! I have just installed virtualbox 2.0.2 and i have a problem with the usb. I installed windows xp. When i go to settings:
    Code:
    Could not load the Host USB Proxy Service (VERR_FILE_NOT_FOUND). The service might be not installed on the host computer.
    
    
    Result Code: 
    NS_ERROR_FAILURE (0x00004005)
    Component: Host
    Interface: IHost {489fb370-c227-4d43-9761-ceb28484fd9f}
    Callee: IMachine {1e509de4-d96c-4f44-8b94-860194f710ac}
    I use opensuse 11 and my user is in the group lp,vboxusers. Can anyoane help me please to solve this?

    thx! Cheers!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: VirtualBox OpenSuse Problem

    So I take it this error is from the windows guest.
    And you have enabled usb in the settings of VBox for the xp machine?

    Have you read here: User_FAQ - VirtualBox

    • USB on openSUSE: Add the following entry to /etc/fstab: none /proc/bus/usb usbfs auto,busgid=XXX,busmode=0775,devgid=XXX,devmode=0664 0 0
      Replace XXX by the group ID of the group vboxusers. You can determine this value by executing grep vboxusers /etc/group
      Of course, the current user should be member of that group. After the next reboot, there should be a directory /proc/bus/usb/ and the device entries below should be accessible by any user of the vboxusers group.


    • If USB doesn't work, check your usbfs permissions. See "Troubleshooting" -> "Linux hosts" in the User Manual for a solution.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: VirtualBox OpenSuse Problem

    Thx man....it works I haved to removed from fstab:
    Code:
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    with

    Code:
    usbfs  		     /proc/bus/usb        usbfs      auto,busgid=116,busmode=0775,devgid=116,devmode=0664  0  0
    Thx again! Now i have problem with the network...i can`t see the virtual pc on the network...i will search to find why...

    Cheers!

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: VirtualBox OpenSuse Problem

    Easiest way to share is shared folders, or at least I find it that way.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •