Results 1 to 10 of 10

Thread: Compiz upgrade breaks Desktop Effects

  1. #1

    Default Compiz upgrade breaks Desktop Effects

    So, I run 11.0 x86_64, gnome, and nvidia. Everything has been working well for months.

    I tried over the weekend to upgrade compiz and compiz-gnome from 0.7.4-31.1 to 0.7.8-25.1 using Yast. The newer version is in the X11:/XGL repository.

    It broke Desktop Effects. No cube, nothing. I went through the process of updating the nvidia driver. No change.

    Downgrading compiz and compiz-gnome solves the problem without touching anything else.

    What's going on?

  2. #2

    Default Re: Compiz upgrade breaks Desktop Effects

    Hiya!

    Same thing happened to me, much wailing and gnashing of teeth ensued, I think this post on linux questions may have the cause, if not the cure?
    opensuse 11 - compiz x86_64, libcompizconfig 586... wait, what? where is x86_64 ver? - LinuxQuestions.org

  3. #3

    Default Re: Compiz upgrade breaks Desktop Effects

    Quote Originally Posted by johnbro67 View Post
    Hiya!

    Same thing happened to me, much wailing and gnashing of teeth ensued, I think this post on linux questions may have the cause, if not the cure?
    opensuse 11 - compiz x86_64, libcompizconfig 586... wait, what? where is x86_64 ver? - LinuxQuestions.org
    Well, that was interesting. Yes, I was certainly seeing a shortage of x86_64 packages. But there was also a repository identified (the Compiz repository) there that had updated versions of everything. So I upgraded everything with "Compiz" in the name from the same repository. I figured that would work.

    It did not. CompizConfig complained that it could not start the Desktop Cube, because the GLX module was not started. GLX would not start.

    I downgraded everything again, and all was well. This is is really weird.

  4. #4

    Default Re: Compiz upgrade breaks Desktop Effects

    I cannot say if my problem is connected to the new version of compiz, but I got the green default desktop, too.

    I activated compiz a few days ago and it seems to work with transparent window decorations, fade effects, etc.

    What does not work is the desktop cube. I could set a background image, read the line with the desktop number, rotate the cube but not see it at all. The cube itself is invisible.

    I tried setting options and upgrading compiz with the effect that the buttons inside the compizconfig-settings-manager don't work anymore. When starting ccsm from console it replies with "ErrorKey: 0" after pressing a button. I tried again with reinstalling compiz. Nothing changed.

    Strangely, after uninstalling every package containing "compiz", I can still activate and use compiz by starting the "Configure Desktop" program, and selecting "Desktop"->"Enable desktop effects". It seems compiz and all settings are still installed even though all packages are uninstalled. I am confused.

    openSUSE 11.0 x86_64 with KDE 4.1 and a lot of factory repositories.

  5. #5

    Default Re: Compiz upgrade breaks Desktop Effects

    I, too, am running x86_64 and experienced problems with the desktop effects after upgrading. I had a bit of a strange problem: there would be a sort of stuttering of the desktop when KDE started up, then the panel would flip out and fill with all sorts of odd half-graphics.

    I read on Compiz Fusion's website that openSUSE's repositories had changed from X11GL to X11:Compiz. Installing from this repository did not do anything to help the situation.

    There was also the recommendation of deleting Compiz's configuration files and re-enabling via the simple configuration utility. This did not solve the issue, either.

    Downgrading and starting anew has been the only resolution I've found that works.

    I wonder if the community packages are meant for KDE 4.1.x and not the stock KDE 4.
    Last edited by Wrath5000; 29-Sep-2008 at 15:08. Reason: KDE version info
    I'm confused...No, wait...Maybe I'm not...

  6. #6

    Default Re: Compiz upgrade breaks Desktop Effects

    I experimented with different versions:

    0.7.8: Buggy: Cannot use buttons inside ccsm, desktop cube is invisible

    0.7.6: Seems to work great except that compiz-kde4 ist not available. Using emerald in the mean time.

    0.7.4: Unusable: Trying to move a window resizes another one.

  7. #7

    Default Re: Compiz upgrade breaks Desktop Effects

    I just discovered that there is a huge difference between enabling desktop effects in "Configure Desktop" and simple-ccsm.

    "Configure Desktop" keeps the kde window decorator but ignores the settings from ccsm. I get the invisible cube bug here even with version 0.7.6.

    Enabling desktop effects using simple-ccsm works fine but looses window decorations until emerald is started.

  8. #8
    Join Date
    Jun 2008
    Location
    Concord, California
    Posts
    262

    Default Re: Compiz upgrade breaks Desktop Effects

    The X11 Compiz repo has been updated - sort of. The modified dates have changed, but the versions are the same.

    I tried it - still broke.

    On my system, once compiz tries to load it freezes. I can ctrl-alt-F1 and login and see that compiz takes 100%. It does not respond to a kill command.
    OpenSUSE Leap 15, KDE5 (plasma 5.16.5, frameworks 5.62, QT 5.13.1)

  9. #9

    Default Re: Compiz upgrade breaks Desktop Effects

    The lagging x86_64 repositories continue to frustrate.

    My 32-bit laptop running an otherwise identical setup of 11.0 works perfectly. My x86_64 desktop is broken. The configuration utilities don't effect their settings. Some settings in CCSM or fusion-icon hang the X11 process. Selecting Advanced in Simple CompizConfig Settings Manager for the Profile hangs X11. Emerald is effectively dead.

    As of this writing:
    0.7.8-12.1 is the latest compiz x86_64
    0.7.8-16.1 is the latest compiz i586

    The compiz-gnome package has the same versions.

    The X11: Compiz repository is providing the most recent i586 versions. X11: XGL and the X11: Compiz repositories have the older ones.

    I don't know if 11.1 will have this issue. Perhaps none of the packagers cares enough to build the x86_64 packages. They may be very busy with 11.1. Perhaps there are bugs in building the 64-bit versions of the packages.

    I do know that while these are marked as tiny changes, the Application Binary Interface (ABI, or function signatures and return codes) changed. Usually at least a minor version bump is called for when this is done in F/OSS (where version numbers can have meaning beyond marketing lies.) As can be seen, when the ABI of the core compiz changed many of the tools and libraries and functionality broke.

    Now I have to go back and try to downgrade to a version that might work.

  10. #10

    Default Re: Compiz upgrade breaks Desktop Effects

    After downgrading, the basics work. However, the 3d plugin does not work anymore and some settings like the number of viewports on my 2nd monitor cannot be set via configuration utilities anymore.

    To detect ABI changes, you don't have to wait for desktop effects to break. If you run something like fusion-icon from the command line, the ABI breakage is plainly visible:

    fusion-icon
    * Detected Session: gnome
    * Searching for installed applications...
    * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
    * Using the GTK Interface
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:46: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:47: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:48: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
    * Starting Compiz
    ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
    compiz (core) - Error: Plugin 'core' has ABI version '30080902', expected ABI version '20080828'.

    compiz (ccp) - Error: InitObject failed
    compiz (core) - Error: Couldn't activate plugin 'ccp'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •