Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Problem with installing/updating through yast.

  1. #1

    Question Problem with installing/updating through yast.

    Hi.. for about a week i'm facing this problem with my opensuse 11 system that whenever i try to install or update anything through yast2 or yast (cli) it gives an error saying

    "Error: INVALIDackage kdelibs4-doc-4.1.1-52.2 fails integrity check. Do you want to retry?"

    For any package from any repository its giving the same error.

    Can someone help?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Problem with installing/updating through yast.

    In a terminal type:

    zypper lr
    post result here
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Problem with installing/updating through yast.

    # | Alias | Name | Enabled | Refresh
    ---+----------------------------------------------------------------------------------------+----------------------------------------------+---------+--------
    1 | http://download.opensuse.org/update/11.0/_1 | Main Update Repository | Yes | Yes
    2 | openSUSE:11.0:Update | openSUSE:11.0:Update | No | Yes
    3 | Index of /repositories/GNOME:/Community/openSUSE_11.0 | openSUSE BuildService - GNOME:Community | No | Yes
    4 | 20080906-142736 | 20080906-142736 | No | Yes
    5 | Index of /repositories/KDE:/Backports/openSUSE_11.0 | openSUSE BuildService - KDE:Backports | No | Yes
    6 | Index of /repositories/Emulators:/Wine/openSUSE_11.0 | openSUSE BuildService - Wine CVS Builds | No | Yes
    7 | openSUSE:11.0 | openSUSE:11.0 | No | Yes
    8 | Index of /repositories/X11:/XGL/openSUSE_11.0 | openSUSE BuildService - X11GL | Yes | Yes
    9 | http://download.opensuse.org/reposit...enSUSE_11.0/_1 | openSUSE BuildService - KDE4:Factoryesktop | No | Yes
    10 | openSUSE--standard | openSUSE--standard | Yes | Yes
    11 | Index of /pub/packman/suse/11.0 | Packman Repository | No | Yes
    12 | Index of /distribution/11.0/repo/non-oss | Main Repository (NON-OSS) | Yes | Yes
    13 | Index of /update/11.0 | Main Update Repository | Yes | Yes
    14 | KDE-QT | KDE-QT | No | Yes
    15 | Index of /repositories/drivers:/webcam/openSUSE_11.0_Update | openSUSE BuildService - Drivers for webcams | No | Yes
    16 | Index of /repositories/KDE:/Community/openSUSE_11.0 | openSUSE BuildService - KDE:Community | No | Yes
    17 | anubis(opensuse11_pidgin) | anubis(opensuse11_pidgin) | No | Yes
    18 | Index of /repositories/GNOME:/STABLE/openSUSE_11.0 | openSUSE BuildService - GNOME:STABLE | No | Yes
    19 | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.0 | openSUSE BuildService - OpenOffice.org | No | Yes
    20 | Index of /repositories/mozilla/openSUSE_11.0 | openSUSE BuildService - Mozilla | No | Yes
    21 | KDE:KDE4:Factoryesktop | KDE:KDE4:Factoryesktop | Yes | Yes
    22 | Packman-Bremen | Packman-Bremen | No | Yes
    23 | Index of /distribution/11.0/repo/oss | Main Repository (OSS) | Yes | Yes
    24 | Index of /pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | No | Yes
    25 | home:figod | home:figod | No | Yes
    26 | http://download.nvidia.com/opensuse/11.0 | NVIDIA Repository | No | Yes
    27 | openSUSE-DVD_11.0 | openSUSE-DVD 11.0 | No | No
    28 | KDE:KDE4:Community | KDE:KDE4:Community | Yes | Yes

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Problem with installing/updating through yast.

    Mate, you have repo's all over the place.

    Which desktop do you use most? kde or gnome?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Problem with installing/updating through yast.

    even if i enable just one of them.. lets say kde4 factory.. n try to update kdelibs.. its giving the same error.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Problem with installing/updating through yast.

    My advice. Delete them ALL.

    Then add the basics first
    OSS
    NON-OSS
    Updates
    Packman

    then
    Index of /repositories/GNOME:/STABLE/openSUSE_11.0

    http://download.opensuse.org/reposit...enSUSE_11.0/_1


    Index of /repositories/X11:/XGL/openSUSE_11.0

    http://download.nvidia.com/opensuse/11.0

    Index of /repositories/mozilla/openSUSE_11.0

    and so on....
    only add what you need
    You don't need VLC (the only package you need from there is libdvdcss - which you should already have)

    see how you go
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Problem with installing/updating through yast.

    Also
    Delete all you can in /tmp
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Jun 2008
    Location
    PHX
    Posts
    481

    Default Re: Problem with installing/updating through yast.

    Get your repos down to the necessities only as mentioned and then try:

    # zypper clean -a
    # rpm --rebuilddb
    <>---><^>

  9. #9

    Default Re: Problem with installing/updating through yast.

    i removed all repos... just added kde4 factory... and even after that im getting the same error.

  10. #10
    Join Date
    Jun 2008
    Location
    PHX
    Posts
    481

    Default Re: Problem with installing/updating through yast.

    The same error for all repos or just when you try to install a pkg from the kde4 factory?
    <>---><^>

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •