Results 1 to 2 of 2

Thread: So I need G++?

  1. #1
    Join Date
    Sep 2008
    Location
    Bellingham, Wa
    Posts
    7

    Default So I need G++?

    Okay, so I downloaded GCC, make, and all the libraries I needed for VisualBoyAdvance. I made it through ./configure, and here is what happens when I tried make...

    Code:
    Making all in m4
    make[1]: Entering directory `/home/darkside/Games/VisualBoyAdvance-1.7.2/m4'
    make[1]: Nothing to be done for `all'.
    make[1]: Leaving directory `/home/darkside/Games/VisualBoyAdvance-1.7.2/m4'
    Making all in src
    make[1]: Entering directory `/home/darkside/Games/VisualBoyAdvance-1.7.2/src'
    Making all in gb
    make[2]: Entering directory `/home/darkside/Games/VisualBoyAdvance-1.7.2/src/gb'
    source='gbCheats.cpp' object='gbCheats.o' libtool=no \
    	depfile='.deps/gbCheats.Po' tmpdepfile='.deps/gbCheats.TPo' \
    	depmode=none /bin/sh ../../depcomp \
    	g++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"VisualBoyAdvance\" -DVERSION=\"1.7.2\" -DHAVE_LIBZ=1 -DHAVE_LIBPNG=1 -DHAVE_LIBPTHREAD=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_MALLOC_H=1 -DHAVE_STRINGS_H=1 -DHAVE_UNISTD_H=1 -DHAVE_ARPA_INET_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_ZUTIL_H=1  -I. -I.     -DPROFILING -DMMX -DDEV_VERSION -c -o gbCheats.o `test -f 'gbCheats.cpp' || echo './'`gbCheats.cpp
    ../../depcomp: line 470: exec: g++: not found
    make[2]: *** [gbCheats.o] Error 127
    make[2]: Leaving directory `/home/darkside/Games/VisualBoyAdvance-1.7.2/src/gb'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/darkside/Games/VisualBoyAdvance-1.7.2/src'
    make: *** [all-recursive] Error 1
    I'm guessing that the problem is that I need G++, as it said in one of the lines, but not sure about any other errors. Can anyone help me, any mandatory packages I need here? I got GCC43-C++, but it doesn't fit the bill...

  2. #2
    Join Date
    Sep 2008
    Location
    Bangalore, India
    Posts
    365

    Default Re: So I need G++?

    Try gcc-c++

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •