Results 1 to 9 of 9

Thread: Help with installing Beryl to OpenSUSE 10.2

  1. #1

    Default Help with installing Beryl to OpenSUSE 10.2

    Hi,

    I'm trying to install beryl to work on my computer. I have a IBM Thinkpad Z60t. That has an Intel 915gm graphics card in it. I've added the repository from the tut from opensuse.org. I've followed those directions. When I get to the yast part it doesn't work. I checked off to install everything in there list and this comes up:

    Can't satisfy requirement dbus-1 == 0.60-33.17.3 for dbus-1-gtk-0.60-33.20.3.i586
    Conflict Resolution:
    ( ) delete dbus-1-gtk
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for compiz-0.4.0-0.21.i586
    Conflict Resolution:
    ( ) delete compiz
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for compiz-gnome-0.4.0-0.21.i586
    Conflict Resolution:
    ( ) delete compiz-gnome
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for compiz-kde-0.4.0-0.21.i586
    Conflict Resolution:
    ( ) delete compiz-kde
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for ekiga-2.0.5-0.9.i586
    Conflict Resolution:
    ( ) delete ekiga
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for gnome-main-menu-0.9.8-0.15.i586
    Conflict Resolution:
    ( ) delete gnome-main-menu
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for gnome-menus-2.16.1-38.11.i586
    Conflict Resolution:
    ( ) delete gnome-menus
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for gnome-panel-nld-2.12.3-0.39.3.i586
    Conflict Resolution:
    ( ) delete gnome-panel-nld
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for gsynaptics-0.9.9-18.9.i586
    Conflict Resolution:
    ( ) delete gsynaptics
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for helix-banshee-0.12.0-0.13.i586
    Conflict Resolution:
    ( ) delete helix-banshee
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for helix-dbus-server-0.4.0-0.10.i586
    Conflict Resolution:
    ( ) delete helix-dbus-server
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for hotkey-setup-0.1-26.7.i586
    Conflict Resolution:
    ( ) delete hotkey-setup
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for libipoddevice-0.5.2-1.17.i586
    Conflict Resolution:
    ( ) delete libipoddevice
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for libssui-0.5.6-0.10.i586
    Conflict Resolution:
    ( ) delete libssui
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for libzypp-2.32.3-0.4.i586
    Conflict Resolution:
    ( ) delete libzypp
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for libzypp-zmd-backend-7.1.1.0_2.15-0.3.i586
    Conflict Resolution:
    ( ) delete libzypp-zmd-backend
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for MozillaFirefox-2.0.0.14-0.2.3.i586
    Conflict Resolution:
    ( ) delete MozillaFirefox
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for NetworkManager-0.6.6-0.8.i586
    Conflict Resolution:
    ( ) delete NetworkManager
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for NetworkManager-glib-0.6.6-0.8.i586
    Conflict Resolution:
    ( ) delete NetworkManager-glib
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for NetworkManager-gnome-0.6.6-0.8.i586
    Conflict Resolution:
    ( ) delete NetworkManager-gnome
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for planner-0.14.1-24.12.i586
    Conflict Resolution:
    ( ) delete planner
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for vlc-0.8.6f-8.1.i586
    Conflict Resolution:
    ( ) delete vlc
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for vlc-mozillaplugin-0.8.6f-8.1.i586
    Conflict Resolution:
    ( ) delete vlc-mozillaplugin
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for yast2-control-center-gnome-2.13.2-0.14.i586
    Conflict Resolution:
    ( ) delete yast2-control-center-gnome
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libdbus-1.so.2 for zypper-0.6.21-0.2.i586
    Conflict Resolution:
    ( ) delete zypper
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libedata-cal-1.2.so.1 for libopensync-plugin-evolution2-0.20-18.8.i586
    Conflict Resolution:
    ( ) delete libopensync-plugin-evolution2
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libpython2.4.so.1.0 for libopensync-0.20-22.8.i586
    Conflict Resolution:
    ( ) delete libopensync
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libpython2.4.so.1.0 for OpenOffice_org-2.4-0.2.11.i586
    Conflict Resolution:
    ( ) delete OpenOffice_org
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libpython2.4.so.1.0 for scribus-1.3.4-26.1.i586
    Conflict Resolution:
    ( ) delete scribus
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement python < 2.5 for libbeagle-0.2.16.3-1.12.i586
    Conflict Resolution:
    ( ) delete libbeagle
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    helix-banshee-engine-gst-0.12.0-0.13.i586 cannot be installed due to missing dependencies
    There are no installable providers of helix-banshee == 0.12.0 for helix-banshee-engine-gst-0.12.0-0.13.i586
    Conflict Resolution:
    ( ) delete helix-banshee-engine-gst
    ( ) Ignore this requirement just here
    helix-banshee-engine-helix-0.12.0-0.13.i586 cannot be installed due to missing dependencies
    There are no installable providers of helix-dbus-server >= 0.4.0 for helix-banshee-engine-helix-0.12.0-0.13.i586
    Conflict Resolution:
    ( ) delete helix-banshee-engine-helix
    ( ) Ignore this requirement just here
    helix-banshee-plugins-default-0.12.0-0.13.i586 cannot be installed due to missing dependencies
    There are no installable providers of helix-banshee == 0.12.0 for helix-banshee-plugins-default-0.12.0-0.13.i586
    Conflict Resolution:
    ( ) delete helix-banshee-plugins-default
    ( ) Ignore this requirement just here
    helix-banshee-plugins-extra-0.12.0-0.13.i586 cannot be installed due to missing dependencies
    There are no installable providers of helix-banshee == 0.12.0 for helix-banshee-plugins-extra-0.12.0-0.13.i586
    Conflict Resolution:
    ( ) delete helix-banshee-plugins-extra
    ( ) Ignore this requirement just here
    MozillaFirefox-translations-2.0.0.14-0.2.3.i586 cannot be installed due to missing dependencies
    There are no installable providers of MozillaFirefox == 2.0.0.14 for MozillaFirefox-translations-2.0.0.14-0.2.3.i586
    Conflict Resolution:
    ( ) delete MozillaFirefox-translations
    ( ) Ignore this requirement just here
    OpenOffice_org-gnome-2.4-0.2.11.i586 cannot be installed due to missing dependencies
    There are no installable providers of OpenOffice_org == 2.4-0.2.11 for OpenOffice_org-gnome-2.4-0.2.11.i586
    Conflict Resolution:
    ( ) delete OpenOffice_org-gnome
    ( ) Ignore this requirement just here
    OpenOffice_org-nld-2.4-0.2.11.i586 cannot be installed due to missing dependencies
    There are no installable providers of OpenOffice_org == 2.4 for OpenOffice_org-nld-2.4-0.2.11.i586
    Conflict Resolution:
    ( ) delete OpenOffice_org-nld
    ( ) Ignore this requirement just here
    zmd-7.2.1.0-0.13.i586 cannot be installed due to missing dependencies
    There are no installable providers of libzypp-zmd-backend >= 7.1.1.0_2.15-0.3 for zmd-7.2.1.0-0.13.i586
    Conflict Resolution:
    ( ) delete zmd
    ( ) Ignore this requirement just here



    What do I do?

  2. #2
    Join Date
    Jun 2008
    Location
    Concord, California
    Posts
    262

    Default Re: Help with installing Beryl to OpenSUSE 10.2

    Beryl is considered dead. It actually merged in with compiz, and created compiz-fusion.

    Use this repo: Index of /repositories/X11:/XGL/openSUSE_10.3 and install compiz and compiz-fusion.

    There is a how to here.
    OpenSUSE Leap 15, KDE5 (plasma 5.16.5, frameworks 5.62, QT 5.13.1)

  3. #3

    Default Re: Help with installing Beryl to OpenSUSE 10.2

    I tried to install compiz-fusion like you said. This is what comes up:

    Can't satisfy requirement compiz == 0.4.0 for compiz-gnome-0.4.0-0.21.i586
    Conflict Resolution:
    ( ) delete compiz-gnome
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement dbus-1 == 0.60-33.17.3 for dbus-1-gtk-0.60-33.20.3.i586
    Conflict Resolution:
    ( ) delete dbus-1-gtk
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libpython2.4.so.1.0 for libopensync-0.20-22.8.i586
    Conflict Resolution:
    ( ) delete libopensync
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libpython2.4.so.1.0 for OpenOffice_org-2.4-0.2.11.i586
    Conflict Resolution:
    ( ) delete OpenOffice_org
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement libpython2.4.so.1.0 for scribus-1.3.4-26.1.i586
    Conflict Resolution:
    ( ) delete scribus
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement python < 2.5 for gnome-menus-2.16.1-38.11.i586
    Conflict Resolution:
    ( ) delete gnome-menus
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement python < 2.5 for libbeagle-0.2.16.3-1.12.i586
    Conflict Resolution:
    ( ) delete libbeagle
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    Can't satisfy requirement python < 2.5 for planner-0.14.1-24.12.i586
    Conflict Resolution:
    ( ) delete planner
    ( ) Ignore this requirement just here
    ( ) Ignore this requirement generally
    compiz-0.7.6-25.2.i586[20080927-073716] cannot be installed due to missing dependencies
    There are no installable providers of libX11-xcb.so.1 for compiz-0.7.6-25.2.i586[20080927-073716]
    Conflict Resolution:
    ( ) do not install compiz
    ( ) Ignore this requirement just here
    compiz-emerald-0.7.6-2.2.i586[20080927-073716] cannot be installed due to missing dependencies
    There are no installable providers of libwnck-1.so.22 for compiz-emerald-0.7.6-2.2.i586[20080927-073716]
    Conflict Resolution:
    ( ) do not install compiz-emerald
    ( ) Ignore this requirement just here
    compiz-fusion-plugins-extra-0.7.6-10.2.i586[20080927-073716] cannot be installed due to missing dependencies
    There are no installable providers of libX11-xcb.so.1 for compiz-fusion-plugins-extra-0.7.6-10.2.i586[20080927-073716]
    Conflict Resolution:
    ( ) do not install compiz-fusion-plugins-extra
    ( ) Ignore this requirement just here
    compiz-fusion-plugins-main-0.7.6-3.2.i586[20080927-073716] cannot be installed due to missing dependencies
    There are no installable providers of libX11-xcb.so.1 for compiz-fusion-plugins-main-0.7.6-3.2.i586[20080927-073716]
    Conflict Resolution:
    ( ) do not install compiz-fusion-plugins-main
    ( ) Ignore this requirement just here
    OpenOffice_org-gnome-2.4-0.2.11.i586 cannot be installed due to missing dependencies
    There are no installable providers of libucbhelper4gcc3.so for OpenOffice_org-gnome-2.4-0.2.11.i586
    Conflict Resolution:
    ( ) delete OpenOffice_org-gnome
    ( ) Ignore this requirement just here
    OpenOffice_org-nld-2.4-0.2.11.i586 cannot be installed due to missing dependencies
    There are no installable providers of OpenOffice_org == 2.4 for OpenOffice_org-nld-2.4-0.2.11.i586
    Conflict Resolution:
    ( ) delete OpenOffice_org-nld
    ( ) Ignore this requirement just here
    python-compizconfig-0.7.6-2.2.i586[20080927-074328] cannot be installed due to missing dependencies
    There are no installable providers of libX11-xcb.so.1 for python-compizconfig-0.7.6-2.2.i586[20080927-074328]
    Conflict Resolution:
    ( ) do not install python-compizconfig
    ( ) Ignore this requirement just here

    Now what?

  4. #4
    Join Date
    Jun 2008
    Location
    Concord, California
    Posts
    262

    Default Re: Help with installing Beryl to OpenSUSE 10.2

    This is weird. The last few talk about Open Office. That has nothing to do with compiz.

    What version of Suse are you using?

    is it 64 bit or 32? (please post uname -a command results)

    What repositories do you have? It looks like python and dbus haven't been installed.
    OpenSUSE Leap 15, KDE5 (plasma 5.16.5, frameworks 5.62, QT 5.13.1)

  5. #5

    Default Re: Help with installing Beryl to OpenSUSE 10.2

    The results are this:
    Linux Samuel8Pepose 2.6.16.60-0.18-default #1 Mon Apr 28 19:10:49 UTC 2008 i686 i686 i386 GNU/Linux

    And these are the repositories I have from YAST Installation Source:
    Index of /repositories/X11:/XGL/openSUSE_10.3
    Index of /repositories/X11:/Compiz/openSUSE_11.0
    Index of /repositories/X11:/XGL/openSUSE_10.3
    Index of /distribution/SL-OSS-factory/inst-source/suse
    Index of /distribution/10.2/repo/oss
    Index of /repositories/X11:/XGL:/Legacy/openSUSE_10.2

    I don't know why I added all of these. You can tell me which ones I don't need and which ones I need to add.

  6. #6
    Join Date
    Jun 2008
    Location
    Concord, California
    Posts
    262

    Default Re: Help with installing Beryl to OpenSUSE 10.2

    Your trying to mix all different sources. You have 10.2, 10.3 and 11. This problem #1.

    We need to limit the repos to just one version.

    Open Konqueror and type: "sysinfo:" in the address bar. About the middle of the right hand you will see the information about version (under OS Information). There is a line for system.

    What does that say? If it says 10.2, then you will need to get rid of all of the ones that do not have 10.2 rpms. (all the ones for 10.3 and for 11)
    OpenSUSE Leap 15, KDE5 (plasma 5.16.5, frameworks 5.62, QT 5.13.1)

  7. #7

    Default Re: Help with installing Beryl to OpenSUSE 10.2

    Okay, with konqueror it didn't work for some reason so I typed this in on Terminal instead: cat /etc/SuSE-release

    These are the results:
    SUSE Linux Enterprise Desktop 10 (i586)
    VERSION = 10
    PATCHLEVEL = 1

    What do I do to get compiz-fusion?

  8. #8
    Join Date
    Jun 2008
    Location
    Concord, California
    Posts
    262

    Default Re: Help with installing Beryl to OpenSUSE 10.2

    Your using the Enterprise desktop version 10. This Novell's business class Suse Linux desktop. It is not the same as opensuse.

    As far as I know those don't work with the opensuse repos. They have their own repositories. I don't know where those are or weather beryl/compiz will work with it. It should work with it, but I won't guarantee that it will.

    There is more information here

    A bump for the guys with SLED knowledge...
    OpenSUSE Leap 15, KDE5 (plasma 5.16.5, frameworks 5.62, QT 5.13.1)

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: Help with installing Beryl to OpenSUSE 10.2

    Quote Originally Posted by cybertaz
    Your using the Enterprise desktop version 10. This Novell's business
    class Suse Linux desktop. It is not the same as opensuse.

    As far as I know those don't work with the opensuse repos. They have
    their own repositories. I don't know where those are or weather
    beryl/compiz will work with it. It should work with it, but I won't
    guarantee that it will.

    There is more information 'here'
    (http://www.novell.com/products/desktop/)

    A bump for the guys with SLED knowledge...
    Hi
    You may wish to upgrade to SP2, but it will still be compiz 0.4.0.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 16:37, 1 user, load average: 0.23, 0.31, 0.26
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •