Results 1 to 6 of 6

Thread: Pure-Ftp Trouble

  1. #1
    Ank3n NNTP User

    Default Pure-Ftp Trouble

    Hello Everyone,
    Hope somebody can help me setup my LAN ftp. I've chosen pure-ftp, but I have hard time configuting it. I can telnet to the ftp port (21) and have the welcome banner, but when I use the users that I created for ftp, I'm getting "Error 530 user cannot login".

    I tried to paste my /etc/pure-ftp/pure-ftpd.conf file, but it seems that we are limited to 10000 characters. Please let me know how i could share my config file.
    BTW, I've read http://forums.opensuse.org/applicati...-pure-ftpd.htm, but that did not help.

    I'm running OpenSuSE 10.3


    Thanks,

    Ank3n!

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Pure-Ftp Trouble

    Ank3n wrote:
    > I can telnet to the ftp port (21) and
    > have the welcome banner, but when I use the users that I created for
    > ftp, I'm getting "Error 530 user cannot login".


    maybe this is a stupid question, but: You say to telnet to the ftp port, what
    happens if you FTP to the port, like:

    ftp YourDomain.com:21

    and then respond to the sign in prompts?

    or, try with your browser:

    ftp://[user[assword]@]host[ort]
    ftp://me:myPass@yourDomain.com:21

    for other ideas, see man ftp

    --
    see caveat: http://tinyurl.com/6aagco
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE 3.5.7, SUSE
    Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  3. #3
    Ank3n NNTP User

    Default Re: Pure-Ftp Trouble

    Quote Originally Posted by DenverD View Post
    Ank3n wrote:[color=blue]

    maybe this is a stupid question, but: You say to telnet to the ftp port, what
    happens if you FTP to the port, like:

    ftp YourDomain.com:21

    and then respond to the sign in prompts?
    Yep, here is the output of what I get:

    220-Welcome to Pure-FTPd.
    220-You are user number 1 of 10 allowed.
    220-This is a private system - No anonymous login
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    Name (localhost:anken): user_ftp
    331 User user_ftp OK. Password required
    Password:
    530 Login authentication failed
    ftp: Login failed.
    ftp>

    I already created user_ftp using pure-ftpd command line. The password is correct.

    Same result using a browser or a ftp client.

    Thanks for the reply.

  4. #4
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Pure-Ftp Trouble

    On 09/25/2008 Ank3n wrote:
    > I tried to paste my /etc/pure-ftp/pure-ftpd.conf file, but it seems
    > that we are limited to 10000 characters. Please let me know how i
    > could share my config file.


    Post only the relevant stuff, i.e., remove the comments.

    Uwe

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Pure-Ftp Trouble

    > ftp: Login failed.

    i'm out of ideas except:

    1. (i'm using the assumption that maybe you made a format mistake in the
    password area of the config, so) try setting the password for _one_ test user to
    nothing/blank/zip/nada and see if that test user can then login just by giving
    the ID and an "Enter" key stroke at the request for password..

    2. or, try (temporarily) to allow anonymous login--if that works i'd guess the
    rest of your non-authentication required config is super...if not, then you have
    lots of config work to do..

    3. i'm happy you didn't post a >10,000 character config file..

    4. a search (within the forum and google) for previous threads with the term
    "pure-ftpd" in the subject line turns up the FACT that more than just you have
    had trouble setting up a working server...i've not tried it myself and wish you
    good luck...and, suggest your luck will increase directly proportional to the
    amount of time you spend reading the man/info pages and those previous
    threads/hits, see:
    a. man pure-ftpd
    b. info pure-ftpd
    b. http://forums.opensuse.org/search.php?searchid=379443
    c. http://www.google.dk/search?q=pure-ftp+problems

    --
    see caveat: http://tinyurl.com/6aagco
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE 3.5.7, SUSE
    Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Pure-Ftp Trouble

    Usually these ftp daemons use pam for authentication. Check in /var/log/messages that pam is being invoked. If it maybe you have not got the name of the service correct in /etc/pam.d. If it is being invoked, then you also have to check that it is using the right encryption method that matches /etc/shadow.

    Sorry I can't offer you more details. I haven't used pure-ftpd for a while, I've been using vsftpd.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •