Results 1 to 4 of 4

Thread: suse 11 rpm dependency problem

  1. #1
    aryasoumen NNTP User

    Default suse 11 rpm dependency problem

    I was trying to install realplayer from RealPlayer11GOLD.rpm in suse11.

    i used this command:
    rpm -ivh RealPlayer11GOLD.rpm

    The following error i got !!//forums.opensuse.org/images/smiliesnew/shock.png
    ##
    error: Failed dependencies:
    lsb >= 3.1 is needed by RealPlayer-11.0.0.4028-20080225.i586
    This s/w got installed in suse 10.3 properly.
    Looking for suggestions !!

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,524
    Blog Entries
    15

    Default Re: suse 11 rpm dependency problem

    Quote Originally Posted by aryasoumen
    I was trying to install realplayer from RealPlayer11GOLD.rpm in suse11.

    i used this command:
    rpm -ivh RealPlayer11GOLD.rpm

    The following error i got
    !!//forums.opensuse.org/images/smiliesnew/shock.png
    ##
    error: Failed dependencies:
    lsb >= 3.1 is needed by RealPlayer-11.0.0.4028-20080225.i586
    This s/w got installed in suse 10.3 properly.
    Looking for suggestions !!
    Hi
    lsb is not installed by default. Install it via YaST or zypper

    Code:
    sudo zypper in lsb
    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 18:40, 1 user, load average: 0.02, 0.01, 0.08
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  3. #3
    Join Date
    Jun 2008
    Location
    Cleveland, TN USA
    Posts
    412

    Default Re: suse 11 rpm dependency problem

    Malcolm wrote:

    >
    Quote Originally Posted by aryasoumen
    > I was trying to install realplayer from RealPlayer11GOLD.rpm in suse11.
    >
    > i used this command:
    > rpm -ivh RealPlayer11GOLD.rpm
    >
    > The following error i got
    > !!//forums.opensuse.org/images/smiliesnew/shock.png
    > ##
    > error: Failed dependencies:
    > lsb >= 3.1 is needed by RealPlayer-11.0.0.4028-20080225.i586
    > This s/w got installed in suse 10.3 properly.
    > Looking for suggestions !!
    >
    > Hi
    > lsb is not installed by default. Install it via YaST or zypper
    >
    >
    Code:
    > sudo zypper in lsb
    >
    >

    Not sure if this works, but you can try to install the local RPM and the dependencies with zypper

    ---
    sudo zypper in ./RealPlayer11GOLD.rpm
    ---

    That should have zypper install Real Player and lsb along with any other dependencies. Of course this is just a thought and I have not actually tried it.
    --
    "We must plan for freedom, and not only for security, if for no other reason than only freedom can make security more secure." Karl Popper

  4. #4
    aryasoumen NNTP User

    Default Re: suse 11 rpm dependency problem

    Thanks a lot.

    Soumen

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •