Results 1 to 6 of 6

Thread: Virtualbox 2.0.2 (mount usbfs)

  1. #1
    Join Date
    Jul 2008
    Location
    Poland
    Posts
    260

    Default Virtualbox 2.0.2 (mount usbfs)

    I got installed Virtualbox 2.0.2 (Sun) and I had to add "mount usbfs" to /etc/init.d/boot.local to enable usb support, I did it by editing that file in gedit as root.
    My question is have I do in right? Shouldn't I make this by some YAST applet? But I didn't find a proper for changing boot.local file.
    Anyone can explain me?

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Virtualbox 2.0.2 (mount usbfs)

    Yes you did fine, although as usual there are probably half a dozen other ways to get to the same goal. VBox is a third-party program. OpenSUSE as distributed has no use for usbfs, but of course the capability is there in Linux.

    There are far far more things you can do in Linux that are not supported in YaST. And that's part of the fun.

  3. #3
    Join Date
    Jul 2008
    Location
    Poland
    Posts
    260

    Default Re: Virtualbox 2.0.2 (mount usbfs)

    Thanks for answer

  4. #4
    millhouse513 NNTP User

    Default Re: Virtualbox 2.0.2 (mount usbfs)

    Thanks for the answer! That did the trick!

  5. #5
    leving NNTP User

    Thumbs up Re: Virtualbox 2.0.2 (mount usbfs)

    Quote Originally Posted by rozbarwinek View Post
    I got installed Virtualbox 2.0.2 (Sun) and I had to add "mount usbfs" to /etc/init.d/boot.local to enable usb support, I did it by editing that file in gedit as root.
    My question is have I do in right? Shouldn't I make this by some YAST applet? But I didn't find a proper for changing boot.local file.
    Anyone can explain me?
    hi try this "mount -t usbfs usbfs /proc/bus/usb"

  6. #6
    Join Date
    Jun 2008
    Location
    U.K.
    Posts
    119

    Default Re: Virtualbox 2.0.2 (mount usbfs)

    Hi,

    mount -t

    That did it for me too. Thanks for the info.

    I have the correct entry in fstab, but its not getting auto mounted for some reason.

    I'm happy to do a mount -t for the moment, but there must be a way for this to happen when the usb device is plugged in.

    Cheers


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •