Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Wireless not working

  1. #1

    Unhappy Wireless not working

    Hello, I am new on this and this is my first problem. I can not connect to the wireless network. I was in the administrator and the system is recognizing the wireless card, I can see the mac address, the activating option, and the IP address option; nevertheless, the led on my laptop that should be blue when the wireless card is activated is in red (which normally in windows means the card is not activated). I check the activation in the grey globe icon and the wireless card is supposed to be activated. I set up a network and then the grey globe becomes a kind of rotating star but the firefox never get connected.
    Any help? maybe the card is not really activated since the indicating led is red? How can I be sure the card is activated?
    Thanks and regards,
    Ibrahim

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Wireless not working

    My car doesn't start.

    That statement is as useful for you to fix my car as the info you gave
    us about your wireless. All we know is that your driver is loaded.

    Please run the command '/sbin/lspci -nnv' and post the first two lines
    of the output that describes your wireless. That way we will know what
    device you have. In addition, you should check the output of the
    'dmesg' command to see if it has any error messages, such as firmware
    not being loaded, etc.

    You should also read the stickies at the start of this forum.

    Larry

  3. #3

    Default Re: Wireless not working

    Well, now I two questions and many reports. First question: How can I interchange a file between the Linux partitions and the Windows partitions; second question: please see the reports in accordance to your advisement, my reports is especially different to what you posted on the last two commands and I think is good to say that the indicating LED for the wlan is still red (it should be blue). What is happening, how can I solved it?? thanks and regards, Ibrahim.

    /sbin/lspci

    01:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (Rev 01)

    /sbin/lspci -n
    01:00.1 0280: 14e4: 4311 (Rev 01)
    b43-phy0: Broadcom 4311 wlan found
    phy0: Selected rate control algorithm: PID
    driver loaded
    [Fedoes: PMIR ID: FW13
    ieee1394: host added: ID: BUS [0-00:1023] GUID [07e40a00a39b5004)

    /usr/sbin/iwconfig
    wlan0 IEEE 802.11 ESS ID:""
    Mode: Managed channel 0 AP: Not associated
    Tx power= 0dbm
    Retry min limit: 7 RTS th: off Fragment th= 2352B
    Link quality: 0 Signal level:0 Noise Level:0
    Rx invalid nwid: 0 Rx invalid cript: 0 Rx invalid frag: 0
    Tx excesive retries: 0 invalid misc: 0 missded beacom: 0

    sudo /usr/sbin/iwlist scan
    Lo interface doesn't support scan
    eth0 interface doesn't support scan
    wmaster0 interface doesn't support scan
    wlan0 interface doesn't support scan

    It is evident that is not communicating with the AP; why???

  4. #4

    Default Re: Wireless not working

    Ok, I finally found a problem with the firmware. Now I must install the firmware; the first line of the error message told me b43/ucode5.fw then it said that I should download the firmware and install it from

    http://linuxwireless.org/en/users/dr...devicefirmware.

    I searched for the Broadcom firmwares and I found this page for b43 firmware installation

    b43 - Linux Wireless

    The first problem is that my laptop which is a HP Pavilion dv2000 is not in the available devices list

    Nevertheless, probably the b43legacy could work.

    The second problem, it says I should have an internet connection (which I have not because I am still dealing with the card) to execute the commands in the following link

    b43 - Linux Wireless

    So, what can I do??? I am working from Windows but I am trying to go to Linux, I must find the way to install the firmware offline; also I need to know the opensuse 11 firmware location, the article says it is normally /lib/firmware. Is this the one in OpenSUSE???

    Any help is highly appreciated...

  5. #5

    Default Re: Wireless not working

    P.D. My car's still not running...

  6. #6

    Default Re: Wireless not working

    Ok, another problem is that I am not familiarized with the Unix commands. I have downloaded the files b43-fwcutter-011.tar.bz2 and wl_apsta-3.130.20.0.o. Nevertheless I do not know how to execute all the following commands (that take the files from the internet) having the files in the hard disk. Can I do this using the GUI? how? I am using KDE4

    Thanks a lot, I am sorry but I am really new in this...

    wget http://bu3sch.de/b43/fwcutter/b43-fwcutter-011.tar.bz2
    tar xjf b43-fwcutter-011.tar.bz2
    cd b43-fwcutter-011
    make
    cd ..
    export FIRMWARE_INSTALL_DIR="/lib/firmware"
    wget http://downloads.openwrt.org/sources...a-3.130.20.0.o
    sudo ./b43-fwcutter-011/b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta-3.130.20.0.o

  7. #7
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Wireless not working

    That was why we needed to have the output of lspci. Now that we know
    that you have Broadcom hardware, my next request would have been to
    get you to use dmesg to look at any b43 messages.

    In the stickies at the beginning of this forum is one entitled
    "Additional Wireless Bits". It has the instructions on how to install
    firmware when you do not have an Internet connection when running Linux.

    If your Windows file system is NTFS, you can mount it using ntfs-3g to
    make it read/write.

    Larry

  8. #8
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Wireless not working

    No, the GUI won't work for you. Some tasks are not worth the effort of
    writing a GUI as they only need to be done once, and only a small
    fraction of the users ever need to do it. If all such things had a GUI
    front-end and were included in a distro, you would need a 3 TB disk
    just to load the OS.

    Do you understand how a GUI system works? Do you know about callbacks,
    etc. Have you ever done any programming? You don't have to know how or
    why a set of console commands work. All you have to do is open a
    terminal and copy/paste or retype those commands. The programs that
    are used will do their thing and your firmware will be installed.

    Did you read the sticky that I referred you to earlier? The reason I
    sent you there is that the command sequence you got from the Linux
    Wireless site also downloads and builds the fwcutter program, whereas
    openSUSE 11.0 already has that available. That is why I simplified the
    commands listed in the sticky.

    I put a lot of effort into helping on these forums. The one thing I
    DEMAND is that you read what I write, and do what I say!!!!!!!!!

    Larry



  9. #9

    Default Re: Wireless not working

    Larry, you stole my auto mechanic analogy!

  10. #10

    Default Re: Wireless not working

    Well my dear friend, you know what are you talking about. I fulfilled your demands and now I am writing this surfing the internet from Linux. Thanks a lot.

    I think you should not think that people like me do not estimate your time and effort for helping us, so thanks again for helping me to start my car.

    Now, I look for mounting procedures int he OpenSUSE help, but I could not find any. If you could give me some light, I will thank you one more time.

    Thanks a lot,
    Ibrahim

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •