Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp'

  1. #1

    Default OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp'

    I just updated Compiz from 0.7.6 to 0.7.8 and now I get the following error when I try to start Compiz:
    Code:
    compiz-manager --replace
    Checking for Xgl: present. 
    Checking for nVidia: not present. 
    Checking for Xgl: present. 
    Enabling Xgl with nVidia drivers...
    Enabling Xgl with fglrx ATi drivers...
    4009
    /usr/bin/compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
    /usr/bin/compiz (core) - Error: Plugin 'core' has ABI version '20080828', expected ABI version '20080424'.
    
    /usr/bin/compiz (ccp) - Error: InitObject failed
    /usr/bin/compiz (core) - Error: Couldn't activate plugin 'ccp'
    What should I do to get Compiz working again?

  2. #2

    Default Re: OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp

    Dear Suse maintainers,

    I posted this question in the Compiz forum too, and from their reply I have come to suspect that the problem almost certainly lies in the fact that libcompizconfig is still of version 0.7.6 where version 0.7.8 is required. But libcompizconfig-0.7.8 does not exist (yet). So:

    1. Could you, in the future, not upgrade compiz and gnome-compiz to a higher version before upgrading libcompizconfig? OR:
    2. Set the proper dependency between compiz and libcompizconfig so the package manager will not upgrade compiz without libcompizconfig? OR:
    3. Not delete the old compiz version completely from RPM Search? Because now it is impossible to downgrade to a working Compiz configuration!

    I use Suse's repository for my Compiz packages, being: Index of /repositories/X11:/XGL/openSUSE_10.3. I hope you will solve this issue very soon.

    Beste regards, SuseUser001

  3. #3

    Default Re: OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp

    Does nobody else have this problem? After an automatic Yast update?

    P.S. Tried to file a bug report...
    I use OpenSuse 10.3.

  4. #4

    Default Re: OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp

    Quote Originally Posted by suseuser001 View Post
    Does nobody else have this problem? After an automatic Yast update?

    P.S. Tried to file a bug report...
    Yes,I have same problem as you.With this diferent,so I am using AIGLX and this time is imposible for me to switch of malfunction Compiz.

  5. #5

    Default Re: OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp

    Quote Originally Posted by milanl View Post
    Yes,I have same problem as you.With this diferent,so I am using AIGLX and this time is imposible for me to switch of malfunction Compiz.
    If you try to start Compiz from a terminal with the command: "compiz-manager --replace", do you get the same error as me?
    I use OpenSuse 10.3.

  6. #6

    Default Re: OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp

    MilanL: I saw your reply at Suse's bugzilla. You indeed get the same error as me.
    I use OpenSuse 10.3.

  7. #7

    Default Re: OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp

    Ha ha. Despite no reply whatsoever from Suse to this thread or the bug, I noticed that as of the Compiz repository is completely empty! So something most definitely IS happening....
    I use OpenSuse 10.3.

  8. #8

    Default Re: OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp

    Yes I thik that same:
    milanl@linux-pxxd:~> compiz-manager --replace
    Checking for Xgl: not present.
    Detected PCI ID for VGA: 01:00.0 Class 0300: 10de:0392 (rev a1) (prog-if 00 [VGA])
    Checking for texture_from_pixmap: present.
    Checking for non power of two support: present.
    Checking for Composite extension: present.
    Comparing resolution (1280x1024) to maximum 3D texture size (4096): Passed.
    Checking for nVidia: present.
    Checking for FBConfig: present.
    Checking for Xgl: not present.
    4357
    /usr/bin/compiz (core) - Error: Plugin 'core' has ABI version '20080828', expected ABI version '20080424'.

    /usr/bin/compiz (ccp) - Error: InitObject failed
    /usr/bin/compiz (core) - Error: Couldn't activate plugin 'ccp'


    Just diferent is in XGL.I using AIGLX.But problem still same.OS is OpenSuse 10.3 x86-64 too.

  9. #9

    Default Re: OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp

    Second day that One Click Install (OCI) does not work (broken link) and that the Compiz repository is completely empty....

    Does anybody know if this problem has been picked up yet? And who manages the OpenSuse's Compiz repository: a volunteer, or Novell themselves? Who can I contact about this?

    Or is there another Compiz repository and has the one that I use and that OCI uses been discontinued?

    This is getting weird....
    I use OpenSuse 10.3.

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,864
    Blog Entries
    15

    Default Re: OpenSuse 10.3 Compiz 0.7.8 couldn't activate plugin 'ccp'

    Quote Originally Posted by suseuser001
    Second day that One Click Install (OCI) does not work (broken link) and
    that the Compiz repository is completely empty....

    Does anybody know if this problem has been picked up yet? And who
    manages the OpenSuse's Compiz repository: a volunteer, or Novell
    themselves? Who can I contact about this?

    Or is there another Compiz repository and has the one that I use and
    that OCI uses been discontinued?

    This is getting weird....
    Hi
    I only see 0.7.6 in the 10.3 repo?
    http://download.opensuse.org/repositories/X11:/XGL/
    0.7.8 is in the 11.0

    It may the mirror your being redirected to is the issue.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 1:36, 1 user, load average: 0.13, 0.10, 0.13
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •