Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Little test. If you use KDE3/4 from OBS try it.

  1. #1

    Default Little test. If you use KDE3/4 from OBS try it.

    Everybody can test it, but I'm specially interested in KDE:KDE3 and KDE:KDE4:Factory:Desktop results.

    To see the effect of bug #420488. Just run
    LC_ALL=C zypper search --details '*' | grep '(System Packages)'
    and paste the result here.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Little test. If you use KDE3/4 from OBS try it.

    > paste the result here

    :~> LC_ALL=C zypper search --details '*' | grep '(System Packages)'
    Unknown option --details

    :~> zypper --version
    zypper 0.8.26

    surprised?

    --
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  3. #3

    Default Re: Little test. If you use KDE3/4 from OBS try it.

    Quote Originally Posted by DenverD View Post
    :~> LC_ALL=C zypper search --details '*' | grep '(System Packages)'
    Unknown option --details
    Looks like a new option in 11.0 (zypper-0.11.10-0.2). I don't know how to obtain the list of installed packages not available in any repo with 10.3.

  4. #4
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: Little test. If you use KDE3/4 from OBS try it.

    Code:
    i | VMwareWorkstation                                      | package    | 6.0.5-109488                      | x86_64 | (System Packages)
    i | agfa-fonts                                             | package    | 2003.03.19-131.1                  | noarch | (System Packages)
    i | akonadi-runtime                                        | package    | 1.0.0-2.9                         | x86_64 | (System Packages)
    i | amaya_wx                                               | package    | 10.0-1                            | i386   | (System Packages)
    i | libkdcraw5                                             | package    | 4.1.1-28.12                       | x86_64 | (System Packages)
    i | libkexiv2-6                                            | package    | 4.1.1-28.8                        | x86_64 | (System Packages)
    i | libraptor1                                             | package    | 1.4.18-2.1                        | x86_64 | (System Packages)
    i | libredland0                                            | package    | 1.0.8-2.1                         | x86_64 | (System Packages)
    i | libxine1                                               | package    | 1.1.15-0.pm.1                     | x86_64 | (System Packages)
    i | nvlan-sles10.1                                         | package    | 6:0.62-1.25                       | x86_64 | (System Packages)
    i | nvlan-suse10.2                                         | package    | 6:0.62-1.23                       | x86_64 | (System Packages)
    i | soprano-backend-redland                                | package    | 2.1-11.7                          | x86_64 | (System Packages)
    i | xvid                                                   | package    | 1.1.3-0.pm.0                      | x86_64 | (System Packages)
    Last edited by geoffro; 20-Sep-2008 at 06:36.
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  5. #5

    Default Re: Little test. If you use KDE3/4 from OBS try it.

    Code:
    i | akonadi-runtime                                   | package    | 1.0.0-23.5                        | x86_64 | (System Packages)                                                                                                     
    i | compiz-emerald                                    | package    | 0.7.6-2.4                         | x86_64 | (System Packages)                                                                                                     
    i | compiz-fusion-plugins-extra                       | package    | 0.7.6-10.4                        | x86_64 | (System Packages)                                                                                                     
    i | compiz-fusion-plugins-main                        | package    | 0.7.6-3.4                         | x86_64 | (System Packages)                                                                                                     
    i | compiz-fusion-plugins-unsupported                 | package    | 0.7.6-1.12                        | x86_64 | (System Packages)                                                                                                     
    i | compiz-kde4                                       | package    | 0.7.6-20.1                        | x86_64 | (System Packages)
    i | compizconfig-settings-manager                     | package    | 0.7.6-2.6                         | x86_64 | (System Packages)
    i | kdebase4-runtime                                  | package    | 4.1.1-45.1                        | x86_64 | (System Packages)
    i | libcompizconfig                                   | package    | 0.7.6-2.4                         | x86_64 | (System Packages)
    i | phonon                                            | package    | 4.2.0-11.4                        | x86_64 | (System Packages)
    i | python-compizconfig                               | package    | 0.7.6-2.4                         | x86_64 | (System Packages)
    i | release-notes-openSUSE                            | package    | 11.0.7-0.2                        | noarch | (System Packages)
    i | simple-ccsm                                       | package    | 0.7.6-5.1                         | x86_64 | (System Packages)
    i | xvid                                              | package    | 1.1.3-0.pm.0                      | x86_64 | (System Packages)

  6. #6

    Default Re: Little test. If you use KDE3/4 from OBS try it.

    Not what I was expecting. How do you update your system?

    i | VMwareWorkstation | package | 6.0.5-109488 | x86_64 | (System Packages) <-- Manually installed, I suppose, ok
    i | agfa-fonts | package | 2003.03.19-131.1 | noarch | (System Packages) <-- Only available in the DVD, ok
    i | akonadi-runtime | package | 1.0.0-2.9 | x86_64 | (System Packages) <-- Why hasn't been updated to akonadi-runtime-1.0.0-26.2???
    i | amaya_wx | package | 10.0-1 | i386 | (System Packages) <-- No idea what it is, ok
    i | libkdcraw5 | package | 4.1.1-28.12 | x86_64 | (System Packages) <-- There is a newer libkdcraw6-4.1.1-42.8, but hasn't been updated because of package problem, ok.
    i | libkexiv2-6 | package | 4.1.1-28.8 | x86_64 | (System Packages) <-- libkexiv2-7-4.1.1-42.8, another package problem, ok.
    i | libraptor1 | package | 1.4.18-2.1 | x86_64 | (System Packages) <-- Why hasn't been updated to libraptor1-1.4.18-32.1???
    i | libredland0 | package | 1.0.8-2.1 | x86_64 | (System Packages) <-- Why hasn't been updated to libredland0-1.0.8-2.3???
    i | libxine1 | package | 1.1.15-0.pm.1 | x86_64 | (System Packages) <-- Why hasn't been updated to libxine1-1.1.15-44.pm.0???
    i | nvlan-sles10.1 | package | 6:0.62-1.25 | x86_64 | (System Packages) <-- Manually installed, I suppose, ok
    i | nvlan-suse10.2 | package | 6:0.62-1.23 | x86_64 | (System Packages) <-- Manually installed, I suppose, ok
    i | soprano-backend-redland | package | 2.1-11.7 | x86_64 | (System Packages) <-- Why hasn't been updated to soprano-backend-redland-2.1.1-17.4???
    i | xvid | package | 1.1.3-0.pm.0 | x86_64 | (System Packages) <-- You can remove this one, now it's called libxvidcore4. Packaging problem, ok

    I was expecting you to have newer versions than the ones available in the repos, not the other way around

  7. #7

    Default Re: Little test. If you use KDE3/4 from OBS try it.

    Code:
    i | agfa-fonts                                        | package    | 2003.03.19-131.1                  | noarch | (System Packages)
    i | akonadi-runtime                                   | package    | 1.0.0-23.5                        | i586   | (System Packages)
    i | curl                                              | package    | 7.19.0-7.1                        | i586   | (System Packages)
    i | hicolor-icon-theme                                | package    | 0.10-81.1                         | noarch | (System Packages)
    i | kde4-kdm-branding-openSUSE                        | package    | 11.1-21.33                        | i586   | (System Packages)
    i | kde4-kio_sysinfo                                  | package    | 11.1-21.33                        | i586   | (System Packages)
    i | kde4-kio_sysinfo-branding-openSUSE                | package    | 11.1-21.33                        | i586   | (System Packages)
    i | kde4-plasma-addons                                | package    | 4.1.1-26.25                       | i586   | (System Packages)
    i | kde4-yakuake                                      | package    | 4.0.84.svn825099-1.1              | i586   | (System Packages)
    i | kdebase4-openSUSE                                 | package    | 11.1-21.33                        | i586   | (System Packages)
    i | kdebase4-openSUSE-lang                            | package    | 11.1-21.33                        | i586   | (System Packages)
    i | kdebase4-runtime                                  | package    | 4.1.1-40.2                        | i586   | (System Packages)
    i | kdebase4-workspace-branding-openSUSE              | package    | 11.1-21.33                        | i586   | (System Packages)
    i | kdelibs4                                          | package    | 4.1.1-33.1                        | i586   | (System Packages)
    i | ktorrent3                                         | package    | 3.0.2-0.pm.5                      | i586   | (System Packages)
    i | ktorrent3-lang                                    | package    | 3.0.2-0.pm.5                      | i586   | (System Packages)
    i | libQtWebKit4                                      | package    | 4.4.1-30.1                        | i586   | (System Packages)
    i | libakonadiprotocolinternals0                      | package    | 0.82.0-5.3                        | i586   | (System Packages)
    i | libcurl-devel                                     | package    | 7.19.0-7.1                        | i586   | (System Packages)
    i | libcurl4                                          | package    | 7.19.0-7.1                        | i586   | (System Packages)
    i | libkdcraw5                                        | package    | 4.1.1-28.6                        | i586   | (System Packages)
    i | libkexiv2-6                                       | package    | 4.1.1-28.6                        | i586   | (System Packages)
    i | libqca2                                           | package    | 2.0.0-112.3                       | i586   | (System Packages)
    i | libqt4                                            | package    | 4.4.1-28.1                        | i586   | (System Packages)
    i | libqt4-qt3support                                 | package    | 4.4.1-28.1                        | i586   | (System Packages)
    i | libqt4-sql                                        | package    | 4.4.1-28.1                        | i586   | (System Packages)
    i | libqt4-sql-mysql                                  | package    | 4.4.1-30.1                        | i586   | (System Packages)
    i | libqt4-sql-postgresql                             | package    | 4.4.1-30.1                        | i586   | (System Packages)
    i | libqt4-sql-sqlite                                 | package    | 4.4.1-28.1                        | i586   | (System Packages)
    i | libqt4-x11                                        | package    | 4.4.1-28.1                        | i586   | (System Packages)
    i | libquicktime1                                     | package    | 1.0.2-100.pm.1                    | i586   | (System Packages)
    i | libstrigi0                                        | package    | 0.6.0-16.1                        | i586   | (System Packages)
    i | libxcrypt                                         | package    | 3.0.1-2.1                         | i586   | (System Packages)
    i | master-boot-code                                  | package    | 1.14-71.1                         | i586   | (System Packages)
    i | phonon                                            | package    | 4.2.0-11.4                        | i586   | (System Packages)
    i | plasma-theme-aya                                  | package    | 4.1.1-26.25                       | i586   | (System Packages)
    i | python                                            | package    | 2.5.2-92.1                        | i586   | (System Packages)
    i | python-devel                                      | package    | 2.5.2-92.1                        | i586   | (System Packages)
    i | python-tk                                         | package    | 2.5.2-92.1                        | i586   | (System Packages)
    i | python-xml                                        | package    | 2.5.2-92.1                        | i586   | (System Packages)
    i | smartlink-softmodem                               | package    | 2.9.10-203.1                      | i586   | (System Packages)
    i | xvid                                              | package    | 1.1.3-0.pm.0                      | i586   | (System Packages)

  8. #8

    Default Re: Little test. If you use KDE3/4 from OBS try it.

    hum.. after a second "zypper up -t package", libqt4* packages have been correctly installed.

  9. #9

    Default Re: Little test. If you use KDE3/4 from OBS try it.

    Quote Originally Posted by Spyhawk View Post
    i | kde4-plasma-addons | package | 4.1.1-26.25 | i586 | (System Packages)
    These are the kind of problems I was expecting. Your package is from "2008-09-12 16:48:30". The latest version is from "2008-09-20 14:34:48", but it's version is 4.1.1-15.5.
    Since 26.25 > 15.5 your package isn't being updated.

    In general the list should be empty. Only if you manually install a package downloaded from a website instead of a repository, or if you install a package from a repository and then remove that repository a package could be listed here.
    90% of the cases in this topic shouldn't exists. For example, Spyhawk has ktorrent3-3.0.2-0.pm.5. The thing is his package is wrongly named, I reported the bug to Packman and now it's just ktorrent and the latest version is ktorrent-3.1.2-0.pm.1. His version is outdated and not available in Packman anymore.
    So, in general you should try to empty that list manually installing the latest versions.

  10. #10

    Default Re: Little test. If you use KDE3/4 from OBS try it.

    Great thx to point this tip to all of us
    A nice way to know how to improve suse'packages.

    I've saw several "strange" things with package in the past, but was unable to know what's the problem, or which of these packages were crappy.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •