Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Copying to NTFS Partition

  1. #1
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Posts
    184

    Default Copying to NTFS Partition

    I usually have to use Konquerer super user mode to copy files to an NTFS partition. It would be so much easier if I could copy to said partitions without having to log into root.

    Is there a way?

  2. #2
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Copying to NTFS Partition

    if you have ntfs-3g installed & configured,i believe you can do this,not that i know how,don't use ntfs filesystem or anything windowish. Only windows in my house are the ones i look out of

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  3. #3
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Posts
    184

    Default Re: Copying to NTFS Partition

    Quote Originally Posted by deltaflyer44 View Post
    if you have ntfs-3g installed & configured,i believe you can do this,not that i know how,don't use ntfs filesystem or anything windowish. Only windows in my house are the ones i look out of

    Andy
    The ntfs-3g driver is installed by default. While it does allow you read/write ntfs access, you still need to be logged in as root to be able to write to an ntfs partition.

  4. #4
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Copying to NTFS Partition

    I have some similar problem before a few moths ago. I'm changed some fstab options, like umask. Go to YaST -> System -> Partitioner, select the ntfs disk, and click to Edit. Here go to fstab options, and set the Arbitrary Option Value to
    Code:
    users,gid=users,umask=0002
    (Of course if you have something different here, back it up to a text file, or something.)

    Maybe it helps
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  5. #5
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Posts
    184

    Default Re: Copying to NTFS Partition

    Quote Originally Posted by ram88 View Post
    I have some similar problem before a few moths ago. I'm changed some fstab options, like umask. Go to YaST -> System -> Partitioner, select the ntfs disk, and click to Edit. Here go to fstab options, and set the Arbitrary Option Value to
    Code:
    users,gid=users,umask=0002
    (Of course if you have something different here, back it up to a text file, or something.)

    Maybe it helps
    I changed this:

    users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8

    To this:

    users,gid=users,umask=0002,dmask=022,locale=en_GB.UTF-8

    I then tried to paste something but write access wasn't allowed. Within the folder structure of the partition, the permissions options are still greyed out.

    I just noticed something interesting, SuSE is setting the values back to what they were before I made the changes. It appears that I am unable to make the changes stick.

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City, MO
    Posts
    570

    Default Re: Copying to NTFS Partition

    search yast2 for ntfs-config i believe it is the gui for ntfs and it will allow you to setup read-write to your ntfs partitions really easliy

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Copying to NTFS Partition

    It might help to read all the options. Here's some background:
    HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

    This is what should ordinarily be used for internal drives:
    Code:
    /dev/sdax    /path_to/mount_point    ntfs-3g    defaults    0 0
    Of course, change sdax to match your situation

    But if you have an external usb drive you use something different, like read this bit:
    Automounting external (USB) NTFS drives in read-write mode
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  8. #8

    Default Re: Copying to NTFS Partition

    Hi all,
    I am new with Suse.
    But what I want to ask is: how can I open from terminal the fstab file???
    I have tried:
    sudo gedit /etc/fstab but I have to put an other command.
    How can i do that?

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Copying to NTFS Partition

    gnomesu gedit
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  10. #10
    Join Date
    Sep 2008
    Location
    Bangalore, India
    Posts
    365

    Default Re: Copying to NTFS Partition

    It would be so much easier if I could copy to said partitions without having to log into root.
    Try "ntfs-config". Its a little tool which allows you to easily give ntfs partions write permissions. Its available in the repos.

    Note: If "Enable write support" is already checked just uncheck it and check again. It took me hours to figure it out.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •