Results 1 to 4 of 4

Thread: Tomcat 6 broken in OpenSuSE 11?

  1. #1
    PeteNelson NNTP User

    Thumbs down Tomcat 6 broken in OpenSuSE 11?

    I recently installed openSuSE 11 and Tomcat 6.0.16 on a virtual machine to do some testing. As far as I can tell, Tomcat 6 appears to be broken with this release.

    There are a number of problems. It looks like things began to move relative to Tomcat 5.5, but are incomplete.

    The links under /usr/share/tomcat are broken in a couple of places. "work" goes to /var/cache/tomcat6, and "temp" goes to /var/cache/tomcat6/temp (which doesn't exist), which is UNDER the work directory ... can that be right?

    The bigger issue I can't get around is the deployment descriptors. There is no longer a "Catalina" directory under /etc/tomcat6, and web applications' META-INF/context.xml files are being ignored.

    Lastly, there is no longer an "rctomcat6", and worse, there does not seem to be a way to make Tomcat run at startup - "chkconfig tomcat6 on" is simply ignored.

    The good news is that all of these things CAN be fixed, and then Tomcat 6 will run. But I would hate to be a new user trying to figure out why Tomcat 6 doesn't work as it should out-of-the-box.

    Here's how I fixed my installation:
    • created /var/cache/tomcat6/work and /var/cache/tomcat6/temp

    • changed the owner of these directories to "tomcat"

    • fixed the related links under /usr/share/tomcat.

    • Created /etc/tomcat6/Catalina

    • changed the owner to Tomcat


    Still have to manually start Tomcat after a reboot. But that works for me, as I am only testing.

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Tomcat 6 broken in OpenSuSE 11?

    I haven't installed tomcat6 myself, but I have installed tomcat5 in previous releases. Are you sure you have installed all the required packages? Sometimes the required files have been moved into another related package. A zypper search tomcat6 returned this:

    | tomcat6 | Apache Servlet/JSP Engine, RI for Serv-> | package
    | tomcat6 | tomcat: fix for directory traversal vu-> | patch
    | tomcat6-admin-webapps | The host-manager and manager web appli-> | package
    | tomcat6-docs-webapp | The docs web application for Apache To-> | package
    | tomcat6-javadoc | Javadoc generated documentation for Ap-> | package
    | tomcat6-jsp-2_1-api | Apache Tomcat JSP API implementation c-> | package
    | tomcat6-lib | Libraries needed to run the Tomcat Web-> | package
    | tomcat6-servlet-2_5-api | Apache Tomcat Servlet API implementati-> | package
    | tomcat6-webapps | The ROOT and examples web applications-> | package
    of which tomcat6-webapps might have the files and directories you want. Also could the init script have been renamed to the generic /etc/init.d/tomcat?

    Somebody else in another thread seem to have had no problems starting up tomcat6 as his problem was with the firewall.

    If those files and scripts are indeed missing, then it would warrant a bug report.

  3. #3
    PeteNelson NNTP User

    Default Re: Tomcat 6 broken in OpenSuSE 11?

    The directories I mentioned should be included with the "tomcat6" package - and I mean that specific package, and not any of the other tomcat6-* packages.

    Tomcat does in fact "run", but you cannot upload files ("temp" is missing), and you can't use context descriptors, because they will not be copied to the correct location (/etc/tomcat6/Catalina does not exist).

    The tomcat6-6.0.16-6.4 package does not function as expected without the alterations I mentioned above.

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Tomcat 6 broken in OpenSuSE 11?

    Ok, that's a serious packaging problem then. Please report it for all of us.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •