Results 1 to 6 of 6

Thread: phpMyAdmin-Configuration

  1. #1
    Join Date
    Sep 2008
    Location
    Germany, Frankfurt am Main
    Posts
    32

    Question phpMyAdmin-Configuration

    I am getting stucked with phpMyAdmin:

    Environment
    • openSUSE 10.3
      (Linux WEB2 2.6.22.18-0.2-default #1 SMP 2008-06-09 13:53:20 +0200 i686 i686 i386 GNU/Linux)
    • Apache 2.2.4
    • MySQL 5.0.45
    • PHP 5.2.6
    • phpMyAdmin 2.11.8.1


    I changed the root-password for the mySQL-database and as I can login to mysql at the shell I know that the credentials are correct.

    I tried to get phpMyAdmin running with the following config.inc.php:
    Code:
    <?php
    /*
     * Generated configuration file
     * Generated by: phpMyAdmin 2.11.8.1 setup script by Michal .iha. <NO@MAIL.PLZ>
     * Version: $Id: setup.php 11423 2008-07-24 17:26:05Z lem9 $
     * Date: Tue, 16 Sep 2008 21:42:33 GMT
     */
    
    /* Servers configuration */
    $i = 0;
    
    /* Server WEB2 (config:root) [1] */
    $i++;
    $cfg['Servers'][$i]['host'] = 'localhost';
    $cfg['Servers'][$i]['extension'] = 'mysqli';
    $cfg['Servers'][$i]['connect_type'] = 'tcp';
    $cfg['Servers'][$i]['compress'] = false;
    $cfg['Servers'][$i]['auth_type'] = 'config';
    $cfg['Servers'][$i]['user'] = 'root';
    $cfg['Servers'][$i]['password'] = 'FOOBAR';
    $cfg['Servers'][$i]['verbose'] = 'WEB2';
    
    /* End of servers configuration */
    ?>
    But when I open phpMyAdmin I always get the following error:
    Code:
    MySQL meldet:  
    #1045 - Access denied for user 'root'@'localhost' (using password: NO)
    I restarted apache several times and tried it with 172.0.0.1 or web2.FOOBAR.local but it does not help. I am not sure, but I think perhaps phpMyAdmin does not use the config.inc.php as the errormessage states no password given.

    The file is stored here:
    /srv/www/htdocs/phpMyAdmin
    -rw-r--r-- 1 root root 702 Sep 16 23:48 config.inc.php


    Thanks for helping me

  2. #2
    VincenzaMaselli NNTP User

    Question Re: phpMyAdmin-Configuration

    Dear all
    I have a similar problem. I can see the login page of phpMyAdmin, but if tray to login I obtain this error:

    #2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

    my configuration file is in /srv/www/htdocs/phpMyAdmin/config and I tried to use it with several combination of parameters.

    Have anyone some suggestions?

  3. #3
    Join Date
    Jun 2008
    Location
    Inzago, Italy
    Posts
    108

    Default Re: phpMyAdmin-Configuration

    Try substituting "localhost" in ['host'] = 'localhost'; with the IP address of the machine.
    OpenSuse 13.1 with KDE 4.11 on Intel I7 930 motherboard Asus P6T SE - RAM 6 Gb
    - video card NVIDIA GT220 1GB - TV card Hauppauge WinTV Nova T stick

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: phpMyAdmin-Configuration

    Make sure that the mysql service is actually running.

  5. #5
    upscope NNTP User

    Default Re: phpMyAdmin-Configuration

    VincenzaMaselli wrote:

    >
    > Dear all
    > I have a similar problem. I can see the login page of phpMyAdmin, but
    > if tray to login I obtain this error:
    >
    > #2002 - The server is not responding (or the local MySQL server's
    > socket is not correctly configured)
    >
    > my configuration file is in /srv/www/htdocs/phpMyAdmin/config and I
    > tried to use it with several combination of parameters.
    >
    > Have anyone some suggestions?
    >

    Are you using blowfish_secret option in Config.inc.php. I found when I
    restored this file from a backup something had changed the blowfish_secret
    word. I was getting the login screen but an error after entering ID and
    password. Putting in secret word again,(same one as originally used) it
    corrected problem.

    Hope this helps.

    --
    Russ
    [openSUSE 11.2 (2.6.31.5-0.1-desktop, x86_64] KDE 4.3.3 release 1, Intel
    Core 2 Dual E7200, 4 GB DDR III, GeForce 8400 GS, 320GB Disc (2)

  6. #6
    Larry Bristol NNTP User

    Default Re: phpMyAdmin-Configuration

    VincenzaMaselli wrote:

    >
    > Dear all
    > I have a similar problem. I can see the login page of phpMyAdmin, but
    > if tray to login I obtain this error:
    >
    > #2002 - The server is not responding (or the local MySQL server's
    > socket is not correctly configured)
    >
    > my configuration file is in /srv/www/htdocs/phpMyAdmin/config and I
    > tried to use it with several combination of parameters.
    >
    > Have anyone some suggestions?


    I got the same error after my initial install of mySql. Did you remember to
    go into YaST->System->System Services (Runlevel) and Enable the mysql
    server?


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •