Results 1 to 3 of 3

Thread: openssh - disable x11 password menu prompt

  1. #1

    Default openssh - disable x11 password menu prompt

    I am using openssh on two different level suse boxes from the command prompt and on one system I get an X11 menu prompt for the password and I want to disable that so I get the prompt on the command line.

    Supposedly from other places I have read that has to do with the env vars of DISPLAY and SSH_ASKPASS.

    On the system where I don't get the prompt:

    ssh -v is: OpenSSH_4.4p1 OpenSSL 0.9.8d 28 Sept 2006
    DISPLAY=:0
    SSH_ASKPASS=/usr/lib/ssh/x11-ssh-askpass

    On the system where I DO get the prompt that I want to get rid of:

    ssh -v is: OpenSSH_4.2p1 OpenSSL 0.9.8a 11 Oct 2005
    DISPLAY=:0.0
    SSH_ASKPASS is not set (tho the /usr/lib/ssh programs do exist)


    I tried setting SSH_ASKPASS to /usr/lib/ssh/x11-ssh-askpass but that didn't get rid of the menu prompt.
    Interestingly, as root on this system I don't get the menu prompt. I compared the env vars from both users but I don't see anything explicit to give me any clues.

    Any suggestions?

  2. #2
    ab@novell.com NNTP User

    Default Re: openssh - disable x11 password menu prompt

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Are you running SSH from the GUI directly or from a terminal window? I
    have never had this prompt show up in the GUI UNLESS I actually loaded
    SSH from the GUI, for example using Alt+F2 and entering 'ssh someBox'.
    If I load it from the command line it never happens.... ever.

    Good luck.





    jrfk2 wrote:
    > I am using openssh on two different level suse boxes from the command
    > prompt and on one system I get an X11 menu prompt for the password and I
    > want to disable that so I get the prompt on the command line.
    >
    > Supposedly from other places I have read that has to do with the env
    > vars of DISPLAY and SSH_ASKPASS.
    >
    > On the system where I don't get the prompt:
    >
    > ssh -v is: OpenSSH_4.4p1 OpenSSL 0.9.8d 28 Sept 2006
    > DISPLAY=:0
    > SSH_ASKPASS=/usr/lib/ssh/x11-ssh-askpass
    >
    > On the system where I DO get the prompt that I want to get rid of:
    >
    > ssh -v is: OpenSSH_4.2p1 OpenSSL 0.9.8a 11 Oct 2005
    > DISPLAY=:0.0
    > SSH_ASKPASS is not set (tho the /usr/lib/ssh programs do exist)
    >
    >
    > I tried setting SSH_ASKPASS to /usr/lib/ssh/x11-ssh-askpass but that
    > didn't get rid of the menu prompt.
    > Interestingly, as root on this system I don't get the menu prompt. I
    > compared the env vars from both users but I don't see anything explicit
    > to give me any clues.
    >
    > Any suggestions?
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIz7HE3s42bA80+9kRAr+RAJ9w+KUv9oo3NmdhLvWkCzDByeycjQCfaJPE
    JCeKn3Qk9BzZDv4JpgKgjL0=
    =QUw0
    -----END PGP SIGNATURE-----

  3. #3

    Default Re: openssh - disable x11 password menu prompt

    I'm running it from the command line .. on both machines .. thats why I am trying to figure out why it shows on one machine and not the other.

    The machine where the menu prompt does show is a modified suse 10, but we can't find anything that is causing the menu prompt to show up ..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •