Results 1 to 7 of 7

Thread: Clock refuses to set

  1. #1
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Clock refuses to set

    I get this message on boot:

    Setting up the hardware clock... Cannot access the Hardware Clock via any known method.
    Use the --debug option to see the details of our search for an access method. failed


    This started a few weeks ago when I was trying to get my internal modem working.

    I'm not sure if this is related, but I also found some problems on the disk and ran reiserfsck which fixed the other odd problems I was having.

    For the modem I installed the driver and also a required alsa sound driver from Linuxant - Company information. The modem never really worked, and of course it also stuffed my sound up.

    I removed those drivers and the alsa thing, and my sound is almost back to normal, although I have to /etc/init.d/alsasound restart in order to get the OSS stuff working properly. But that is another story.

    My main problem at the moment is that my clock is always wrong, I have set the timezone and I can set the time either from the GUI or from the command line, and it stays correct until reboot.

    Then I get that message about the hardware clock.

    I also did a BIOS update around the same time as I was messing with those modem drivers, I've checked in there and there is no setting other than the time and date that I can change.

    The time is set to my local timezone in the BIOS, and it works fine when I boot into the other O/S on this laptop, so I don't think there's anything wrong with the hardware.

    It recommends trying the --debug option but I don't know how to do that.

    Any ideas?

    Thanks

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Clock refuses to set

    Quote Originally Posted by growbag View Post
    I removed those drivers and the alsa thing, and my sound is almost back to normal, although I have to /etc/init.d/alsasound restart in order to get the OSS stuff working properly. But that is another story.
    Does this also work:
    su -c 'rcalsasound restart'
    if so, then in your /etc/init.d/boot.local file, put a line at the end with: rcalsasond restart

    I'm off on vacation for over a week, and so will not be able to follow up on this thread.

    Good luck.

  3. #3
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: Clock refuses to set

    Thanks (yet again) oldcpu, that works a treat for the sound.

    Now I really need to get the system clock working properly.

    It sort of feels like the system is stuck in some sort of timezone problem, "Hardware clock set to UTC" is unchecked in the Yast control panel, and my timezone is set up in there for my correct zone.

    Is there a config file that overrides the settings in there? Maybe I can change that.

    The clock is always 8 hours ahead of the correct time. I recently came back from Europe (...this copy of openSUSE 11 was installed and setup there) and changed the timezone (which coincidentally is an 8 hour difference by the way!), maybe that will give someone a clue as to what is going on?

    Thanks

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Clock refuses to set

    Which desktop are you using?

    Check here too
    Wrong clock in 11.0 - openSUSE Forums
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: Clock refuses to set

    Thanks for the reply caf4926.

    I'm using openSUSE 11, with KDE3 desktop.

    From that other post you gave me, I figured out to run the following command, and here is the result:

    my-laptop:/etc/init.d/boot.d # hwclock --debug
    hwclock from util-linux-ng 2.13.1
    hwclock: Open of /dev/rtc failed, errno=2: No such file or directory.
    No usable clock interface found.
    Cannot access the Hardware Clock via any known method.


    Odd eh?

    Which leads me to believe that there is something missing in /etc/init.d, ie the RTC module is not being loaded. Unfortunately I don't know the name of the module, and modprobe rtc gave nothing.

  6. #6
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: Clock refuses to set

    I just booted from the KDE4.11 liveCD (686), and the clock works perfectly.

    There are some rtc modules loaded.

    lsmod | grep rtc gives:
    rtc_cmos 14752 0
    rtc_core 24860 1 rtc_cmos
    rtc_lib 7040 1 rtc_core

    ....whereas the same command on my normal installation gives nothing.

    How would I go about loading these modules on boot?

  7. #7
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: Clock refuses to set

    OK, I did:

    modprobe rtc_cmos

    ....the module(s) loaded and created /dev/rtc0 (a link to /dev/rtc), and everything seems to work properly after that.

    But now I need that to be done automatically on boot, where should I put that command?

    Also, why would that command have been removed from my boot sequence, and from where would it have been removed?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •