Results 1 to 10 of 10

Thread: SuperKaramba-KDE4

  1. #1

    Question SuperKaramba-KDE4

    okay im complete noob so dont laugh
    can someone plz help me installing Superkaramba-KDE4....
    System:
    Linux 2.6.25.16-0.1-pae i686
    openSUSE 11.0 (i586)
    4.1.2 (KDE 4.1.1 (KDE 4.1 >= 20080828))
    "release 33.1

    When i try to install SuperKaramba-KDE4 with yast i get an error that libxklavier.so.11 is needed but cant be installed....

    #### YaST2 conflicts list - generated 2008-09-14 01:27:27 ####

    nichts bietet libxklavier.so.11 bentigt von kdebase4-workspace-4.1.64-2.3.i586

    [ ] kde4-superkaramba-4.1.64-1.4.i586 nicht installieren
    #### YaST2 conflicts list END ###


    okay tryin to install libxklavier.so.11 with yast libxklavier-3.2-23.i586.rpm following error msg coming up:

    Subprocess failed.Error: RPM failed: error Failed dependencies:
    Libxklavier = 3.5 is needed by (installed) libxklavier-devel-3.5-17.1.i586
    Libxklavier = 3.5 is needed by (installed) libxklavier-3.5-17.1.i586


    im clueless i got libxklavier.so.12 installed a newer version(?) but need libxklavier.so.11?

    thx in advance

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: SuperKaramba-KDE4

    In a terminal as su type:
    zypper se libxklavier

    post result here:
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: SuperKaramba-KDE4

    okay
    linux-r3pb:/> zypper se libxklavier

    S | Name | Zusammenfassung | Typ
    --+-------------------+-------------------------------------------------------+------
    i | libxklavier | Library with X keyboard related functions | Paket
    i | libxklavier-devel | Include Files and Libraries mandatory for Development | Paket
    | libxklavier-doc | Additional Package Documentation for libxklavier | Paket
    i | libxklavier12 | Library with X keyboard related functions | Paket

    done

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: SuperKaramba-KDE4

    you do have libxklavier installed

    but notice your post, you quote:
    tryin to install libxklavier.so.11 with yast libxklavier-3.2-23.i586.rpm
    which is older than
    Libxklavier = 3.5 is needed by (installed) libxklavier-devel-3.5-17.1.i586
    Libxklavier = 3.5 is needed by (installed) libxklavier-3.5-17.1.i586
    In my superkaramba, no such requirement is made in the requires list.

    Which kde4 repo's are you using?
    In a terminal as su
    zypper lr -u
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: SuperKaramba-KDE4

    yer i got libxklavier installed ^^ im a noob not blind well i didnt write it clear... my point is that i got libxklavier.so.12 installed
    but Superkaramba-KDE4 needs libxklavier.so.11.
    Downgrading doesnt work cause it would deinstall nearly anything related with plasma...
    linux-r3pb:~> zypper lr -u

    | httxp://www2.ati.com/suse/11.0 | ATI Repository | Ja | Ja | hxttp://www2.ati.com/suse/11.0
    2 | hxttp://download.opensuse.org/repositories/games/openSUSE_11.0/ | openSUSE BuildService - Spiele | Ja | Ja | htxtp://download.opensuse.org/repositories/games/openSUSE_11.0/
    3 | hxttp://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.0/ | openSUSE BuildService - Wine CVS Pakete | Ja

  6. #6

    Default Re: SuperKaramba-KDE4

    4 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Ja | Nein | cd:///?devices=/dev/sr0
    5 | htxtp://download.opensuse.org/repositories/KDE:/Community/openSUSE_11.0/ | openSUSE BuildService - KDE:Community | Ja | Ja | hxttp://download.opensuse.org/repositories/KDE:/Community/openSUSE_11.0/
    6 | httxp://download.videolan.org/pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | Ja | Ja | hxttp://download.videolan.org/pub/videolan/vlc/SuSE/11.0/
    7 | httxp://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0/ | openSUSE BuildService - KDE4:Factory:Desktop | Ja | Ja | hxttp://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0/
    8 | KDE:KDE4:Community | KDE:KDE4:Community | Ja | Ja | hxttp://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE4_Factory_Desktop/
    9 | httxp://ftp.skynet.be/pub/packman/suse/11.0/ | Packman Repository | Ja | Ja | hxttp://ftp.skynet.be/pub/packman/suse/11.0/
    10 | KDE:Qt | KDE:Qt | Ja | Ja | hxttp://download.opensuse.org/repositories/KDE:/Qt/openSUSE_10.3/
    11 | httxp://download.opensuse.org/repositories/X11:/xfce/openSUSE_11.0/ | openSUSE BuildService - XFCE | Ja | Ja | hxttp://download.opensuse.org/repositories/X11:/xfce/openSUSE_11.0/
    12 | home:Thruth | home:Thruth | Ja | Ja | hxttp://download.opensuse.org/repositories/home:/Thruth/openSUSE_11.0/
    13 | htxtp://download.opensuse.org/repositories/server:/database/openSUSE_11.0/ | openSUSE BuildService - Datenbanken | Ja | Ja | hxttp://download.opensuse.org/repositories/server:/database/openSUSE_11.0/
    14 | httxp://download.opensuse.org/repositories/X11:/XGL/openSUSE_11.0/ | openSUSE BuildService - X11:XGL | Ja | Ja | hxttp://download.opensuse.org/repositories/X11:/XGL/openSUSE_11.0/
    15 | KDE:KDE4:UNSTABLE:Desktop | KDE:KDE4:UNSTABLE:Desktop | Ja | Ja | hxttp://download.opensuse.org/repositories/KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_10.3/
    16 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Ja | Ja | hxttp://download.opensuse.org/update/11.0/
    17 | repo-non-oss | openSUSE-11.0-Non-Oss | Ja | Nein | hxttp://download.opensuse.org/distribution/11.0/repo/non-oss/
    18 | KDE:KDE4:STABLE:Desktop | KDE:KDE4:STABLE:Desktop | Ja | Ja | hxttp://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_10.3/
    19 | htxtp://download.opensuse.org/repositories/KDE:/Backports/openSUSE_11.0/ | openSUSE BuildService - KDE:Backports | Ja | Ja | hxttp://download.opensuse.org/repositories/KDE:/Backports/openSUSE_11.0/
    20 | repo-debug | openSUSE-11.0-Debug | Nein | Nein | htxtp://download.opensuse.org/distribution/11.0/repo/debug/
    21 | repo-oss | openSUSE-11.0-Oss | Ja | Nein | hxttp://download.opensuse.org/distribution/11.0/repo/oss/

    done

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: SuperKaramba-KDE4

    For a NOOB as you put it you have too many repo's.
    For kde 4.1 factory, you should have just these:
    Index of /repositories/KDE:/KDE4:/Factory:/Desktop
    Index of /repositories/KDE:/KDE4:/Factory:/Extra-Apps/openSUSE_11.0
    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE4_Factory_Desktop

    Again. I find that there is no such dependency as you quote.

    Go to yast software management, select superkaramba for install and post the errors here. You can use the expert button in the error box to save the errors to file and paste them here.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: SuperKaramba-KDE4

    Hehe too many repos? how did i grab those and how can i remove them?

    #### YaST2 conflicts list - generated 2008-09-14 10:13:25 ####

    nothing provides libxklavier.so.11 needed by kdebase4-workspace-4.1.64-2.3.i586

    [ ] kde4-superkaramba-4.1.64-1.4.i586 nicht installieren

    #### YaST2 conflicts list END ###

    well in fact same paste as my first post ^^

    p.s. thx for quick replies uRoxkx

  9. #9
    Join Date
    Jun 2008
    Location
    near SUSE Headquarter
    Posts
    237

    Default Re: SuperKaramba-KDE4

    Delete/replace all the repositories you get with "zypper lr -u | grep 10.3" - don't mix 11.0 and 10.3 repositories!

  10. #10

    Default Re: SuperKaramba-KDE4

    hehe thx it worked sry for being nwbsh
    thx guys

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •