Results 1 to 5 of 5

Thread: openSUSE 11 XD

  1. #1

    Default openSUSE 11 XD

    Hello,

    I use Xming and XDMCP to access my openSUSE system, (which I just installed openSUSE and replaced a working install of SLES10.)

    Previously I had no problems with using Xming to access the computer when it had SLES10 on it.

    From windows I ran Xming like this and had no issues with SLES10.
    "CProgram Files (x86)\Xming\Xming.exe" :1 -clipboard -emulate3buttons -query 10.0.0.4 -once


    I have reconfigured /etc/sysconfig/displaymanger
    to have
    DISPLAYMANAGER_REMOTE_ACCESS="yes"
    DISPLAYMANAGER_ROOT_LOGIN_REMOTE="yes"
    DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes"

    When I launch Xming I get an Xsession and see kdm and put in my username/passwd no problem.

    When I hit enter and the splash screen for kdm comes up Xming suddenly crashes.

    The failsafe session works but Gnome, kde 3.5, kde 4 all cause Xming to crash.

    Here is the .xsession errors I get from this.

    Any help to get this working would be greatly appreciated.
    I don't want to have to go back to SLES10.

    Thanks.

    wrights:~ # cat .xsession-errors
    /etc/X11/xim: Checking whether an input method should be started.
    /etc/X11/xim: user environment variable LANG=POSIX
    /etc/X11/xim: user environment variable LC_CTYPE=en_US.UTF-8
    sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale en_US.UTF-8 ...
    There is no default input method for the current locale.
    Warning: No symbols defined for <SYRQ> (keycode 92)
    Warning: No symbols defined for <II5D> (keycode 93)
    Warning: No symbols defined for <II65> (keycode 101)
    Warning: No symbols defined for <BRK> (keycode 114)
    Warning: No symbols defined for <FK13> (keycode 118)
    Warning: No symbols defined for <FK14> (keycode 119)
    Warning: No symbols defined for <FK15> (keycode 120)
    Warning: No symbols defined for <FK16> (keycode 121)
    Warning: No symbols defined for <FK17> (keycode 122)
    Warning: No symbols defined for <KPDC> (keycode 123)
    Warning: No symbols defined for <XFER> (keycode 129)
    Warning: No symbols defined for <I02> (keycode 130)
    Warning: No symbols defined for <NFER> (keycode 131)
    Warning: No symbols defined for <I04> (keycode 132)
    Warning: No symbols defined for <AE13> (keycode 133)
    Warning: No symbols defined for <I06> (keycode 134)
    Warning: No symbols defined for <I07> (keycode 135)
    Warning: No symbols defined for <I08> (keycode 136)
    Warning: No symbols defined for <I09> (keycode 137)
    Warning: No symbols defined for <I0A> (keycode 138)
    Warning: No symbols defined for <I0B> (keycode 139)
    Warning: No symbols defined for <I0C> (keycode 140)
    Warning: No symbols defined for <I0D> (keycode 141)
    Warning: No symbols defined for <I0E> (keycode 142)
    Warning: No symbols defined for <I0F> (keycode 143)
    Warning: No symbols defined for <I10> (keycode 144)
    Warning: No symbols defined for <I11> (keycode 145)
    Warning: No symbols defined for <I12> (keycode 146)
    Warning: No symbols defined for <I13> (keycode 147)
    Warning: No symbols defined for <I14> (keycode 148)
    Warning: No symbols defined for <I15> (keycode 149)
    Warning: No symbols defined for <I16> (keycode 150)
    Warning: No symbols defined for <I17> (keycode 151)
    Warning: No symbols defined for <I18> (keycode 152)
    Warning: No symbols defined for <I19> (keycode 153)
    Warning: No symbols defined for <I1A> (keycode 154)
    Warning: No symbols defined for <I1B> (keycode 155)
    Warning: No symbols defined for <K59> (keycode 157)
    Warning: No symbols defined for <I1E> (keycode 158)
    Warning: No symbols defined for <I1F> (keycode 159)
    Warning: No symbols defined for <I20> (keycode 160)
    Warning: No symbols defined for <I21> (keycode 161)
    Warning: No symbols defined for <I22> (keycode 162)
    Warning: No symbols defined for <I23> (keycode 163)
    Warning: No symbols defined for <I24> (keycode 164)
    Warning: No symbols defined for <I25> (keycode 165)
    Warning: No symbols defined for <I26> (keycode 166)
    Warning: No symbols defined for <I27> (keycode 167)
    Warning: No symbols defined for <I28> (keycode 168)
    Warning: No symbols defined for <I29> (keycode 169)
    Warning: No symbols defined for <K5A> (keycode 170)
    Warning: No symbols defined for <I2B> (keycode 171)
    Warning: No symbols defined for <I2C> (keycode 172)
    Warning: No symbols defined for <I2D> (keycode 173)
    Warning: No symbols defined for <I2E> (keycode 174)
    Warning: No symbols defined for <I2F> (keycode 175)
    Warning: No symbols defined for <I30> (keycode 176)
    Warning: No symbols defined for <I31> (keycode 177)
    Warning: No symbols defined for <I32> (keycode 178)
    Warning: No symbols defined for <I33> (keycode 179)
    Warning: No symbols defined for <I34> (keycode 180)
    Warning: No symbols defined for <K5B> (keycode 181)
    Warning: No symbols defined for <K5D> (keycode 182)
    Warning: No symbols defined for <K5E> (keycode 183)
    Warning: No symbols defined for <K5F> (keycode 184)
    Warning: No symbols defined for <I39> (keycode 185)
    Warning: No symbols defined for <I3A> (keycode 186)
    Warning: No symbols defined for <I3B> (keycode 187)
    Warning: No symbols defined for <I3C> (keycode 188)
    Warning: No symbols defined for <K62> (keycode 189)
    Warning: No symbols defined for <K63> (keycode 190)
    Warning: No symbols defined for <K64> (keycode 191)
    Warning: No symbols defined for <K65> (keycode 192)
    Warning: No symbols defined for <K66> (keycode 193)
    Warning: No symbols defined for <I42> (keycode 194)
    Warning: No symbols defined for <I43> (keycode 195)
    Warning: No symbols defined for <I44> (keycode 196)
    Warning: No symbols defined for <I45> (keycode 197)
    Warning: No symbols defined for <K67> (keycode 198)
    Warning: No symbols defined for <K68> (keycode 199)
    Warning: No symbols defined for <K69> (keycode 200)
    Warning: No symbols defined for <K6A> (keycode 201)
    Warning: No symbols defined for <I4A> (keycode 202)
    Warning: No symbols defined for <K6B> (keycode 203)
    Warning: No symbols defined for <K6C> (keycode 204)
    Warning: No symbols defined for <K6D> (keycode 205)
    Warning: No symbols defined for <K6E> (keycode 206)
    Warning: No symbols defined for <K6F> (keycode 207)
    Warning: No symbols defined for <HKTG> (keycode 208)
    Warning: No symbols defined for <KANA> (keycode 209)
    Warning: No symbols defined for <EISU> (keycode 210)
    Warning: No symbols defined for <AB11> (keycode 211)
    Warning: No symbols defined for <I54> (keycode 212)
    Warning: No symbols defined for <I55> (keycode 213)
    Warning: No symbols defined for <I5A> (keycode 218)
    Warning: No symbols defined for <K74> (keycode 219)
    Warning: No symbols defined for <K75> (keycode 220)
    Warning: No symbols defined for <K76> (keycode 221)
    Warning: No symbols defined for <I5E> (keycode 222)
    Warning: No symbols defined for <I5F> (keycode 223)
    Warning: No symbols defined for <I60> (keycode 224)
    Warning: No symbols defined for <I61> (keycode 225)
    Warning: No symbols defined for <I62> (keycode 226)
    Warning: No symbols defined for <I63> (keycode 227)
    Warning: No symbols defined for <I64> (keycode 228)
    Warning: No symbols defined for <I65> (keycode 229)
    Warning: No symbols defined for <I66> (keycode 230)
    Warning: No symbols defined for <I67> (keycode 231)
    Warning: No symbols defined for <I68> (keycode 232)
    Warning: No symbols defined for <I69> (keycode 233)
    Warning: No symbols defined for <I6A> (keycode 234)
    Warning: No symbols defined for <I6B> (keycode 235)
    Warning: No symbols defined for <I6C> (keycode 236)
    Warning: No symbols defined for <I6D> (keycode 237)
    Warning: No symbols defined for <I6E> (keycode 238)
    Warning: No symbols defined for <I6F> (keycode 239)
    Warning: No symbols defined for <I70> (keycode 240)
    Warning: No symbols defined for <I71> (keycode 241)
    Warning: No symbols defined for <I72> (keycode 242)
    Warning: No symbols defined for <I73> (keycode 243)
    Warning: No symbols defined for <I74> (keycode 244)
    Warning: No symbols defined for <I75> (keycode 245)
    Warning: No symbols defined for <I76> (keycode 246)
    Warning: No symbols defined for <I77> (keycode 247)
    Warning: No symbols defined for <I78> (keycode 248)
    Warning: No symbols defined for <I79> (keycode 249)
    Warning: No symbols defined for <I7A> (keycode 250)
    Warning: No symbols defined for <I7B> (keycode 251)
    Warning: No symbols defined for <I7C> (keycode 252)
    Warning: No symbols defined for <I7D> (keycode 253)
    Warning: No symbols defined for <I7E> (keycode 254)
    Warning: No symbols defined for <I7F> (keycode 255)

  2. #2

    Smile Re: openSUSE 11 XD

    Hi,

    I found that the solution to Xming crahing, when you press Enter to login on the remote KDM screen, is to modifiy a line in the /usr/share/kde4/config/kdm/kdmrc file.

    Change the line under [Xdmcp] which says:

    #Enable=false

    to

    Enable=true.

    Reboot the remote machine (just to make sure this 'takes') and you should then be able to login. However, KDE4 on Suse11.0 seems to run a lot of background processes that do do not end cleanly when you logout. Expect an Xming crash at this point.

    Hope this helps.

  3. #3
    plodder NNTP User

    Default Re: openSUSE 11 XD


    Hi,

    I found that the solution to Xming crahing, when you press Enter to
    login on the remote KDM screen, is to modifiy a line in the
    /usr/share/kde4/config/kdm/kdmrc file.

    Change the line under [Xdmcp] which says:

    #Enable=false

    to

    Enable=true.

    Reboot the remote machine (just to make sure this 'takes') and you
    should then be able to login. However, KDE4 on Suse11.0 seems to run a
    lot of background processes that do do not end cleanly when you logout.
    Expect an Xming crash at this point.

    Hope this helps.


    --
    plodder
    ------------------------------------------------------------------------
    plodder's Profile: http://forums.opensuse.org/member.php?userid=10637
    View this thread: http://forums.opensuse.org/showthread.php?t=395263


  4. #4

    Default Re: openSUSE 11 XD

    I tried this

    [Xdmcp]
    Enable=true

    in /usr/share/kde4/config/kdm/kdmrc

    But Xming still crashes for me

  5. #5
    asnrcw NNTP User

    Default Re: openSUSE 11 XD


    I tried this

    [Xdmcp]
    Enable=true

    in /usr/share/kde4/config/kdm/kdmrc

    But Xming still crashes for me


    --
    asnrcw
    ------------------------------------------------------------------------
    asnrcw's Profile: http://forums.opensuse.org/member.php?userid=10850
    View this thread: http://forums.opensuse.org/showthread.php?t=395263


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •