Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: can't play .flv files???

Hybrid View

  1. #1

    Default can't play .flv files???

    Hi
    I've installed opensuse 11 in the past, and installed the codecs-kde.ymp file from the site, and i was always able to play my media. I've just installed Opensuse11 again for the first time in quite a while, and done the same thing as i use to... and i can't get .flv files to play at all...........

    I installed the codecs-kde.ymp package over and over again, reset, try to play my .flv video file, and it just keeps asking me to be directed to the site to get the codecs again........

    I even download "ffmpeg" from the repo, and i still can't play .flv files.
    Any ideas?
    thanx in advance.
    ps... i also download vlc player, and not even vlc will let me play my flash video files, from what i remember... vlc is suppose to be able to handle these files, it always use to.. but nope. not even kaffeine will work.

    thanx... ?????????????????????

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: can't play .flv files???

    Make sure all your multi-media packages are Packman
    Only libdvdcss will be from vlc

    I can't say I have tried .flv (flash) files.
    There is a stand alone flash player in suse 11, have you tried that.
    oldcpu may come in on this: he's the guru

    check here: FLV - openSUSE Forums
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: can't play .flv files???

    i just found an error with libxine in yast.

    libxine1-1.1.15-0.pm.1.i686 obsoletes xine-lib provided by xine-lib-1.1.12-8.1.i586

    [ ] replacement of xine-lib-1.1.12-8.1.i586 with libxine1-1.1.15-0.pm.1.i686
    [ ] do not install libxine1-1.1.15-0.pm.1.i686

    I wonder if that is why i can't play .flv files.
    i have tried the conflict resolution and it doesn't work.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: can't play .flv files???

    Check you have libdvdcss installed form VLC
    then disable VLC repo
    now use Yast software management
    and update Packman

    check the thread I quoted earlier
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: can't play .flv files???

    Ok.. i have done all that was suggested.
    except 1 thing... I am not able to install libxine1 from the repo. It won't let me, it comes back with the error i mentioned earlier. I will try and get that file from the build service or rpmsearch, install it and see how i go........
    let you know what happened soon
    thanx for ur help by the way...

  6. #6

    Default Re: can't play .flv files???

    ahhhh
    fixed it.

    for some reason, the package xine-lib was conflicting with the package that i needed, thats why it wouldn't let me install it :s
    i deleted xine-lib, then i was able to install the package that i needed. Now .flv files play as normal

    strange....
    but atleast its fixed now
    thanx anyways

  7. #7

    Default Re: can't play .flv files???

    Although... vlc still won't play the .flv files... and i prefer to use vlc over kaffeine...
    any ideas on how to get vlc to play .flv files anyone? usually it plays them by default :s

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: can't play .flv files???

    Quote Originally Posted by kaddy View Post
    Although... vlc still won't play the .flv files... and i prefer to use vlc over kaffeine...
    any ideas on how to get vlc to play .flv files anyone? usually it plays them by default :s
    Yes, ... its as I posted ...

    Quote Originally Posted by oldcpu View Post
    Reference vlc and libffmpeg, as you note, together they should play the flash video for you. But note there are two packagers that provide both of these (videolan and packman), and their versions are currently not compatible with each other. My recommendation is you stick to the vlc version and the libffmpeg version, that are packaged by packman and avoid the videolan packaged version (for now until this incompatibility is addressed).
    To fix it, I recommend you setup your repos as I noted:
    Quote Originally Posted by oldcpu View Post
    Immediately after I install an openSUSE (assuming I have internet) the very first thing I do is setup my Software Package Manager repositories with 4 and only 4 repositories (repos) so as to make the installation of software very very fast and very user friendly. The 4 that I add are OSS, Non-OSS, Update and Packman. Just those 4. No others. You can add others only once you know better the risks (such as incompatibilities between packagers - ie the videolan / packman incompatibility example). To setup those 4 repositories please follow the very brief and very simple instructions here:
    Repositories/11.0 - openSUSE-Community
    ... and then add only the 4 that I mentioned. If you added others, I recommend you remove them until at least you sort out your multimedia.
    Then select the packman packaged vlc for install and the packman packaged libffmpeg0 for install.

    The odds are you have one videolan and one packman and they are not compatible.

  9. #9

    Default Re: can't play .flv files???

    cheers for the info.
    but i didn't have video/lan repo enabled
    I did a fresh install of Opensuse 11 kde, however i did enable alot of other community repo's, but not video/lan. And I did the 1 click install for media from the opensuse website.
    but yer, i'll try disabling all the other repo's like you said, uninstall the packages, and reinstall them from packman.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: can't play .flv files???

    You don't need to un-install
    it's just a matter of going through the packages in software management and making sure you have the packman version, use the version tab in the packages window and make sure the radio button is to packman's ver
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •