Results 1 to 6 of 6

Thread: Can't update system

  1. #1

    Default Can't update system

    I get a message that 31 updates are pending but when I try to install those I get this message:
    Package Kit Error; Dependency resolution failed; A package could not be found that alows the task to complete.
    More information is available in the detailed report.

    patch:esound-138.noarch conflicts with pavucontrol.x86_64 < 0.9.6-4.1 provided by pavucontrol-0.9.6-0.pm.1.x86_64
    Do I need to remove esound-138.noarch? If so how should I remove it (with rpm)? Will there be a sound problem after removal?

  2. #2

    Default Re: Can't update system

    I have had the same problem for a long time. I've done the "review" option and unckecked "esound" so that all other updates will work, but it gets annoying having to manually do that every time.

    1) Is there a workaround?

    2) If not, is there a way to tell my system to stop trying to update that file?

  3. #3
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: Can't update system

    Quote Originally Posted by Airdawg10 View Post
    2) If not, is there a way to tell my system to stop trying to update that file?
    Maybe that works with a packagelock (since openSUSE11). Try the following or something similar while you are root.
    Code:
    zypper al esound

  4. #4

    Default Re: Can't update system

    Quote Originally Posted by Airdawg10 View Post
    I have had the same problem for a long time. I've done the "review" option and unckecked "esound" so that all other updates will work, but it gets annoying having to manually do that every time.

    1) Is there a workaround?

    2) If not, is there a way to tell my system to stop trying to update that file?
    Doing the review and unchecking esound worked. The system is downloading the packages now. Thank you!

    This:
    Maybe that works with a packagelock (since openSUSE11). Try the following or something similar while you are root.
    Code:

    zypper al esound
    Does not work. Issued that as root and it still gave the same error message. How do I unlock. I guess Can read thru man zypper.

    Thanks for the replies.

  5. #5

    Default Re: Can't update system

    yeah, that didn't work for me either. From root, I typed as you said and it told me that the lock was successfully added. But when I try to update esound, it still gives me the same error message.

  6. #6

    Default Re: Can't update system

    I had similar problem after installation of the system. All I did was update via Yast and not a notification icon and since then everything worked smoothly. Not sure if it will work for you though...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •