Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Zypper/Yast package update problem

  1. #1

    Default Zypper/Yast package update problem

    I'm having a problem with zypper/yast. Yesterday automatic update reported three new updates, one of which was kernel and another was for clamav. The update failed with no reported error.

    I tried manually via zypper update, and it failed on clamav. I installed other updates and returned to clamav later. The problem is, it is installing the patch clamav-181.noarch AND removing clamav-0.93-19.1 at the same time:

    Code:
    The following NEW patches are going to be installed:
      clamav-181.noarch  (openSUSE-11.0-Updates, maint-coord@suse.de)
    
    The following package is going to be REMOVED:
      clamav-0.93-19.1.x86_64  (@System, SUSE LINUX Products GmbH, Nuernberg, Germany)
    Overall result, clamav is removed and not patched. When I try to install it again, version 0.93 is installed, again requiring update. Please note this is clamav update, not virus db update.

    This is on my laptop, 64-bit OpenSuSE 11. Another machine, 32-bit OpenSuSE 11 server, with no gui, updated just fine.

    I don't know how to track the problem. I'm figuring it's either my zypper/yast, or 64-bit patch for clamav.

  2. #2

    Default Re: Zypper/Yast package update problem

    Ok, so I managed to force-install clamav 0.94 using

    Code:
    zypper install -C clamav=0.94-0.1
    as suggested by Spyhawk on IRC. But I'm still curious what could have been the problem. I tried even cleaning zypper cache and installing clamav anew, but it offered 0.93 still, and update to 0.94 failed.

    Is the 64-bit patch for clamav 0.94 faulty, or is my zypper (or something else) broken?

    Edit: trying to install klamav reverts clamav back to 0.93.

  3. #3

    Default Re: Zypper/Yast package update problem

    Bump?

    Did anyone else have this problem with clamav 0.93? Is it just my system? What could have gone wrong?

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Zypper/Yast package update problem

    > This is on my laptop, 64-bit OpenSuSE 11. Another machine, 32-bit
    > OpenSuSE 11 server, with no gui, updated just fine.


    why, on a non-server system do you feel the need to run it at all?
    (unless you want to help your Windows[tm] using friends protect their
    fragile systems)

    anyway, unless you are running a mail server which does deliver
    directly to Doz machines there is little utility in running it..

    i've never run an anti-virus on my Linux box, ever...all the way back
    to late last century.

    --
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,378
    Blog Entries
    1

    Default Re: Zypper/Yast package update problem

    i've never run an anti-virus on my Linux box, ever...all the way back
    to late last century.
    The last Millenium even...

  6. #6

    Default Re: Zypper/Yast package update problem

    Quote Originally Posted by DenverD View Post
    why, on a non-server system do you feel the need to run it at all?
    (unless you want to help your Windows[tm] using friends protect their
    fragile systems)
    Actually, this is exactly the reason. I'm asked a lot to help others clean their PCs and I'd like to have an antivirus handy and up to date.

    But that's irrelevant. I'm still clueless as to what might be the cause of the problem.

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Zypper/Yast package update problem

    > Actually, this is exactly the reason. I'm asked a lot to help others
    > clean their PCs and I'd like to have an antivirus handy and up to date.


    i don't know how to fix the zypper problem either, but tell me how
    having clamav up to date and working on your lap top helps you clean
    a friends infected Windows[tm] machine...

    btw: friends don't let friends drive home windows..

    --
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  8. #8

    Default Re: Zypper/Yast package update problem

    Quote Originally Posted by DenverD View Post
    i don't know how to fix the zypper problem either, but tell me how
    having clamav up to date and working on your lap top helps you clean
    a friends infected Windows[tm] machine...
    It's quite simple, actually and there are several ways you can access the (infected) windows machine from Linux. Through an NFS, or what I often do, through USB external hard drive case to which I connect their drives and clean them.

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Zypper/Yast package update problem

    good info, thanks..

    since you are performing open-gutz surgery on sick and frail clients,
    i hope you have both malpractice insurance AND get paid for your
    kindness.. ;-)

    me, i tell'em i never use M$ and don't know how to clean up Redmond's
    mess...which sure gives me more free time (i used to try to
    help'em)....thankfully i don't need their money..

    of course, ymmv..

    --
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  10. #10
    bokobokoboko NNTP User

    Default Re: Zypper/Yast package update problem

    Hi
    I think you have also klamav installed on you system.

    if you want clamav-0.93-19.1 you need to UNinstall klamav 0.42 and then install clamav.

    The problem is that klamav 0.42 is not compatible with new libraries from clamav-0.93 and that stops the yast

    so, if you need only clamav /to use it from command line/ this is solution for you, but if you need also klamav then you have the following options:
    1. wait for klamav new rpm from suse teem
    2. download klamav sources + patch for clamav-0.93 and buid it manualy
    3. go back to old versions

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •