Results 1 to 5 of 5

Thread: International keyboard Layouts

  1. #1

    Default International keyboard Layouts

    I'm using openSUSE 11.0 on a MacBook (C2D). As I use both English and Portuguese languages on my computer, I have tried to add these keyboard layouts to my Panel from Yast>>Hardware>>Keyboard Layout
    Although both are available, switching between them makes aboslutely no difference. IOW, I cannot type accented vowels or C-cedila.
    And, yes, I have gone into Configure Desktop>>Regional&Language>>Keyboard Layout to enable keyboard layout.
    One puzzling feature of this is that right now, for reasons I don't at all understand, I can no longer enter into Yast>>Hardware>>Keyboard Layout. The scroll box appears after hitting KeyBoard Layout, but then that just fizzles out and the main page doesn't open.
    Any clues?

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,475

    Default Re: International keyboard Layouts

    YaST>Hardware is for ensuring that openSUSE knows the hardware of your keyboard; Regional>Keyboard layout is to allow you to change software keyboards. If you want to use two different layouts, you change the software keyboard; if you want to change the physical keyboard, you change the hardware keyboard.

  3. #3
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: International keyboard Layouts

    I had the same problem until I found out that c-cedilla is placed with rightALT + , and not '+c
    I like using US keyboard with intl layout.

  4. #4

    Default Re: International keyboard Layouts

    @john_hudson
    Thanks for that clarification.
    Actually, I was able to resolve my problem by removing the duplicate IE (Ireland) keyboard layout that I had inadvertently added to the list of "software" keyboard layouts.
    Now, I can click the panel icon to change from IE to BR (Brazilian Portuguese) and I get the required keyboard behaviour change I need.
    Actually, the only difficult part here was figuring out how to remove an unwanted layout from the "active layout" list in the Regional & Language System Settings box. To remove a layout, you have to highlight it and then click the left-most triangle of the two that appear just above the upper left corner of the Active Layout box.

    @beli0135
    You can certainly use dead-keys and all that good stuff, but I find it much more covenient to be able to click a panel icon to move immediately to a keyboard layout that is almost identical to a Brazilian Portuguese layout (or whatever other one you want to use).
    To enable this other layout, just go to the Gecko menu>>Configure Desktop>>Regional & Language>>Keyboard Layout. Now:
    1. Make sure your keyboard shows up in the Keyboard Model box
    2. Click the radio button to Enable Keyboard Layouts
    3. Check Show Country Flag
    4. Go to the Available Layouts box and choose the ones you want. Double click or use the triangle thing above the box to get your chosen layouts to enter the Active Layouts box
    5. Highlight each entry in the Active Layouts box and choose the Layout Variant you want if you need something other than Default.
    6. Click the Apply button
    Now, you should see an icon with your layouts flag on it in the panel. Click this to change layouts.
    Legal, no ?

  5. #5
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: International keyboard Layouts

    No, no legal.
    I hate using ABNT2 or whatever layout or switching it.
    Catch is not to change layout at all, as it will disrupt position of characters for what I got used to use.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •