Results 1 to 4 of 4

Thread: System time... giving problem

  1. #1
    Join Date
    Sep 2008
    Location
    Bangladesh
    Posts
    17

    Default System time... giving problem

    Hi everyone, I just Installed OpenSuse 11 (KDE 3.5 Desktop) and set my locale to Asia/Dhaka which is +6:00 GMT & now my clock skips 6 hours ahead every time i restart my PC...

    so I check time in my BIOS and It also seems to have skipped ahead with the system clock!!!

    so I went to Yast > System > /etc/sysconfig editor > System > Environment > clock and changed the SYSTOHC option off!! so that the wrong time is not being written to bios when I reboot.

    now my bios doesn't skip ahead but as usual my system clock shows time 6 hours ahead of my bios!!!!

    What on earth is wrong??
    Emon

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: System time... giving problem

    Emon,

    Yast, System, Date and time: Check if you are in the correct timezone and if your BIOS clock is set to UTC or local time. If you are using Windows on the very same machine, set the BIOS clock to local time and uncheck the corresponding setting in Yast, else use UTC.

    Uwe

  3. #3
    Join Date
    Sep 2008
    Location
    Bangladesh
    Posts
    17

    Talking Re: System time... giving problem

    Hi

    Really, really sorry about this delayed response

    But I guess "better be late than never" :-P

    This is how I solved the problem
    I went to Yast > System > /etc/sysconfig editor > System > Environment > clock and changed the SYSTOHC option off!!

    Then added this line

    hwclock -s

    to /etc/init.d/boot.local

    Thanks again everyone
    Emon

  4. #4
    emon suse NNTP User

    Default Re: System time... giving problem


    Hi

    Really, really sorry about this delayed response

    But I guess "better be late than never" :-P

    This is how I solved the problem
    I went to Yast > System > /etc/sysconfig editor > System > Environment
    > clock and changed the SYSTOHC option off!!


    Then added this line

    hwclock -s

    to /etc/init.d/boot.local

    Thanks again everyone
    Emon


    --
    emon_suse
    ------------------------------------------------------------------------
    emon_suse's Profile: http://forums.opensuse.org/member.php?userid=10654
    View this thread: http://forums.opensuse.org/showthread.php?t=395052


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •