Results 1 to 4 of 4

Thread: Permissions problems with KDE 4.1.1 at opensuse 11

  1. #1
    Join Date
    Sep 2008
    Location
    Athens-Hellas
    Posts
    35

    Exclamation Permissions problems with KDE 4.1.1 at opensuse 11

    Hi folks!

    I have this permission's problem here...

    In details...
    Whenever I enter KDE 4 environment from a moment and after a massive update (I always do massive updates from the factory repos bleeding edge KDE 4.1.1 worths it!)
    I logged normally at my user account and firstly I realised that kmix icon dissapearred from the taskbar and not starting whatever I tried even from console, the NetworkManager icon that shows connection state is not green anymore but grey although I use internet normally, furthermore the HP Status Service icon appears but the HPLIP panel shows connection problem between the app and my printer.
    Also if I give alsamixer at a console window I get this message:
    Code:
    alsamixer: function snd_ctl_open failed for default: Permission denied
    If I login as root everything works fine!

    Any ideas guys??
    I suspected PolicyKit but really don't know...

  2. #2

    Default Re: Permissions problems with KDE 4.1.1 at opensuse 11

    Sometimes I get the same thing on my laptop. If it works like mine, I can re-boot a couple of times and it usually clears up. Spending the first 20 minutes or so every morning re-booting isn't really productive though.

    Do you authenticate against LDAP/AD or is it a local login? If it's a local login, is your user account a member of the correct groups to access these resources(Audio)?

    C.Durbin

  3. #3
    Join Date
    Sep 2008
    Location
    Athens-Hellas
    Posts
    35

    Default Re: Permissions problems with KDE 4.1.1 at opensuse 11

    I work with a local login.
    But how can my user came out of these groups? I didn't touch anything at users settings!

    How can I check those groups? Via Yast at user accounts??
    Fight is the only way my friends! Compiz-Fusion Hellas.

  4. #4

    Default Re: Permissions problems with KDE 4.1.1 at opensuse 11

    The more I look into this problem, the more I believe you are correct in your original assessment that it is an issue with PolicyKit.

    This happens randomly with KDE 3.x & 4.x it also happens with Gnome.

    I don't really know enough about PolicyKit to be much help though and their documentation is severely lacking.

    This is becoming such an issue that I am starting to think about switching to a different distro to see if they have this problem.

    Can anyone else shed any light on this?

    C.Durbin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •