Results 1 to 4 of 4

Thread: DirectFB 1.2.3-2.1 update dependency problems annoyance

  1. #1
    Join Date
    Jul 2008
    Location
    Istanbul, Turkey
    Posts
    50

    Default DirectFB 1.2.3-2.1 update dependency problems annoyance

    One of the updates released yesterday (08 Sep 2008) on the openSUSE games repository was DirectFB 1.2.3-2.1

    If I were to update this i would cause a large number of dependency errors including removal of:

    splashy
    suspend
    mplayer
    eaxaile
    gstreamer-plugis-bad

    and downgrade of:

    brasero

    Why would such an update be released onto a repository if it could cause problems such as breaking my computers suspend function and adversely affecting the multimedia capabilities of my computer. Aren't things like this checked and why put an update on that can break things if the existing version works fine?

    The reason I switched all my computers to openSUSE was because my impression is that it is a superior distribution to Ubuntu and yet updates are released that can cause newcomers problems. Don't get me wrong I really appreciate what you have produced with this distribution and I love using it but is there not some quality checking by the repository maintainers before you release updates such as these?

  2. #2

    Default Re: DirectFB 1.2.3-2.1 update dependency problems annoyance

    This may not be the optimal way to do this, but I forced mine to install without allowing it to remove/downgrade any packages (ignore dependencies). This temporarily broke those applications, but then I created a symlink in /usr/lib named libdirectfb-1.1.so.0 and pointed it at libdirectfb-1.2.so.0.3.0. All the apps seemed to work correctly after that.

    C.Durbin

  3. #3
    Join Date
    Jul 2008
    Location
    Istanbul, Turkey
    Posts
    50

    Default Re: DirectFB 1.2.3-2.1 update dependency problems annoyance

    Thanks for response. If I decide to unlock the update and install it I will follow your advice.

    Still not overly happy that such updates appear which so obviously break things. There is a post earlier in this forum about this being done with the same package last year on 10.3 and it caused that user grief as well with no response to his forum post.

    Microsoft are criticised openly for providing 'updates' which break things. This DirectFB 'update' doesn't seem alot different.

  4. #4
    Join Date
    Jun 2008
    Location
    Mount Airy, MD
    Posts
    32

    Thumbs down Re: DirectFB 1.2.3-2.1 update dependency problems annoyance

    It seems this has yet to be resolved, as YaST Package Selection is reporting the same problem when trying to update DirectFB 1.1.1-48.1 to 1.2.9-6.1:

    splashy-0.3.8-53.1.i586 requires libdirectfb-1.1.so.0, but this requirement cannot be provided

    http://www.mail-archive.com/debian-b...msg625302.html
    "Splashy has not been tested against newer version of libdirectfb. I know for sure that libdirectfb 1.2 makes it segfault."

    http://n2.nabble.com/Bug-512951-etc-...td2212877.html
    "Drop hard-coded libdirectfb dependency. Splashy does not requires any source code changes to work with libdirectfb 1.2.x."
    Jim Matthews
    desktop: OpenSuSE 13.2-64 Gnome 3.0 GHz Athlon II X4 640 8 GB M4A88TD-V
    laptop: OpenSuSE 13.2-64 Gnome 1.9 GHz Tur64 X2 2 GB nVIDIA GeForce 7000M
    netbook: OpenSuSE 11.4-64 Gnome 1.66 GHz Atom N450 2 GB GMA 3150

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •