Results 1 to 9 of 9

Thread: system error

  1. #1

    Default system error

    good day.

    i am using suse 10.3. there is a opensuse updater error:

    /usr/sbin/zypp-checkpatches-wrapper: error while loading shared libraries: libsqlite3.so.0

    i opened the yast and hit on the software management, also the error:

    error loading language plugin /usr/lib/yast2/plugin/liby2lang_perl.so: libsqlite3.so.0

    i cant use the system restore because of the same error too. help please. thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: system error

    You can use your system though? It's just your updater causing problems?

    In a terminal go su

    type:
    zypper in libzypp sqlite3

    post results of:
    zypper lu
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: system error

    yes i can use the system. i uninstalled the sqlite yesterday, i was trying to use the mysql instead. there were dependencies i just select the ignore button. i am trying to use the system restoration but theres a error:

    error loading language plugin /usr/lib/yast2/plugin/libpy2lang_perl.so: libsqlite3.so.0: cannot open shared object file: no such file or directory

    no such client module restore.

    i went to terminal and su root then typed in "zypper lu", the errror is:

    zypper: error while loading shared libraries: libsqlite3.so.0: cannot open shared object file: no such file or directory.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: system error

    do you have another package manager installded: eg smart

    otherwise, I'm not too sure how you should proceed. You may be able to force a re-installation of the broken packages.
    I know a way to do it, but it's a bit fiddly and may not be the best or most efficient way.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: system error

    Quote Originally Posted by moj591669 View Post
    good day.

    i am using suse 10.3. there is a opensuse updater error:

    /usr/sbin/zypp-checkpatches-wrapper: error while loading shared libraries: libsqlite3.so.0

    i opened the yast and hit on the software management, also the error:

    error loading language plugin /usr/lib/yast2/plugin/liby2lang_perl.so: libsqlite3.so.0

    i cant use the system restore because of the same error too. help please. thank you.
    Try this: (make a backup of the directory /var/lib/rpm first)
    Then in a terminal:
    su
    rpm --rebuilddb

    /G
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  6. #6
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: system error

    Quote Originally Posted by caf4926 View Post
    do you have another package manager installded: eg smart

    otherwise, I'm not too sure how you should proceed. You may be able to force a re-installation of the broken packages.
    I know a way to do it, but it's a bit fiddly and may not be the best or most efficient way.
    If your not sure how to proceed other than a "fiddly" way not worth posting as it provides no help whatsoever
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  7. #7
    Join Date
    Aug 2008
    Location
    127.0.0.1
    Posts
    22

    Default Re: system error

    On Tue, 09 Sep 2008 11:36:01 +0700, moj591669
    <moj591669@no-mx.forums.opensuse.org> wrote:
    >
    > zypper: error while loading shared libraries: libsqlite3.so.0: cannot
    > open shared object file: no such file or directory.
    >
    >


    in this case you should install sqlite3 manually using rpm.

    if you have DVD, search the sqlite package in there, or download one
    from 10.3 repositories.

    in case you did not know how to use rpm,

    $ rpm -i sqlite-<insert-version-number>.rpm

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Smile Re: system error

    geoffro:
    I was simply trying to give moj591669 some hope for a future solution. Trusting that someone more gifted - like yourself might come along. There is nothing worse than getting no response at all. New users tend to go into panic mode and start clicking like crazy.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: system error

    thank you for the help kind sirs. i was overcome by panic and didnt think. i just re installed the sqlite from the cd and its now working fine again. thanks again for the replies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •