Results 1 to 4 of 4

Thread: 10.3 knetworkmanager cpio bad magic

  1. #1

    Default 10.3 knetworkmanager cpio bad magic

    Hello all. I am trying to update knetworkmanager to a more current version than the version found in the 10.3 repository. I've tried adding the 11 and Factory repositories(only one at a time) and installing, but each time I am met with
    Code:

    RPM failed: error: unpacking of archive failed: cpio: Bad Magic

    I am not sure how to remedy the problem. I've seen from other posts this may have something to do with update or delta RPMs, but i still don't know how to fix the issue. Any help would be greatly appreciated!

    (I've also tried using zypper, same error)

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,890
    Blog Entries
    15

    Default Re: 10.3 knetworkmanager cpio bad magic

    Quote Originally Posted by kptkill
    Hello all. I am trying to update knetworkmanager to a more current
    version than the version found in the 10.3 repository. I've tried adding
    the 11 and Factory repositories(only one at a time) and installing, but
    each time I am met with
    Code:

    RPM failed: error: unpacking of archive failed: cpio: Bad Magic

    I am not sure how to remedy the problem. I've seen from other posts
    this may have something to do with update or delta RPMs, but i still
    don't know how to fix the issue. Any help would be greatly appreciated!

    (I've also tried using zypper, same error)

    Hi
    With 11, they changed the way rpm's are packaged lzma rather than bz2.
    Maybe try compiling from the source rpm.

    Code:
    rpmbuild --rebuild <name_of_rpm>
    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 11:04, 1 user, load average: 0.08, 0.13, 0.15
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  3. #3

    Default Re: 10.3 knetworkmanager cpio bad magic

    Thanks for the response! Am i going to have to do this for each of the dependencies the new networkmanager-kde will require? (there are a ton)

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,890
    Blog Entries
    15

    Default Re: 10.3 knetworkmanager cpio bad magic

    Quote Originally Posted by kptkill
    Thanks for the response! Am i going to have to do this for each of the
    dependencies the new networkmanager-kde will require? (there are a ton)
    Hi
    More than likely and get into dependency hell.... Have you tried
    building from source or svn? Have a read here;
    http://en.opensuse.org/Projects/KNetworkManager

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 17:39, 1 user, load average: 0.19, 0.34, 0.35
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •