Results 1 to 3 of 3

Thread: Wireless with Atheros AR5212 on Opensuse 11 and Lenovo T61

  1. #1
    MattGEvans NNTP User

    Question Wireless with Atheros AR5212 on Opensuse 11 and Lenovo T61

    Hello to all. I've managed to configure a wire-connection for Internet using Suse 11 on my Lenovo. However, despite much effort I can't figure out how to set up a wireless connection. Hence, my post.

    I've installed Madwifi for Suse 11 following instructions from this site: Atheros madwifi - openSUSE. I've also blacklisted ath5k. In YaST >> Network Devices >> Network Settings I've tried all kinds of configuration and can't work it out. I should also mention that the Network Setup Method is set to Traditional Method with ifup. I also have a statically assigned IP address and subnet mask, and have selected Enable Device Control for Non-root User Via Kinternet. The tabs Hostname/DNS and Routing are also configured.

    From what I've gathered by reading other posts, I should provide some technical info that might help. Using the Terminal, here is some output that I get concerning my wireless card:

    When I type in /sbin/lspci I get the following output:

    ... snip ...
    00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
    ... snip ...
    03:00.0 Ethernet controller: Atheros Communications Inc. AR5212 802.11abg NIC (rev 01)
    ... snip ...


    By putting in /sbin/lspci -n I get:

    ... snip ...
    00:19.0 0200: 8086:1049 (rev 03)
    ... snip ...
    03:00.0 0200: 168c:1014 (rev 01)
    ... snip ...

    When I type in the command dmesg | less, some of the output that I *think* is associated with my wireless card is:

    ... snip ...
    ath_hal: module license 'Proprietary' taints kernel.
    ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    wlan: 0.9.4
    ath_pci: 0.9.4
    ... snip ...
    wifi0: Atheros 5212: mem=0xdf3f0000, irq=17
    ... snip ...
    ath0: no IPv6 routers present
    ... snip ...


    When I type in the command /usr/sbin/iwconfig I get the following:

    lo no wireless extensions.
    eth0 no wireless extensions.
    wifi0 no wireless extensions.

    ath0 IEEE 802.11g ESSID:"MattCed" Nickname:""
    Mode:Managed Frequency:2.462 GHz Access Point: 00:17:33:72:74:45
    Bit Rate:36 Mb/s Tx-Power:8 dBm Sensitivity=1/1
    Retry:off RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality=52/70 Signal level=-45 dBm Noise level=-97 dBm
    Rx invalid nwid:355580 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0


    And when I type in the command sudo /usr/sbin/iwlist scan, one of the output is:

    Cell 06 - Address: 00:17:33:72:74:45
    ESSID:"MattCed"
    Mode:Master
    Frequency:2.462 GHz (Channel 11)
    Quality=52/70 Signal level=-43 dBm Noise level=-95 dBm
    Encryption key:on
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
    24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
    12 Mb/s; 48 Mb/s
    Extra:bcn_int=100
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (2) : CCMP TKIP
    Authentication Suites (1) : PSK


    Finally, when I put in /sbin/lspci -v, I get:

    ... snip ...
    00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
    Subsystem: Lenovo ThinkPad T61
    Flags: bus master, fast devsel, latency 0, IRQ 4345
    Memory at fe000000 (32-bit, non-prefetchable) [size=128K]
    Memory at fe025000 (32-bit, non-prefetchable) [size=4K]
    I/O ports at 1840 [size=32]
    Capabilities: <access denied>
    Kernel driver in use: e1000e
    Kernel modules: e1000e
    ... snip ...
    03:00.0 Ethernet controller: Atheros Communications Inc. AR5212 802.11abg NIC (rev 01)
    Subsystem: IBM ThinkPad 11a/b/g Wireless LAN Mini Express Adapter (AR5BXB6)
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at df3f0000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: ath_pci
    Kernel modules: ath_pci, ath5k
    ... snip ...


    There you have it. Thanks for any help you can give me.

    Matt

  2. #2
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Wireless with Atheros AR5212 on Opensuse 11 and Lenovo T

    looking through this i find
    ath0 IEEE 802.11g ESSID:"MattCed" Nickname:""
    Mode:Managed Frequency:2.462 GHz Access Point: 00:17:33:72:74:45
    Bit Rate:36 Mb/s Tx-Power:8 dBm Sensitivity=1/1
    Retryff RTS thrff Fragment thrff
    Power Managementff
    Link Quality=52/70 Signal level=-45 dBm Noise level=-97 dBm
    Rx invalid nwid:355580 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon
    if that is your router,you are connected,so, there must be a problem elsewhere. have you checked the usual bits ? i.e.
    1 ) firewall,
    2 )ipv6 turned off,
    3 )encryption is the same as the router, hex to hex,ascii to ascii,passphrase to passphrase
    4 ) if using MAC address filtering, yours is added to filter

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  3. #3
    MattGEvans NNTP User

    Default Re: Wireless with Atheros AR5212 on Opensuse 11 and Lenovo T

    Thanks for your help, Andy.

    I've found a somewhat satisfactory solution to the problem. First, I should say that I have what's called a "Neuf Box" connected to the phone line coming in from outside the house. The Neuf Box has various cables running from it that provide Internet, telephone, and cable tv access. The 9 Box also sends out the wireless signal throughout the house. That's the way things typically work here in France.

    Back to my solution: it seems that the problem may be linked to the Gateway. When I type "/sbin/route -n" into a Terminal, I get the following output:
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 ath0
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 ath0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

    From what I've gathered, the Gateway that I need isn't identified correctly.

    So, as root, I need to type the following command into a Terminal:
    “route add default gw 192.168.1.1”

    Now, when I type in "/sbin/route -n" I get the following:
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 ath0
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 ath0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 ath0
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

    At that point the wireless connection works.

    There is one catch: every time I boot up I have to type “route add default gw 192.168.1.1” into a Terminal as root. Yet, in YaST > Network Devices > Network Settings > on the tab “Routing” I've already set the Default Gateway as 192.168.1.1.

    If the Gateway is set and saved in YaST, why do I have to go through this maneuver in the Terminal every time I boot up?

    Matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •