One of the problems I've had with KDE4.1 was with kwrite saving an entry but when one went back to open it the entry was invisible. This was for new documents only.
It turns out it was listed on the KDE bugzilla as Bug 167767. They're calling it resolved even though this seems more like a workaround than a fix.
First the problem: For a new document you would type in say, The cow jumped over the moon. Then click Save As type in Cow Moon,close kwrite or even kate & leave it. Then later you'd open Cow Moon & nothing would be there. I pressed either F11 or enter & that'd get it back. The best results were from pressing enter because that'd move the line down one. Then it'd stay after a discard or save box came up I'd click save then close. It'd be seen, but it was down one space.
Now the workaround: 1st open kwrite go to settings configure editor & uncheck Dynamic Wordwrap.
Then if you should write anything into kwrite or kate make sure to get at least 2 lines.
Using my example one could open one of these text editors type it in like so:
Cow Moon
The cow jumped over the moon

Then click save as title it whatever & it'll be there completely upon opening.
I this helps those that had the same problem.