Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: YaST got signal 6 at YCP

  1. #1

    Default YaST got signal 6 at YCP

    Hello!

    I can not open any icon in Yast control center. All trials end up with messages containing YaST got signal 6 at YCP and all on line 421. Do you know what could be wrong? I am using Opensuse 11 64-bit version.

    terminate called after throwing an instance of 'YUIPluginException'
    what(): Couldn't load plug-in gtk
    YaST got signal 6 at YCP file Wizard.ycp:688
    /sbin/yast2: line 421: 5582 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    user and group:
    /usr/lib64/YaST2/plugin/libpy2gtk.so.2: /usr/local/lib/libpng12.so.0: no version information available (required by /usr/lib64/libcairo.so.2)
    terminate called after throwing an instance of 'YUIPluginException'
    what(): Couldn't load plug-in gtk
    YaST got signal 6 at YCP file Wizard.ycp:688
    /sbin/yast2: line 421: 5690 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    Software management:
    /usr/lib64/YaST2/plugin/libpy2gtk.so.2: /usr/local/lib/libpng12.so.0: no version information available (required by /usr/lib64/libcairo.so.2)
    terminate called after throwing an instance of 'YUIPluginException'
    what(): Couldn't load plug-in gtk
    YaST got signal 6 at YCP file SlideShow.ycp:76
    /sbin/yast2: line 421: 5724 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    Best reg MAgnus

  2. #2
    Join Date
    Aug 2008
    Location
    127.0.0.1
    Posts
    22

    Default Re: YaST got signal 6 at YCP

    On Fri, 05 Sep 2008 06:16:01 +0700, magmos 019
    <magmos_019@no-mx.forums.opensuse.org> wrote:

    > terminate called after throwing an instance of 'YUIPluginException'
    > what(): Couldn't load plug-in gtk


    have you installed yast2-gtk ?

  3. #3

    Default Re: YaST got signal 6 at YCP

    rv77ax!

    What I did was the following commands;
    zypper remove yast2-libyui
    zypper install yast2-libyui
    zypper install yast2-ycp-ui-bindings
    zypper install yast2-update
    zypper install yast2-qt
    zypper install yast2-ncurses

    After this I can start yast and run different modules but it does not look the same as before and it seems to miss some modules. When I try to add som modules, for example samba server it goes back to the eratic state. Yast-gtk is installed. Below is the results of rpm -qa | grep yast2 after this procedure. Far below is a list of what was removed with "zypper remove yast2-libyui".

    Best reg Magnus


    rpm -qa | grep yast2:
    yast2-storage-2.16.26-0.1
    autoyast2-installation-2.16.19-0.1
    yast2-users-2.16.33-6.1
    yast2-country-data-2.16.26-6.1
    yast2-ycp-ui-bindings-2.16.47-5.1
    yast2-country-2.16.26-6.1
    yast2-network-2.16.48-3.1
    yast2-ncurses-2.16.27-8.1
    yast2-theme-openSUSE-2.16.38-2.1
    yast2-core-2.16.51-6.1
    yast2-trans-stats-2.15.0-87.1
    yast2-libyui-2.16.48-3.1
    yast2-2.16.71-6.1
    yast2-ldap-2.16.0-52.1
    yast2-bootloader-2.16.20-0.1
    yast2-packager-2.16.53-3.1
    yast2-add-on-2.16.8-6.1
    yast2-qt-pkg-2.16.47-0.2
    yast2-hardware-detection-2.16.1-49.1
    yast2-xml-2.16.1-14.1
    yast2-gtk-2.16.14-1.2
    yast2-mouse-2.16.1-26.1
    yast2-firewall-2.16.2-25.1
    yast2-installation-2.16.50-3.1
    yast2-online-update-2.16.15-6.1
    yast2-qt-2.16.53-5.1
    yast2-slp-2.16.0-25.1
    yast2-trans-en_US-2.16.9-1.1
    yast2-perl-bindings-2.16.7-14.1
    yast2-pam-2.16.2-17.1
    yast2-registration-2.16.7-4.1
    yast2-ncurses-pkg-2.16.14-0.2
    yast2-storage-lib-2.16.26-0.1
    yast2-transfer-2.16.1-76.1
    yast2-update-2.16.10-4.1
    yast2-security-2.16.1-16.1
    yast2-ldap-client-2.16.16-6.1

    zypper remove yast2-libyui:
    Removing gnome-applets-2.22.1-29.1 [done]
    Removing yast2-printer-2.16.32-3.1 [done]
    Removing yast2-profile-manager-2.16.1-27.1 [done]
    Removing yast2-registration-2.16.7-4.1 [done]
    Removing yast2-repair-2.16.12-4.1 [done]
    Removing yast2-restore-2.16.2-26.1 [done]
    Removing yast2-runlevel-2.16.5-15.1 [done]
    Removing yast2-samba-server-2.16.3-15.1 [done]
    Removing yast2-samba-client-2.16.9-3.1 [done]
    Removing yast2-scanner-2.16.10-13.1 [done]
    Removing yast2-add-on-2.16.8-6.1 [done]
    Removing yast2-apparmor-2.16.4-4.1 [done]
    Removing yast2-backup-2.16.5-7.1 [done]
    Removing yast2-control-center-gnome-2.13.3-11.1 [done]
    Removing yast2-control-center-2.16.2-11.1 [done]
    Removing yast2-firewall-2.16.2-25.1 [done]
    Removing yast2-inetd-2.16.0-27.1 [done]
    Removing yast2-irda-2.16.1-25.1 [done]
    Removing yast2-iscsi-client-2.16.14-6.1 [done]
    Removing yast2-kerberos-client-2.16.11-9.1 [done]
    Removing yast2-mail-2.16.6-2.1 [done]
    Removing yast2-metapackage-handler-0.8.5-16.1 [done]
    Removing yast2-nfs-client-2.16.1-26.1 [done]
    Removing yast2-nis-client-2.16.3-6.1 [done]
    Removing yast2-ntp-client-2.16.9-11.1 [done]
    Removing yast2-online-update-frontend-2.16.15-6.1 [done]
    Removing yast2-online-update-2.16.15-6.1 [done]
    Removing yast2-vm-2.16.5-7.1 [done]
    Removing yast2-x11-2.15.12-15.1 [done]
    Removing yast2-sudo-2.16.1-27.1 [done]
    Removing yast2-users-2.16.33-6.1 [done]
    Removing yast2-ldap-client-2.16.16-6.1 [done]
    Removing yast2-ldap-2.16.0-52.1 [done]
    Removing yast2-network-2.16.48-3.1 [done]
    Removing yast2-packager-2.16.53-3.1 [done]
    Removing yast2-installation-2.16.50-3.1 [done]
    Removing autoyast2-installation-2.16.19-0.1 [done]
    Removing yast2-mouse-2.16.1-26.1 [done]
    Removing yast2-update-2.16.10-4.1 [done]
    Removing yast2-ncurses-pkg-2.16.14-0.2 [done]
    Removing yast2-security-2.16.1-16.1 [done]
    Removing yast2-pam-2.16.2-17.1 [done]
    Removing yast2-country-2.16.26-6.1 [done]
    Removing yast2-support-2.16.1-6.1 [done]
    Removing yast2-sysconfig-2.16.0-28.1 [done]
    Removing yast2-tune-2.16.2-2.1 [done]
    Removing yast2-bootloader-2.16.20-0.1 [done]
    Removing yast2-storage-2.16.26-0.1 [done]
    Removing yast2-tv-2.16.6-7.1 [done]
    Removing yast2-sound-2.16.11-6.1 [done]
    Removing yast2-2.16.71-6.1 [done]
    Removing yast2-ncurses-2.16.27-8.1 [done]
    Removing yast2-gtk-2.16.14-1.2 [done]
    Removing yast2-perl-bindings-2.16.7-14.1 [done]
    Removing yast2-ycp-ui-bindings-2.16.47-5.1 [done]
    Removing yast2-libyui-2.16.48-3.1 [done]

  4. #4
    Join Date
    Aug 2008
    Location
    127.0.0.1
    Posts
    22

    Default Re: YaST got signal 6 at YCP

    On Fri, 05 Sep 2008 06:16:01 +0700, magmos 019
    <magmos_019@no-mx.forums.opensuse.org> wrote:
    >
    > user and group:
    > /usr/lib64/YaST2/plugin/libpy2gtk.so.2: /usr/local/lib/libpng12.so.0:
    > no version information available (required by /usr/lib64/libcairo.so.2)
    > terminate called after throwing an instance of 'YUIPluginException'
    > what(): Couldn't load plug-in gtk
    > YaST got signal 6 at YCP file Wizard.ycp:688
    > /sbin/yast2: line 421: 5690 Aborted $ybindir/y2base
    > $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    >
    > Software management:
    > /usr/lib64/YaST2/plugin/libpy2gtk.so.2: /usr/local/lib/libpng12.so.0:
    > no version information available (required by /usr/lib64/libcairo.so.2)
    > terminate called after throwing an instance of 'YUIPluginException'
    > what(): Couldn't load plug-in gtk
    > YaST got signal 6 at YCP file SlideShow.ycp:76
    > /sbin/yast2: line 421: 5724 Aborted $ybindir/y2base
    > $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    >


    what about libpng12.so.0. why yast2 search on /usr/local/lib/ ?

    did libpng12.so.0 exist in /usr/local/lib/ or /usr/lib64/ ?
    it should be in /usr/lib64/.

    if it doesn't exist you should install them,
    if it exist maybe it's a bug, or libpng12.so.0 is 32 bit version.

    this is libpng12 in my *32-bit* (not 64) system,

    # file /usr/lib/libpng12.so.0
    /usr/lib/libpng12.so.0: symbolic link to `libpng12.so.0.26.0'

    # file /usr/lib/libpng12.so.0.26.0
    /usr/lib/libpng12.so.0.26.0: ELF 32-bit LSB shared object, Intel 80386,
    version 1 (SYSV), dynamically linked, stripped

    sorry i can't help much, since i'm using 32-bit version.

  5. #5

    Default Re: YaST got signal 6 at YCP

    Hello! Here are some answers on your questions rv77ax.

    what about libpng12.so.0. why yast2 search on /usr/local/lib/?

    I do not know why it search there.

    did libpng12.so.0 exist in /usr/local/lib/ or /usr/lib64/ ?
    it should be in /usr/lib64/.

    libpng12.so.0 exist in /usr/local/lib/, /usr/lib and /usr/lib64/. Below is the description of each file:

    ~> file /usr/lib/libpng12.so.0
    /usr/lib/libpng12.so.0: symbolic link to `libpng12.so.0.26.0'
    > file /usr/lib/libpng12.so.0.26.0
    /usr/lib/libpng12.so.0.26.0: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped

    ~> file /usr/local/lib/libpng12.so.0
    /usr/local/lib/libpng12.so.0: symbolic link to `libpng12.so.0.1.2.8'
    ~> file /usr/local/lib/libpng12.so.0.1.2.8
    /usr/local/lib/libpng12.so.0.1.2.8: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, not stripped

    ~> file /usr/lib64/libpng12.so.0
    /usr/lib64/libpng12.so.0: symbolic link to `libpng12.so.0.26.0'
    ~> file /usr/lib64/libpng12.so.0.26.0
    /usr/lib64/libpng12.so.0.26.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

    if it doesn't exist you should install them,
    if it exist maybe it's a bug, or libpng12.so.0 is 32 bit version.

    How do I reinstall them?

    Best reg MAgnus

  6. #6
    Join Date
    Aug 2008
    Location
    127.0.0.1
    Posts
    22

    Default Re: YaST got signal 6 at YCP

    On Fri, 05 Sep 2008 23:26:01 +0700, magmos 019
    <magmos_019@no-mx.forums.opensuse.org> wrote:
    >
    > How do I reinstall them?
    >
    > Best reg MAgnus
    >
    >


    first, i think it's a bug in one of rpm file, either gtk, libpng, or
    others.
    you should filed one to openSuSE bugzilla.

    i do some search on google, and found this one:

    ----
    http://www.centos.org/modules/newbb/...er=ASC&start=0
    ----

    try to follow the last step in that forum. or
    in your cases, do something like this (like the one suggested in that
    forum) :

    $ cd /usr/local/lib
    $ mkdir tmp
    $ mv libpng12* tmp
    $ ldconfig

    and try to YaST again, and see how it's going.

  7. #7

    Default Re: YaST got signal 6 at YCP

    I had the same error message when starting yast2 sw_single

    yast2 sw_single
    terminate called after throwing an instance of 'YUIPluginException'
    what(): Couldn't load plug-in qt
    YaST got signal 6 at YCP file SlideShow.ycp:76
    /sbin/yast2: line 421: 13353 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    I have solved this for my system, you may not have the same cause but I'll include the process as it may help with diagnosis:

    Summary
    libpcre.so.0 existed in /usr/local/lib and /usr/lib
    (and the files were different) the one in /usr/local/lib was being used (when I would expect system software to use /usr/lib)

    moving /usr/local/lib/libpcre.so.0.0.1 to /usr/local/lib/xlibpcre.so.0.0.1

    prevented it from being used and yast2 sw_single now works correctly

    (I also moved it back to check, as I was fixing something else at the time, to recreate the problem I needed to run ldconfig as ldd indicated that the version in /usr/lib was still being used)

    The Long version
    My system exhibited two other problems which eventually lead me to solving this one;

    1)Yast2 didn't work crashing with the message shown in the start of the thread (and this post)

    2)An a new install of yum (to play with as it is on my CentOS /RedHat boxes) crashed with:
    There was a problem importing one of the Python modules
    required to run yum. The error leading to this problem was:
    Code:
       /usr/lib/libglib-2.0.so.0: undefined symbol: pcre_get_stringtable_entries
    
    Please install a package which provides this module, or
    verify that the module is installed correctly.
    
    It's possible that the above module doesn't match the
    current version of Python, which is:
    2.5.2 (r252:60911, Aug  1 2008, 00:43:38
    [GCC 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036]]
    
    If you cannot solve this problem yourself, please go to
    the yum faq at:
      YumFaq - Linux@Duke Project Wiki
    3)A compile of openmovieeditor was failing with
    Code:
    libglib-2.0.so: undefined reference to `pcre_get_stringtable_entries'

    Investigating libglib-2.0.so


    ldd -r /usr/lib/libglib-2.0.so.0
    returned:
    Code:
     linux-gate.so.1 =>  (0xffffe000)
            libpcre.so.0 => /usr/local/lib/libpcre.so.0 (0xb7e66000)
            libc.so.6 => /lib/libc.so.6 (0xb7d23000)
            /lib/ld-linux.so.2 (0xb7f69000)
    undefined symbol: pcre_get_stringtable_entries  (/usr/lib/libglib-2.0.so.0)
    Strangely libpcre.so.o was being called from /usr/local/lib rather than usr/lib
    Comparing the two
    Code:
    ls -l /usr/lib |grep libpcre.so
    lrwxrwxrwx   1 root root       16 2008-07-02 16:54 libpcre.so -> libpcre.so.0.0.1
    lrwxrwxrwx   1 root root       16 2008-11-18 09:30 libpcre.so.0 -> libpcre.so.0.0.1
    -rwxr-xr-x   1 root root   167232 2008-06-23 13:44 libpcre.so.0.0.1
    and
    Code:
    ls -l /usr/local/lib |grep libpcre.so
    lrwxrwxrwx 1 root root       16 2006-04-25 09:36 libpcre.so -> libpcre.so.0.0.1
    lrwxrwxrwx 1 root root       16 2008-11-18 14:08 libpcre.so.0 -> libpcre.so.0.0.1
    -rwxr-xr-x 1 root root   284114 2006-04-25 09:36 libpcre.so.0.0.1

    My system was using a version from two years ago !
    mv /usr/local/lib/libpcre.so.0.0.1 /usr/local/lib/xlibpcre.so.0.0.1

    to break it temporarily (and the two symlinks to it)

    .. and as Robert is your Mums brother... yast2 was working again

    I hope this fixes you problem... of at least gives you some insight enabling you to do it
    Cheers Ian Hayhurst

  8. #8

    Default Re: YaST got signal 6 at YCP

    I now have the same problem, but found no way to solve it.
    It happened after I set up the Factory version of packagekit and then tried to switch back to the stable version.

    I tried to reinstall all possible Yast packages...

  9. #9
    phocean NNTP User

    Default Re: YaST got signal 6 at YCP


    I now have the same problem, but found no way to solve it.
    It happened after I set up the Factory version of packagekit and then
    tried to switch back to the stable version.

    I tried to reinstall all possible Yast packages...


    --
    phocean
    ------------------------------------------------------------------------
    phocean's Profile: http://forums.opensuse.org/member.php?userid=16374
    View this thread: http://forums.opensuse.org/showthread.php?t=394564


  10. #10

    Default Re: YaST got signal 6 at YCP

    Forget it. I just solved it with :
    # sudo zypper remove yast2-libyui

    Though just reinstalling was not enough.
    Uninstall all possible dependancies, taking note of them.

    Then, reinstall them all. That worked for me.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •