Results 1 to 3 of 3

Thread: Sound settings return to 0 after restart

  1. #1

    Default Sound settings return to 0 after restart

    Hi.

    I'm using openSUSE 11.0 with GNOME. When I start up, my volume settings are gone and replaced with these (output from amixer):

    Simple mixer control 'Master',0
    Capabilities: pvolume pswitch pswitch-joined
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Mono:
    Front Left: Playback 0 [0%] [-46.50dB] [off]
    Front Right: Playback 0 [0%] [-46.50dB] [off]
    Simple mixer control 'Master Mono',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback 0 - 31
    Mono: Playback 0 [0%] [-46.50dB] [off]
    Simple mixer control 'Headphone',0
    Capabilities: pvolume pswitch pswitch-joined
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Mono:
    Front Left: Playback 0 [0%] [-46.50dB] [off]
    Front Right: Playback 0 [0%] [-46.50dB] [off]
    Simple mixer control '3D Control - Center',0
    Capabilities: volume volume-joined
    Playback channels: Mono
    Capture channels: Mono
    Limits: 0 - 15
    Mono: 0 [0%]
    Simple mixer control '3D Control - Depth',0
    Capabilities: volume volume-joined
    Playback channels: Mono
    Capture channels: Mono
    Limits: 0 - 15
    Mono: 0 [0%]
    Simple mixer control '3D Control - Switch',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [off]
    Simple mixer control 'PCM',0
    Capabilities: pvolume pswitch pswitch-joined
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Mono:
    Front Left: Playback 0 [0%] [-34.50dB] [off]
    Front Right: Playback 0 [0%] [-34.50dB] [off]
    Simple mixer control 'PCM Out Path & Mute',0
    Capabilities: enum
    Items: 'pre 3D' 'post 3D'
    Item0: 'pre 3D'
    Simple mixer control 'Line',0
    Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Front Left: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Front Right: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Simple mixer control 'CD',0
    Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Front Left: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Front Right: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Simple mixer control 'Mic',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Mono
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Mono: Playback 0 [0%] [-34.50dB] [off]
    Front Left: Capture [on]
    Front Right: Capture [on]
    Simple mixer control 'Mic Boost (+20dB)',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [off]
    Simple mixer control 'Mic Select',0
    Capabilities: enum
    Items: 'Mic1' 'Mic2'
    Item0: 'Mic1'
    Simple mixer control 'Video',0
    Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Front Left: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Front Right: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Simple mixer control 'Phone',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Mono
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Mono: Playback 0 [0%] [-34.50dB] [off]
    Front Left: Capture [off]
    Front Right: Capture [off]
    Simple mixer control 'IEC958',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [off]
    Simple mixer control 'IEC958 Playback AC97-SPSA',0
    Capabilities: volume volume-joined
    Playback channels: Mono
    Capture channels: Mono
    Limits: 0 - 3
    Mono: 3 [100%]
    Simple mixer control 'PC Speaker',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback 0 - 15
    Mono: Playback 0 [0%] [-45.00dB] [off]
    Simple mixer control 'Aux',0
    Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
    Capture exclusive group: 0
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Front Left: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Front Right: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Simple mixer control 'Mono Output Select',0
    Capabilities: enum
    Items: 'Mix' 'Mic'
    Item0: 'Mix'
    Simple mixer control 'Capture',0
    Capabilities: cvolume cswitch cswitch-joined
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 15
    Front Left: Capture 0 [0%] [0.00dB] [on]
    Front Right: Capture 0 [0%] [0.00dB] [on]
    Simple mixer control 'Mix',0
    Capabilities: cswitch cswitch-exclusive
    Capture exclusive group: 0
    Capture channels: Front Left - Front Right
    Front Left: Capture [off]
    Front Right: Capture [off]
    Simple mixer control 'Mix Mono',0
    Capabilities: cswitch cswitch-exclusive
    Capture exclusive group: 0
    Capture channels: Front Left - Front Right
    Front Left: Capture [off]
    Front Right: Capture [off]
    Simple mixer control 'External Amplifier',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [on]

    How can I get my sound settings to stick?

    Also -- I don't know if this is related... Yast --> Hardware --> Sound --> Volume fails to save my settings. For example, if I change my settings and click finish, those settings are not saved. In order to change my settings, I have to open that volume panel and then open a terminal window and run su -c 'alsactl store' to save my settings. Obviously, having both of these problems together is really annoying.

    Any help would be appreciated. Thanks!

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Sound settings return to 0 after restart

    Quote Originally Posted by comidacomer View Post
    Also -- I don't know if this is related... Yast --> Hardware --> Sound --> Volume fails to save my settings. For example, if I change my settings and click finish, those settings are not saved. In order to change my settings, I have to open that volume panel and then open a terminal window and run su -c 'alsactl store' to save my settings.
    Does not typing su -c 'alsactl store' save your settings, such that they survive a reboot?

    If it were me, and if YaST and "alsactl store" were not saving my settings, I would write a bug report on YaST.
    Submitting Bug Reports - openSUSE

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Sound settings return to 0 after restart

    I forgot to ask, ... if you do a speaker test with root permissions after a reboot ... ie
    su -c 'speaker-test -Dplug:front -c2 -l5 -twav'
    if that works, then this is permissions related, and may be solveable by adding your regular user to group audio.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •