Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Zypper update-problems (repository XY is out of date...)

  1. #1

    Default Zypper update-problems (repository XY is out of date...)

    Hello all,

    I have configured the following repositories:
    Code:
    # | Alias                                                        | Name                      | Enabled | Refresh
    --+--------------------------------------------------------------+---------------------------+---------+--------
    1 | openSUSE-DVD 11.0                                            | openSUSE-DVD 11.0         | No      | No     
    2 | NVIDIA                                                       | NVIDIA                    | Yes     | Yes    
    3 | VLC                                                          | VLC                       | Yes     | Yes    
    4 | http://download.opensuse.org/distribution/11.0/repo/oss/     | Main Repository (OSS)     | Yes     | Yes    
    5 | http://download.opensuse.org/distribution/11.0/repo/non-oss/ | Main Repository (NON-OSS) | Yes     | Yes    
    6 | NVIDIA Repository                                            | NVIDIA Repository         | Yes     | Yes    
    7 | Packman                                                      | Packman                   | Yes     | Yes    
    8 | http://download.opensuse.org/update/11.0/                    | Main Update Repository    | Yes     | Yes    
    9 | repo-debug                                                   | openSUSE-11.0-Debug       | No      | No
    Since a few days, I cannot update or install new software with "zypper up" or "zypper install [package-name]. I always receive the following error-message:

    Code:
    Downloading package opensc-0.11.4-37.2.i586 (1/34), 523.0 K (1.7 M unpacked)
    Downloading delta: ./rpm/i586/opensc-0.11.4-37.1_37.2.i586.delta.rpm, 312.1 K
    Downloading: opensc-0.11.4-37.1_37.2.i586.delta.rpm [done]
    Can't provide file './rpm/i586/opensc-0.11.4-37.1_37.2.i586.delta.rpm' from repository 'http://download.opensuse.org/update/11.0/'
    Downloading: opensc-0.11.4-37.2.i586.rpm [done]
    Downloading: repomd.xml [done]
    Problem downloading the package file from the repository:
    Can't provide ./rpm/i586/opensc-0.11.4-37.2.i586.rpm : Can't copy /var/adm/mount/AP_0x00000001/rpm/i586/opensc-0.11.4-37.2.i586.rpm to /var/cache/zypp/packages/http:__download.opensuse.org_update_11.0_
    Repository 'http://download.opensuse.org/update/11.0/' is out of date. Running 'zypper refresh' might help.
    I have already removed the "/var/cache/zypp"-directory. I also have recreated all repositories and refreshed with "zypper ref". Then I also have rebuilded the rpm-database (rpm --rebuilddb) -> no success. I also linked the repositories to an openSuSE-mirror -> no success.

    I'm successful with "zypper lr". But as soon as I want to update with "zypper up", the error-messages above appears.

    I don't have an idea, what this problem is.
    Kind regards,
    Tom

  2. #2
    Join Date
    Jul 2008
    Posts
    11

    Default Re: Zypper update-problems (repository XY is out of date...)

    Hello,

    I'm having the same problem as you on the past few weeks when I run the opensuse updates.

    I also tried running 'zypper refresh', create the /var/amd/mount/AP_00000XYZ directory manually, etc but nothing fix this issue.

    Any helps is appreciated.

    Thanks,

    Luciano

  3. #3
    Join Date
    Sep 2008
    Location
    Switzerland
    Posts
    31

    Default Re: Zypper update-problems (repository XY is out of date...)

    Patches cannot be installed

    Hello

    I Have so evenly installed opensuse 11,0 x86_64 on the basis of a net ISO CD, downloaded and installed from mirror.switch.ch; so far everything ok

    After OS install:
    Unfortunately as far as I try to install the patches from the update repository this misshapens. I suspect that possibly one rpm' which is on update schedule did install wrongly during the opensuse operating system installation so that it cannot be correctly overwritten by the update patch When I start yast2update, shortly after the yast2 program has loaded it's repositories I get the following error message:

    Error with the initialization of the Repositorys. ' repo-non-oss': No valid meta data at the indicated address (URL) found The following errors arose: - Can' t CoPy /var/adm/mount/AP_0x00000001/suse/setup/descr/packages.DU.gz ton of /var/cache/zypp/raw/repo-non-ossFNdn8d - Can' t provide /suse/setup/descr/packages.DU.gz: Can' t CoPy /var/adm/mount/AP_0x00000001/suse/setup/descr/packages.DU.gz ton of /var/cache/zypp/raw/repo-non-ossFNdn8d

    I guess this is the same problem as yours?
    Thank's for your feedback

  4. #4
    Join Date
    Jul 2008
    Posts
    11

    Default Re: Zypper update-problems (repository XY is out of date...)

    Hi Dagalbert,

    I think you have the same problem as ours because I tried to remove the sub-directories on the "/var/cache/zypp" directory and when I run "zypper refresh", I have the same error message as yours:

    Can't provide /suse/setup/descr/packages.en.gz : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/packages.en.gz to /var/cache/zypp/raw/repo-non-ossGdR5bK
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'openSUSE-11.0-Non-Oss' because of the above error.

    For information, I've installed openSUSE 11.0 x86_64 early July and the updates was running fine until end of August.

  5. #5

    Default Re: Zypper update-problems (repository XY is out of date...)

    Dagalbert,

    Yes, it's the same error as I receive. I replaced the opensuse-update, opensuse-oss and the opensuse-non-oss repositories with the ftp-server from "mirror.switch.ch". So, I did not receive any error-messages, when I enter "zypper update". I also can install software without any error-messages.

    But, with the switch-mirror, I receive no update-list, when I enter "zypper lu". When I configure zypper to get the updates from the the original openSuSE-mirrors, I receive four or fives recommended updates, but I'm not able to install them because of the following error-message:
    Code:
    Can't provide file './rpm/i586/opensc-0.11.4-37.1_37.2.i586.delta.rpm' from repository 'http://download.opensuse.org/update/11.0/'
    Downloading: opensc-0.11.4-37.2.i586.rpm [done]
    Downloading: repomd.xml [done]
    Problem downloading the package file from the repository:
    Can't provide ./rpm/i586/opensc-0.11.4-37.2.i586.rpm : Can't copy /var/adm/mount/AP_0x00000001/rpm/i586/opensc-0.11.4-37.2.i586.rpm to /var/cache/zypp/packages/http:__download.opensuse.org_update_11.0_
    Repository 'http://download.opensuse.org/update/11.0/' is out of date. Running 'zypper refresh' might help.
    ...
    ...
    ...
    Something is strange out there....

  6. #6
    Join Date
    Sep 2008
    Location
    Switzerland
    Posts
    31

    Default Re: Zypper update-problems (repository XY is out of date...)

    Hello Puzzled Penguin

    Thank's for your news, I don't want to lure anyone into a missunderstanding, as far as I know mirror.switch.ch is an operating system installation mirror.

    I ignore if mirror.switch.ch deserves updates but I guess it doesn't I just mentionned it because of the thought to give any data of the circumnstances at my end of the wire,


    By posting on a german forum :

    LINUX • openSUSE - Patches lassen sich nicht installieren

    There I've been told to change to another mirror.; I'll do so these next days.


    At german forum they told me that there was or is anything not in order with non-OSS Repo

    so I asked back if it could be that a non working non OSS Repo eventually would cause other patch updates installations from the other repositorys not to work anymore correctly?


    Is it right Puzzled Penguin ..? that in your case it is the update 11.0 repository which is not working? Do you know or do you suspect which repositories seem to be concerned in your case?

    Thank's for your post.

  7. #7
    Join Date
    Jun 2008
    Location
    Geneva/Switzerland
    Posts
    39

    Default Re: Zypper update-problems (repository XY is out of date...)

    I have a full out of the net opensuse 11.0 installed.
    All the repositories that I added are from the "official" list.
    As follow :
    BuildService - Database, PHP, Mail, Mozilla, X11GL, VitualBox, OpenOffice.org, KDE:Community, KDE:Backports, Wine CVS Builds, NVIDIA
    Packman
    VideoLan
    Oss
    and finally the non-OSS repository.

    I have the same problem with the openSUSE-11-0-Updates repository. i.e.
    Can't provide ./rpm/adm/libopensc2-0.11.4-37.2.i586.rpm : Can't copy /var/adm/mount/AP_0x00000001/rpm/i586/libopensc2-0.11.4-37.2.i586.rpm to /var/cache/zypp/packages/openSUSE-11.0-Updates Le dpot 'openSUSE-11.0-Updates' n'est plus jour.

    I have tried zypper refresh, rebuild the rpm db, erase the repository from list and recreate it.

    All worked fine until last week, I though about some bug in the repository and told myself to try again later...

    On the other hand, I feel less alone in the dark
    Box: i7-2700K CPU@3.50GHz | 32GbRAM | 14Tb HDD | nVidia GTX 690 | openSuSE 12.2-64 | KDE 4.8.5
    Lap: Lenovo W510 i7 820QM | 8GbRAM | 500Gb SSD | nVidia Quadro FX 880M | openSuSE12.2-64 | KDE 4.8.5

  8. #8

    Default Re: Zypper update-problems (repository XY is out of date...)

    hello,

    have a look to the following thread:
    Zypper Update/Installation-Problems - openSUSE Forums

    the solution is to replace the original opensuse-repositories with a mirror-repository. In my case, this is now working.

  9. #9
    Join Date
    Jul 2008
    Posts
    11

    Default Re: Zypper update-problems (repository XY is out of date...)

    Hi tamgarten,

    I replaced my repositories with the mirror-urls (also mirror.switch.ch for me) and the problem remains the same...

    This is very strange because I selected to upgrade only the kernel (alone) and it worked fine.

    So, after the kernel upgrade, I restarted opensuse and tried to update the others packages, but I still have the error

    Code:
    The following packages are going to be upgraded:
      gvfs-backends libsmbclient0 cifs-mount
    
    
    The following NEW patches are going to be installed:
      gvfs samba
    
    
    Overall download size: 2.7 M. After the operation, additional 4.1 M will be used.
    Continue? [YES/no]: 
    Downloading package libsmbclient0-3.2.3-0.1.x86_64 (1/5), 1.1 M (3.7 M unpacked)
    Downloading: libsmbclient0-3.2.3-0.1.x86_64.rpm [done]
    Downloading: repomd.xml [done]
    Problem downloading the package file from the repository:
    Can't provide ./rpm/x86_64/libsmbclient0-3.2.3-0.1.x86_64.rpm : Can't copy /var/adm/mount/AP_0x00000004/rpm/x86_64/libsmbclient0-3.2.3-0.1.x86_64.rpm to /var/cache/zypp/packages/openSUSE_Updates
    And when we go to opensuse Mirror Selection site, it's clearly said :
    You don't need to select a mirror yourself. If you use download.opensuse.org (Index of /distribution, respectively Index of /update), it takes care of everything. This site will automatically select one of the mirrors from a database and redirect the download. See Build_Service/Redirector for (technical) details on how this works.

    Any hints?
    Thanks

  10. #10

    Default Re: Zypper update-problems (repository XY is out of date...)

    But the Mirror Selection - openSUSE site also said:
    If you would like to use a different mirror, or want to see all mirrors where you could download a file from, you can browse to Index of /distribution and click on the 'Mirrors' link. Find the mirror lists for openSUSE 11.0 DVD images for example, here: Index of /distribution/11.0/iso/dvd

    Did you refresh your zypper-repository with "zypper ref"? Did you also rebuild your rpm-database with "rpm --rebuilddb"?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •