Results 1 to 8 of 8

Thread: openSuSE 10,3 sudo hangs

  1. #1
    Join Date
    Jun 2008
    Posts
    16

    Default openSuSE 10,3 sudo hangs

    OpenSUSE 10.3 freshly installed from scratch on a DELL PC.

    When clicking the Sudo icon in Yast / Security&Users, the system hangs: A window frame is displayed with Help, Abort
    and Finish buttons at the bottom, but nothing inside the window specific to Sudo dialog screen. The pointer (with crawling beads)just keeps on crawling forever (waited for more than an hour).

    At closing the window a message appears "Window not responding. The window belongs to the application qt (PID=10605, hostname=localhost) Do you wish to terminate?"

    Tried it several times with reboots in between. Always the same behaviour.

    (For the rest everything works fine)

    On a PC with exactly the same hardware (in every respect) with OpenSuSE 10.2, no problem.

    How come???

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: openSuSE 10,3 sudo hangs

    * pdon,

    rename /etc/sudoers and try again.

    Uwe

  3. #3
    Join Date
    Jun 2008
    Posts
    16

    Default Re: openSuSE 10,3 sudo hangs

    I moved /etc/sudoers to /etc/sudoers.old
    restarted the system - now starting Yast
    exits immediatly with error window Sudo - error.

    renamed /etc/sudoers.old back to /etc/sudoers
    Yast now starting, but Sudo from Yast still hangs...

  4. #4
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: openSuSE 10,3 sudo hangs

    * pdon,

    rename it again, then create a blank one ("touch /etc/sudoers" as root)
    Any difference?

    Uwe

  5. #5
    Join Date
    Jun 2008
    Posts
    16

    Default Re: openSuSE 10,3 sudo hangs

    no help
    Yast again gives window with
    "su returned an error"

  6. #6
    Join Date
    Jun 2008
    Posts
    16

    Default Re: openSuSE 10,3 sudo hangs

    Also tried the following:
    # chmod 440 /etc/sudoers
    (touch /etc/sudoers created with slightly different access rights)
    Edited the empty /etc/sudoers via
    # visudo
    and copied the contents of the sudoers.old
    file into it.
    The contents is centainly OK - I checked with
    another OpenSUSE 10.3 system where YAST sudo is no problem. A diff shows no difference.

    Still, Yast Sudo hangs ...

  7. #7
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: openSuSE 10,3 sudo hangs

    * pdon,

    weird, my system behaves differently when I try that. I recommend you reinstall the yast2-sudo package to see if that helps.

    Uwe

  8. #8
    Join Date
    Jun 2008
    Posts
    16

    Default Re: openSuSE 10,3 sudo hangs

    this seems to solve the problem..
    Thx for your help..

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •