Results 1 to 7 of 7

Thread: Really Freaking strange desktop behavior

  1. #1

    Default Really Freaking strange desktop behavior

    Ok, So I installed ATI Livna Drivers and my display looks great and I am running dual monitors on a laptop. The normal monitor and an external 27".

    The strange part is the keyboard only works on one monitor.
    The mouse works on both.

    On the external monitor I can open application but only with the mouse and the application windows do not have a border. The top area that says openSuse an enables you do move the window around.
    It isnt there. It tried alt +f3, but as I said the keyboard only works on display1 (laptop). Therefor all key commands revert back to the laptop monitor.

    What the ????
    This shouldnt be possible

  2. #2

    Default Re: Really Freaking strange desktop behavior

    Any ideas, Still having the same problem. How is it possible for the keyboard only to work on one monitor?

  3. #3
    Join Date
    Jun 2008
    Location
    Concord, California
    Posts
    253

    Default Re: Really Freaking strange desktop behavior

    It sounds like you have it setup to have two seperate X sessions. There are two ways to setup dual monitors. one is to have a single X session span the two monitors. The other is to have two seperate X sessions.

    I don't know about the ATI drivers. But you should be able change it in sax2. (in YaST or console window by typing sax2)
    OpenSUSE Leap 15, KDE5 (plasma 5.13, frameworks 5.49, QT 5.11)

  4. #4

    Default Re: Really Freaking strange desktop behavior

    that is exactly what is is doing. It like having two operating systems running. How do I stop it. sax2 isnt active because of the ati driver

  5. #5

    Default Re: Really Freaking strange desktop behavior

    open suse automatically boots into the dual x sessions. If I try to run suse without dual monitors it wont start.

    I dont want it on I just want to stop the dual x sessions.

    ATI Cataylist doesnt have any setting they are all grayed out and sax2 cant find any displays, so I have no idea what is causing this

    HELP???

  6. #6

    Default Re: Really Freaking strange desktop behavior

    that is definatly the problem

    ech $display results in :0.0 and 0.1
    how to I kill the 0.1 if I dont have a working keyboard in that x server?

  7. #7

    Default Re: Really Freaking strange desktop behavior

    I use two monitors configured as separate X screens. Gnome handles them very well.

    If you're not getting any window borders and can't use the keyboard, this suggests you aren't running a window manager on the problem display.

    So install fvwm via YaST and then try, from your primary display, the one called :0.0, the command:

    fvwm -d :0.1 -s

    The -d tells fvwm, a window manager, to run on display 0:1, the -s says run on only one display.

    You'll see something from 15 years ago appear (I love fvwm) but you should see window borders and be able to type into a terminal window.

    If that works, we can see what can be done to get you working with something like Gnome or KDE.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •