Results 1 to 4 of 4

Thread: hibernate suspend works on CLI, not from GUI

  1. #1
    MrStanaland NNTP User

    Default hibernate suspend works on CLI, not from GUI

    I hope somebody can help...I've spent most of the day trying to fix this already!!

    I got a new laptop and installed Opensuse 11.0 on it. The laptop is a Dell Studio. I am trying to get hibernate and suspend working from GUI programs, like kpowersave. After spending much of the day searching forums and google, I've learned this:

    The following work perfectly from the command line (as root):
    s2ram -f

    The following do NOT work as root OR user:
    powersave -U
    powersave -u
    KDE or Gnome GUI programs don't work

    When I try powersave at the commandline, it just seems to hang until I hit Ctrl-C. The GUI programs have no result. The system continues running as if nothing happened.

    My understanding is that the problem is related to HAL or PolicyKit but I don't know how they work to try to debug them. The config files seem fine and it is a fresh install (with all updates installed).

    If anyone has any suggestions, let me know! Your help is truly appreciated!
    Last edited by MrStanaland; 01-Sep-2008 at 21:02. Reason: Forgot to explain "doesn't work"

  2. #2
    Join Date
    Jun 2008
    Auckland, NZ
    Blog Entries

    Default Re: hibernate suspend works on CLI, not from GUI

    If 's2ram -f' works from a root console, then try creating a file called '/etc/pm/config.d/config' containing the string:

    KPowersave should work ok then.

  3. #3
    MrStanaland NNTP User

    Default Re: hibernate suspend works on CLI, not from GUI

    Thanks for your suggestions, but I've already tried that one. I do think your suggestions will help suspend work once the problem is solved. I believe that powersave has to work from the command line before kpowersave will work.

    More Info:
    I am reading through the kpowersave documentation. It says "it is advisable to set DEBUG to 7 or 15 to increase the verbosity of the powersaved and of the proxy scripts." Does anybody know what "set DEBUG" means? Google hasn't help me with this.

  4. #4
    MrStanaland NNTP User

    Default Re: hibernate suspend works on CLI, not from GUI

    More Criteria Discovered:

    -If I set kpowersave to NOT start on log in
    -> then I can use powersave -U or powersave -u
    -> this works repeatedly without problems
    -> until I start kpowersave....then neither GUI or CLI work
    -> powersave CLI does not work again until I log out/into KDE
    (killing kpowersave does not make powersave CLI begin to work)

    -If I set kpowersave to start on log in
    -> Neither kpowersave GUI or powersave CLI work

    Next I will try in Gnome.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts