Results 1 to 5 of 5

Thread: Which version of Samba am I using?

  1. #1
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Which version of Samba am I using?

    Hey all,

    Can I tell from Konsole which version of Samba I am using?

    I was reading in a Linux mag a new version (3.2 I think) is out.

    Thanks

    Heeter
    Linux Counter 475994

  2. #2
    Join Date
    Jul 2008
    Location
    Manistique, MI
    Posts
    64

    Default Re: Which version of Samba am I using?

    At a konsole try ~>samba --version
    Example:
    Code:
    lindy@lindys_contraption:~> rpm --version
    RPM version 4.4.2
    Sometimes ~><program> --help will tell you how to see the version (generally -v or --version).
    Obscurum per obscurius.
    -The obscure (explained) by the more obscure.

  3. #3
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Re: Which version of Samba am I using?

    Thanks J,

    But that is not working.

    Would you have another way?

    Heeter
    Linux Counter 475994

  4. #4
    Join Date
    Jul 2008
    Location
    Manistique, MI
    Posts
    64

    Default Re: Which version of Samba am I using?

    Yes... You can try ~>zypper info <package>
    Example:
    Code:
    lindy@lindys_contraption:~> zypper info rpm
    Information for package rpm:
    
    Repository: openSUSE-11.0-Oss
    Name: rpm
    Version: 4.4.2-199.1
    Arch: i586
    Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
    Installed: Yes
    Status: up-to-date
    Installed Size: 3.7 M
    Summary: The RPM Package Manager
    Description:
    RPM Package Manager is the main tool for managing the software packages
    Or you can try ~>rpm -q <package>
    Example:
    Code:
    lindy@lindys_contraption:~> rpm -q rpm
    rpm-4.4.2-199.1
    Obscurum per obscurius.
    -The obscure (explained) by the more obscure.

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Which version of Samba am I using?

    Quote Originally Posted by Heeter View Post
    Thanks J,

    But that is not working.

    Would you have another way?

    Heeter
    console command: rpm -qa | grep samba
    You get about 6 returns -- look for samba alone, like this:
    e.g.samba-3.2.3-0.1.128 --> version 3.2.3
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •