Results 1 to 10 of 10

Thread: Compiling Fahmon problems

  1. #1

    Default Compiling Fahmon problems

    I keep trying to compile Fahmon and the problem i am having is about wxWidgets. I compiled and installed the latest wxWidgets yet the configure script from Fahmon tells me it cannot find it in the proper library path. I checked ld.so.conf and seen that /usr/local/lib and /usr/lib64 are listed in there. I ran ldconfig as well.

    Here is the error im getting and proof to show that i have 2.8.8 installed.

    checking dependency style of g++... gcc3
    checking for wx-config... /usr/local/bin/wx-config
    checking for wxWidgets version >= 2.8.0... no
    configure: error:
    wxWidgets must be installed on your system.

    Please check that wx-config is in path, the directory
    where wxWidgets libraries are installed (returned by
    'wx-config --libs' or 'wx-config --static --libs' command)
    is in LD_LIBRARY_PATH or equivalent variable and
    wxWidgets version is 2.8.0 or above.

    unimatrix:~/FahMon-2.3.2b # wx-config --version
    2.8.8
    unimatrix:~/FahMon-2.3.2b #



    any ideas?

    OS: openSuSE 64bit 11

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,110
    Blog Entries
    15

    Default Re: Compiling Fahmon problems

    Quote Originally Posted by scoobaspeaz
    I keep trying to compile Fahmon and the problem i am having is about
    wxWidgets. I compiled and installed the latest wxWidgets yet the
    configure script from Fahmon tells me it cannot find it in the proper
    library path. I checked ld.so.conf and seen that /usr/local/lib and
    /usr/lib64 are listed in there. I ran ldconfig as well.

    Here is the error im getting and proof to show that i have 2.8.8
    installed.

    checking dependency style of g++... gcc3
    checking for wx-config... /usr/local/bin/wx-config
    checking for wxWidgets version >= 2.8.0... no
    configure: error:
    wxWidgets must be installed on your system.

    Please check that wx-config is in path, the directory
    where wxWidgets libraries are installed (returned by
    'wx-config --libs' or 'wx-config --static --libs'
    command)
    is in LD_LIBRARY_PATH or equivalent variable and
    wxWidgets version is 2.8.0 or above.

    unimatrix:~/FahMon-2.3.2b # wx-config --version
    2.8.8
    unimatrix:~/FahMon-2.3.2b #



    any ideas?

    OS: openSuSE 64bit 11
    Hi
    You probably need the devel version installed as well.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 2 days 15:54, 1 user, load average: 0.20, 0.09, 0.12
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  3. #3

    Default Re: Compiling Fahmon problems

    when compiling wxWidgets from source you would have the binary installed as well as the libraries. :/

    Ty for the reply though..this has me confused.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,110
    Blog Entries
    15

    Default Re: Compiling Fahmon problems

    Quote Originally Posted by scoobaspeaz
    when compiling wxWidgets from source you would have the binary installed
    as well as the libraries. :/

    Ty for the reply though..this has me confused.
    Hi
    Missed the bit where you compiled the wx-Widgets. Have you tried adding
    the option to tell it where the libraries are? See ./configure --help
    and that should give you an option to tell it where wx-Widgets is eg
    --libdirs=/usr/lib64

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 2 days 16:15, 1 user, load average: 0.07, 0.11, 0.09
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  5. #5

    Default Re: Compiling Fahmon problems

    Tried that as well :/

  6. #6

    Default Re: Compiling Fahmon problems

    bumping for hope :/

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,110
    Blog Entries
    15

    Default Re: Compiling Fahmon problems

    Quote Originally Posted by scoobaspeaz
    bumping for hope :/
    Hi
    Why not uninstall the wxWidgets you compiled from source and try the
    rpms from openSUSE http://software.opensuse.org/search including the
    devel one from the Application:Geo repository (Best to add it to
    pickup any dependencies, which seem to be a few....(compat, gl,
    gl-compat etc)

    The error I got was "checking for wx-config... no" Once installed as
    above configured without issues.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 3 days 18:48, 1 user, load average: 0.16, 0.16, 0.14
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  8. #8

    Default Re: Compiling Fahmon problems

    Thank you for all your help but i solved the solution. Suse 11 doesnt come standard with wxwidgets with unicode support. Actually you cant find the rpm for it.

    I compiled the latest version of wxwidgets 2.8.8 with the --enable-unicode support flag and then installed it. Fahmon is compiling as i type this

    for more information: #143 (Building of fahmon2.3.2b fails on openSUSE 10.3 (x86_64) using wxWidget version 2.8.0) - FahMon - Trac

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,110
    Blog Entries
    15

    Default Re: Compiling Fahmon problems

    Quote Originally Posted by scoobaspeaz
    Thank you for all your help but i solved the solution. Suse 11 doesnt
    come standard with wxwidgets with unicode support. Actually you cant
    find the rpm for it.

    I compiled the latest version of wxwidgets 2.8.8 with the
    --enable-unicode support flag and then installed it. Fahmon is
    compiling as i type this

    for more information: '#143 (Building of fahmon2.3.2b fails on openSUSE
    10.3 (x86_64) using wxWidget version 2.8.0) - FahMon - Trac'
    (http://trac.fahmon.net/ticket/143)
    Hi
    Glad you have it sorted. I would like to make a comment though re the
    rpms, I had a look at the src spec file, it does enable unicode as
    long as using gtk2. So I would guess if you built from the src rpm
    all should be enabled.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 3 days 21:43, 2 users, load average: 0.08, 0.17, 0.21
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  10. #10

    Default Re: Compiling Fahmon problems

    ty for the reply..just for the record though i used the source tarball. I never did like source rpms.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •