Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: no sound at all in openSuSE

  1. #1

    Exclamation no sound at all in openSuSE

    ive just installed the new realtek coder AC97 Audio and now i dont have and sound at all in my pc!! please help !!

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: no sound at all in openSuSE

    Quote Originally Posted by offshore View Post
    ive just installed the new realtek coder AC97 Audio and now i dont have and sound at all in my pc!! please help !!
    Please try to work your way through the openSUSE audio troubleshooting guide to get your audio working:
    SDB:AudioTroubleshooting - openSUSE

    If you do not succeed after going from start to finish in that guide, then we need more information in order to help.

    With your computer connected to the internet, please copy and paste the following into a gnome-terminal / konsole:
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your sound card (for example my PC has 3 i/o plugs/jacks on the motherboard). When the script completes it will pass you a URL. Please post that URL here.

    Also, please copy and paste the following into a gnome-terminal / konsole and post the output here.
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

  3. #3

    Default Re: no sound at all in openSuSE

    the troubleshooting didnt help much, so ive done the next steps, here is the url that the terminal gave after answering the questions of the first code tsalsa.txt - nopaste.com (beta)

    then here is the output of the next lines

    linux-alei:/home/george # rpm -qa | grep alsa
    alsa-oss-1.0.15-48.1
    alsa-utils-1.0.16-35.1
    alsa-1.0.16-39.1
    alsa-plugins-1.0.16-57.1
    alsa-plugins-pulse-1.0.16-57.1
    linux-alei:/home/george # rpm -qa | grep pulse
    pulseaudio-utils-0.9.10-26.5
    libpulse0-0.9.10-26.5
    pulseaudio-module-gconf-0.9.10-26.5
    libpulse-browse0-0.9.10-26.5
    pulseaudio-module-x11-0.9.10-26.5
    pulseaudio-module-bluetooth-0.9.10-26.5
    pulseaudio-0.9.10-26.5
    pulseaudio-module-zeroconf-0.9.10-26.5
    libpulsecore4-0.9.10-26.5
    gstreamer-0_10-pulse-0.9.7-42.pm.1
    pulseaudio-esound-compat-0.9.10-26.5
    alsa-plugins-pulse-1.0.16-57.1
    libpulse-mainloop-glib0-0.9.10-26.5
    pulseaudio-module-lirc-0.9.10-26.5
    linux-alei:/home/george # rpm -q libasound2
    libasound2-1.0.16-39.1
    linux-alei:/home/george # uname -a
    Linux linux-alei 2.6.25.11-0.1-pae #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux
    linux-alei:/home/george # cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel,snd-intel8x0
    # NXNs.DVbS_qxEbm1:RV630/M76 audio device [Radeon HD 2600 Series]
    alias snd-card-0 snd-hda-intel
    # r0Vg.6tUyCrVQna9:GA-8I915ME-G Mainboard
    alias snd-card-1 snd-intel8x0


    i have to mention that when i press the volume button on the system tray i get this message

    The volume control did not find any elements and/or devices to control. This means either that you don't have the right GStreamer plugins installed, or that you don't have a sound card configured.

    You can remove the volume control from the panel by right-clicking the speaker icon on the panel and selecting "Remove From Panel" from the menu

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: no sound at all in openSuSE

    Quote Originally Posted by offshore View Post
    the troubleshooting didnt help much, so ive done the next steps, here is the url that the terminal gave after answering the questions of the first code tsalsa.txt - nopaste.com (beta)
    Thanks for that.


    Quote Originally Posted by offshore View Post
    i have to mention that when i press the volume button on the system tray i get this message
    The volume control did not find any elements and/or devices to control. This means either that you don't have the right GStreamer plugins installed, or that you don't have a sound card configured.
    That error message confirms what the script indicates. Your sound card is not being detected by alsa.

    The tsalsa script notes you have and Audio device: ATI Technologies Inc RV630/M76 audio device. I did a search on alsa for the RV630/M76 and I obtained this: Search results for RV630/M76 - AlsaProject which suggests to me that support for this device was first introduced in 1.0.15 / 1.0.16 of alsa. openSUSE-11.0 comes with 1.0.16 of alsa, so this should work with your openSUSE-11.0. BUT the tsalsa script also notes you alsa lib is version 1.0.14 . I can't see how that could possibly happen, unless by mistake you downgraded to 1.0.14 of alsa or the "new realtek coder AC97 Audio" did that. The tsalsa also indicates you do not have an alsa driver, which makes no sense given you have 1.0.16 of alsa rpm installed, unless of course, the "new realtek coder AC97 Audio" caused this problem.

    Specifically, I note you provided this information on installed alsa rpms:
    Quote Originally Posted by offshore View Post
    linux-alei:/home/george # rpm -qa | grep alsa
    alsa-oss-1.0.15-48.1
    alsa-utils-1.0.16-35.1
    alsa-1.0.16-39.1
    alsa-plugins-1.0.16-57.1
    alsa-plugins-pulse-1.0.16-57.1
    Which makes no reference to 1.0.14 of alsa. So I am left here noting there is an inconsistency between the script and the rpms you have, and thus I have to deduce the "new" realtek coder AC97 Audio is NOT so new, but is based on an old alsa 1.0.14.

    I do not know exactly what the "new" realtek coder AC97 Audio has done to your PC, and could very well be I end up giving inaccurate recommendations as a result. But I'll try my best.

    Still, I recommend you update your alsa to the very latest drivers/libraries, so as to remove any consistency problems that you appear to have as a result of this failed ""new" realtek coder AC97 Audio" attempt. Do this by opening a gnome-terminal / konsole and type "su" to get root permissions (enter root password when prompted). Then once you have root permissions in a gnome-terminal / konsole , with your PC connected to the internet, in that same gnome-terminal / konsole copy and paste the following six commands, one line at a time, in the exact sequence provided, into the gnome-terminal / konsole (executing them one after another):
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
    Code:
    zypper install alsa alsa-utils alsa-oss alsa-plugins alsa-plugins-pulse alsa-tools alsa-firmware libasound2
    Code:
    zypper rr multimedia
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ multimedia
    Code:
    zypper install alsa-driver-kmp-pae
    Code:
    zypper rr multimedia
    then restart your PC and test your audio.

    If your audio still does not work then, please post run the tsalsa script again:
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    and also rpm the rpm commands again:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2


    and post here the output URL from the tsalsa script and the output of the rpm commands.

  5. #5

    Default Re: no sound at all in openSuSE

    the problem isnt solved but there is no such error message when im pressing the volume option in the system tray. there is the tsalsa script output.

    and there is the output of the next lines

    linux-alei:/home/george # rpm -qa | grep alsa
    alsa-plugins-pulse-1.0.17.git20080827-1.2
    alsa-firmware-1.0.17.git20080617-2.1
    alsa-driver-kmp-pae-1.0.16.20080902_2.6.25.11_0.1-2.1
    alsa-tools-1.0.17.git20080715-1.11
    alsa-1.0.17.git20080901-1.1
    alsa-utils-1.0.17.git20080820-1.1
    alsa-oss-1.0.17.git20080715-2.9
    alsa-plugins-1.0.17.git20080827-1.2
    linux-alei:/home/george # rpm -qa | grep pulse
    pulseaudio-utils-0.9.10-26.5
    alsa-plugins-pulse-1.0.17.git20080827-1.2
    libpulse0-0.9.10-26.5
    pulseaudio-module-gconf-0.9.10-26.5
    libpulse-browse0-0.9.10-26.5
    pulseaudio-module-x11-0.9.10-26.5
    pulseaudio-module-bluetooth-0.9.10-26.5
    pulseaudio-0.9.10-26.5
    pulseaudio-module-zeroconf-0.9.10-26.5
    libpulsecore4-0.9.10-26.5
    gstreamer-0_10-pulse-0.9.7-42.pm.1
    pulseaudio-esound-compat-0.9.10-26.5
    libpulse-mainloop-glib0-0.9.10-26.5
    pulseaudio-module-lirc-0.9.10-26.5
    linux-alei:/home/george # rpm -q libasound2
    libasound2-1.0.17.git20080901-1.1

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: no sound at all in openSuSE

    Quote Originally Posted by offshore View Post
    the problem isnt solved but there is no such error message when im pressing the volume option in the system tray. there is the tsalsa script output.
    Thanks, that looks better, BUT you still may have a problem. I note this from tsalsa script:
    Code:
    Alsa driver: 1.0.18rc1        
    Alsa lib: 1.0.14        
    Alsa utils: 1.0.18rc2
    That indicates you still have a 1.0.14 alsa library, which is a hang over from the realtek driver that you tried to install. That has really messed things up, and short of a custom compile/install of alsa lib, I don't know how to get rid of that (and I am not even certain a custom compile/of alsa lib will solve that - maybe a re-install is needed). Alsa lib can be found here:
    ftp://ftp.alsa-project.org/pub/lib/a....0.17a.tar.bz2

    But lets leave 1.0.14 for now where it is ... and not do ANYTHING drastic, .... and instead, lets work with what you have got. I notice this from tsalsa:
    Amixer contents for card 1 [ICH6] _____________________________________
    amixer set 'Master',0 100%,100% on
    amixer set 'Master Mono',0 0% off
    amixer set 'PCM',0 0% off 0% off
    amixer set 'Surround',0 0% off 0% off
    amixer set 'Surround Jack Mode',0 Items: 'Shared' 'Independent' Item0: 'Shared'
    amixer set 'Center',0 100% off
    amixer set 'LFE',0 0% off
    amixer set 'Line',0 0% off 0% off Capture off
    amixer set 'CD',0 0% off 0% off Capture off
    amixer set 'Mic',0 0% off Capture on
    amixer set 'Mic Boost (+20dB)',0 off
    amixer set 'Mic Select',0 Items: 'Mic1' 'Mic2' Item0: 'Mic1'
    amixer set 'Video',0 Capture off
    amixer set 'Phone',0 0% off Capture off
    amixer set 'IEC958',0 off Capture off
    amixer set 'IEC958 Playback AC97-SPSA',0 Mono: 3 100%
    amixer set 'IEC958 Playback Source',0 Items: 'PCM' 'Analog In' 'IEC958 In' Item0: 'PCM'
    amixer set 'PC Speaker',0 0% off
    amixer set 'Aux',0 0% off 0% off Capture off
    amixer set 'Mono Output Select',0 Items: 'Mix' 'Mic' Item0: 'Mix'
    amixer set 'Capture',0 Capture 15 100%,Capture 15 100% on
    amixer set 'Mix',0 Capture off
    amixer set 'Mix Mono',0 Capture off
    amixer set 'Channel Mode',0 Items: '2ch' '4ch' '6ch' Item0: '2ch'
    amixer set 'Duplicate Front',0 off
    amixer set 'External Amplifier',0 on
    The items I highlighet in red could be incorrectly set. Especially the PCM. That should almost always be around 60 to 70% or so.

    After that update, in addition to going into your mixer to try adjust the sound, also go into YaST > Hardware > Sound and edit your sound config ... and if that fails, try running: su -c alsaconf

  7. #7

    Default Re: no sound at all in openSuSE

    sound returned after i installed the library but the volume is very low though all the meters in Pulse AudioVolume Control are in 100%, what now?

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: no sound at all in openSuSE

    Quote Originally Posted by offshore View Post
    sound returned after i installed the library but the volume is very low though all the meters in Pulse AudioVolume Control are in 100%, what now?
    How did you install the library? Do you build it from the tarball?

    Did you try going to:
    YAST > Hardware > Sound > Other > Volume and move your slider bars there up to around 60% or 70%.

    Did you investigate the mixer options that I suggested you look at?

  9. #9

    Default Re: no sound at all in openSuSE

    How did you install the library? Do you build it from the tarball?
    i downloaded the file above (ftp://ftp.alsa-project.org/pub/lib/a....0.17a.tar.bz2)

    and i installed it (./configure, make, make install)

    then the sound worked, after i wrote in the terminal su -c alsaconf
    the loudspeaker in the system tray got an X and after the restart i had again no sound , shall i try to install the file above again??

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,642
    Blog Entries
    14

    Default Re: no sound at all in openSuSE

    open a terminal, type 'alsamixer', you will see all the channels on the device. Alsaconf is known to mute all channels
    Anyway, it's better to download a complete 'alsa-set', driver, libs, everything; install the libs first, then driver and others, then run 'alsaconf' as root to configure it.
    Then, in your graphical mixer, check that it shows all the available channels, and that the mixericon in the system tray is handling the right channel

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •