Results 1 to 5 of 5

Thread: Soundcard woe

Hybrid View

  1. #1
    doc_white NNTP User

    Question Soundcard woe

    On a new install of SUSE 11 and KDE 4.0 I am unable to get any* sound from my speakers. Sound does comes through the headphone socket. This is the case for different sound sources CD, MP3, WAV and different applications Amarok, KsCD, Real Player and Flash.

    I have run the online update and there are no patches left to install.

    YaST 2 shows the soundcard as a Creative SB Audigy 2 and that the driver (EMU10K1_Audigy) is active.

    alsaconf command detects sound card but again sound is only through the headphones. My version of Alsa is 1.0.16 and I have downloaded version 1.0.17 but don't know how to get YaST to install it.
    * Just before alsaconf plays it's test file my speakers make a noise like they have just been switched on/off.

    Any advice would be welcome but keep it simple as I am really new to Linux. The speakers work fine in Windows XP (this is a dual boot system) so I am confident this is a software/driver issue.

  2. #2
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: Soundcard woe

    Since you get sound through the headphones i suspect that you do not have the speakers connected properly. I have the same card and it works without problems.
    If you co to yast > hardware and select other on the bottom right you van test your sound. If this does not work you can have a read here of all else fails maybe our sound guru oldcpu may be able to help when he gets back online

    /Geoff
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  3. #3
    doc_white NNTP User

    Default Re: Soundcard woe

    Went through YaST and tested sound, works through headphones but not speakers. Sounds like it plays the alsaconf wave file.

    Speakers are working in Windows XP which identifies the card as an Audigy 2 ZS (WDM), listening as I type.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,489
    Blog Entries
    37

    Default Re: Soundcard woe

    Quote Originally Posted by doc_white View Post
    Went through YaST and tested sound, works through headphones but not speakers. Sounds like it plays the alsaconf wave file.

    Speakers are working in Windows XP which identifies the card as an Audigy 2 ZS (WDM), listening as I type.
    I might be able to help, but typically I ask for a LOT of information in order to come up with a recommendation.

    First, can you check out this "solution" to see if it helps you:
    [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums

    failing that, you could run a script that comes with 1.0.17 alsa (not with earlier versions of alsa)/. Simply type in a gnome-terminal / konsole:
    /usr/sbin/alsa-info.sh
    and that should provide a bunch of information about your audio configuration, and if your PC is connected to the internet, in the end paste it to an alsa site. When complete, please post the URL that it gives here.

    If that script does not work, then to provide more information, then with your PC connected to the internet, please copy and paste the following into a gnome-terminal / konsole:
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

    Also, please copy and paste the following, one line at a time, into a gnome-terminal/konsole and post the output here.
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

    Good luck (and hopefully the first link will work for you so that you do not have to go thru the rest to give information)!

  5. #5
    doc_white NNTP User

    Thumbs up Re: Soundcard woe

    Thanks. The first link worked a treat, the analogue/digital jack setting was muted.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •