Results 1 to 9 of 9

Thread: Problem viewing avi & mov

  1. #1

    Default Problem viewing avi & mov

    I've been running OpenSUSE 11 for two weeks now and like it so far. Only this that VLC won't play the avi or mov files correctly. Sometime it will play the sound but no picture and I have try change the video output settings to everything. In Ubuntu I was able to rip dvd's play everything vlc. I'm going to give this another day. In gnome then I'm going to try the KDE desktop and see if the experience it better. Files wouldn't play in totem either. But when I logged in as root totem would play both avi & mov files (crazy). I'm sure I'll find a workaround.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Problem viewing avi & mov

    Quote Originally Posted by vwbond View Post
    I've been running OpenSUSE 11 for two weeks now and like it so far. Only this that VLC won't play the avi or mov files correctly. Sometime it will play the sound but no picture and I have try change the video output settings to everything. In Ubuntu I was able to rip dvd's play everything vlc. I'm going to give this another day. In gnome then I'm going to try the KDE desktop and see if the experience it better. Files wouldn't play in totem either. But when I logged in as root totem would play both avi & mov files (crazy). I'm sure I'll find a workaround.
    My understanding is vlc can give you problems if:
    a. you mix packman packaged rpms (such as those that provide codecs) with videolan packaged rpms (such as those that provide codecs);
    b. you have special desktop effects enabled, in which case the video output module "auto" nor "xv" (xvideo) will possibly not work well, in which case you need to select "x11" as an output video mode/module in your video player (vlc in this case).
    c. if you move up the vlc player volume control too much, you get a lot of audio distortion. Keep the vlc player volume control low around 20% or so.

    I recommend when installing openSUSE that the very first thing users do is setup their software repositories with 4, and only 4 repositories. That is: OSS, NON-OSS, Update and Packman. One can add more repositories when they know more about the quirks of openSUSE, but not until then. I've been using openSUSE for years, and I typically only enable those 4. You can learn how to do that here:
    Repositories/11.0 - openSUSE-Community

    Install ONLY the 4 that I mentioned. ie. OSS, NON-OSS, Update, and Packman. If you have already set up more, remove them.

    Then ensure your vlc and libffpmeg0 are packaged by Packman (replace any videolan versions now).

    Also, note my advice in items a-c above, and you should not have problems with vlc playing video.

    As for KDE, I recommend you do NOT try KDE-4.0.4 that comes with openSUSE-11.0 Novell Packaged CD (nor Novell packaged DVD). If you can't solve a simple vlc problem, I seriously doubt you will solve buggy KDE-4.0.4 problems. Stick with KDE-3.5.9. Or if you feel you really MUST try KDE-4 then try the KDE-4.1 liveCD that is hosted on the kde.org site:
    "KDE Four Live" CD

    Don't waste your time with KDE-4.0.4. (IMHO of course).

  3. #3

    Default Re: Problem viewing avi & mov

    I did what you advised, as for as VLC is considered.
    Didn't have this issue with Ubuntu anyway I reinstalled Opensuse 11 with KDE 3.5 and installed VLC (only got the four repositories enabled) and it still doesn't play avi's or .mov. Is there a converter I can use in suse to convert them to .ogg files. I need a fix or workaround or I'll have to return to Ubuntu. I need to be able to view .avi, mov, dvd, ogg, mp4 and rip and burn DVD's.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Problem viewing avi & mov

    Quote Originally Posted by vwbond View Post
    I did what you advised, as for as VLC is considered.
    Didn't have this issue with Ubuntu anyway I reinstalled Opensuse 11 with KDE 3.5 and installed VLC (only got the four repositories enabled) and it still doesn't play avi's or .mov. Is there a converter I can use in suse to convert them to .ogg files. I need a fix or workaround or I'll have to return to Ubuntu. I need to be able to view .avi, mov, dvd, ogg, mp4 and rip and burn DVD's.
    Ok, then you will have to provide specific examples with PRECISE details. I am confident we can solve this, but don't let my confidence disuade you from returning to Ubuntu. I have two friend who use Ubuntu ... and they like it, despite the problems that they have (and I don't). .... If Ubuntu does what you want, then go for it! Stick with what works for you. And if I can take my moderator hat off for a second, on a personal note, please don't post " I need a fix or workaround or I'll have to return to Ubuntu" .. if you don't have the patience, then please just go to Ubuntu. Like I say, my friends like Ubuntu. Also I do not want to waste my time if a user is not going to give SuSE more of a chance. (In truth, all that comments like that do is irritate ... and as I note, ... I have friends who like Ubuntu).

    Now reference your problem ...

    If your movie file is "mymovie.avi" please type:
    file mymovie.avi
    and post here the output.

    Please also post here the output of:
    rpm -q libffmpeg0 vlc libxine1 xvid libquicktime0

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Problem viewing avi & mov

    Quote Originally Posted by vwbond View Post
    Is there a converter I can use in suse to convert them to .ogg files. I need a fix or workaround or I'll have to return to Ubuntu. I need to be able to view .avi, mov, dvd, ogg, mp4 and rip and burn DVD's.
    A converter? I don't think openSUSE is any different from Ubuntu here. In terms of one file to another file format, then avidemux is hard to beat.

    You need to spend some time looking at the packman site. Go to its advanced search engine, and search on the codecs you mention:
    PackMan :: website
    Note the "tab" on that site for search. Its a great search engine.

    Also, if you have trouble playing ogg files, then please copy and paste the following into a terminal and post here the output (as ogg should play with no problem):
    rpm -q libtheora0 ffmpeg2theora flac libvorbis libogg0

  6. #6

    Default Re: Problem viewing avi & mov

    Thanks for the tip about the codecs I check them out when I get home. I'm going to reinstall Gnome their is to much extra clicking in KDE 3.5. Any way I just visited VLC's site and it doesn't have standard support for avi or mov. So hope fully I can get the codecs I need to add the functionality of playing avi and mov in VLC.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Problem viewing avi & mov

    Quote Originally Posted by vwbond View Post
    I just visited VLC's site and it doesn't have standard support for avi or mov. So hope fully I can get the codecs I need to add the functionality of playing avi and mov in VLC.
    I play .mov and various .avi (of different codecs) in VLC all the time with no hiccups. (although I prefer smplayer over vlc). I have this vlc capability with KDE-3.5.7 (on openSUSE-10.3) and KDE-3.5.9 (on openSUSE-11.1) in all cases only using Packman packaged rpms.

    Good luck with your efforts.

  8. #8

    Default Re: Problem viewing avi & mov

    Thank for you help.
    I reinstalled the OS using the Live CD -just because.
    Installed VLC via packman. Then I installed the codec for .avi & mov. Now I can play those file without problem.

    The only problem I have now it that when visiting Apple.com none of the videos play.How could I fix firefox so I can watch their content.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Problem viewing avi & mov

    Quote Originally Posted by vwbond View Post
    Thank for you help.
    I reinstalled the OS using the Live CD -just because.
    Installed VLC via packman. Then I installed the codec for .avi & mov. Now I can play those file without problem.

    The only problem I have now it that when visiting Apple.com none of the videos play.How could I fix firefox so I can watch their content.
    If you have the Packman repository added to your repos list, then simply install smplayer, MPlayer, mplayerplug-in and libquicktime0. Do this by copying and pasting:
    su -c 'zypper install smplayer mplayerplug-in libquicktime0'

    Enter root password when prompted for a password.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •