Results 1 to 5 of 5

Thread: autostart Conky in openSuSE 11 w/ Gnome

  1. #1
    afencl NNTP User

    Default autostart Conky in openSuSE 11 w/ Gnome

    Ok... I'm confused. I have a launcher on my desktop that runs the Conky program (basically runs /usr/bin/conky). If I login and double click this, everything works fine. If I copy this desktop file to ~/.config/autostart and then logout and back in, one of two things happens: 1) the "task bar" along the bottom doesn't appear and conky doesn't run .OR. 2) everything else if fine, but no conky.

    Now, conky DOES flash but seems to be starting before the desktop so when the desktop starts, it covers it up (I'm sort of making that up, but it kind of makes sense-- at least to me).

    I've tried this "by hand" as well as using gnome-session-properties and have played with the "order" on the Current Session tab in that app but still have the same results.

    What am I missing? Is there a better way to do this?

    THANKS in advance.

    Al Fencl

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,110
    Blog Entries
    15

    Default Re: autostart Conky in openSuSE 11 w/ Gnome

    Quote Originally Posted by afencl
    Ok... I'm confused. I have a launcher on my desktop that runs the Conky
    program (basically runs /usr/bin/conky). If I login and double click
    this, everything works fine. If I copy this desktop file to
    ~/.config/autostart and then logout and back in, one of two things
    happens: 1) the "task bar" along the bottom doesn't appear and conky
    doesn't run .OR. 2) everything else if fine, but no conky.

    Now, conky DOES flash but seems to be starting before the desktop so
    when the desktop starts, it covers it up (I'm sort of making that up,
    but it kind of makes sense-- at least to me).

    I've tried this "by hand" as well as using gnome-session-properties and
    have played with the "order" on the Current Session tab in that app but
    still have the same results.

    What am I missing? Is there a better way to do this?

    THANKS in advance.

    Al Fencl
    Hi
    Just tried it, worked fine here with the following autostart;

    Code:
    [Desktop Entry]
    Type=Application
    Encoding=UTF-8
    Version=1.0
    Name=No Name
    Name[en_US]=Conky
    Exec=/usr/bin/conky
    X-GNOME-Autostart-enabled=true
    Have you checked the /etc/conky/conky.conf file?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 1 day 6:15, 3 users, load average: 0.16, 0.42, 0.36
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  3. #3
    afencl NNTP User

    Default Re: autostart Conky in openSuSE 11 w/ Gnome

    Did a copy/paste into a new file in the .config/autostart directory with your code -- still isn't running (even checked with ps aux | grep conky). Like I said it *DOES* run from the shortcut on the desktop (even shows up via 'ps') so I'm pretty sure the config file is ok. Just incase, here is my config file (I'll leave out the TEXT portion of what I'm showing to save space)
    Code:
    alignment bottom_right
    background no
    border_width 1
    cpu_avg_samples 2
    default_color white
    default_outline_color white
    default_shade_color white
    draw_borders yes
    draw_graph_borders yes
    draw_outline no
    draw_shades no
    font 10x12
    gap_x 15
    gap_y 60
    minimum_size 5 5
    net_avg_samples 2
    no_buffers yes
    out_to_console no
    own_window no
    own_window_class Conky
    own_window_type normal
    stippled_borders 0
    update_interval 10.0
    uppercase no
    use_spacer none
    show_graph_scale no
    show_graph_range no
    Any ideas? Might it make a difference using ~/.conkyrc vs /etc/conky/conky.conf ??

    Hum....
    Al

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,110
    Blog Entries
    15

    Default Re: autostart Conky in openSuSE 11 w/ Gnome

    Quote Originally Posted by afencl
    Did a copy/paste into a new file in the .config/autostart directory with
    your code -- still isn't running (even checked with ps aux | grep
    conky). Like I said it *DOES* run from the shortcut on the desktop
    (even shows up via 'ps') so I'm pretty sure the config file is ok. Just
    incase, here is my config file (I'll leave out the TEXT portion of what
    I'm showing to save space)

    Code:
    --------------------

    alignment bottom_right
    background no
    border_width 1
    cpu_avg_samples 2
    default_color white
    default_outline_color white
    default_shade_color white
    draw_borders yes
    draw_graph_borders yes
    draw_outline no
    draw_shades no
    font 10x12
    gap_x 15
    gap_y 60
    minimum_size 5 5
    net_avg_samples 2
    no_buffers yes
    out_to_console no
    own_window no
    own_window_class Conky
    own_window_type normal
    stippled_borders 0
    update_interval 10.0
    uppercase no
    use_spacer none
    show_graph_scale no
    show_graph_range no

    --------------------


    Any ideas? Might it make a difference using ~/.conkyrc vs
    /etc/conky/conky.conf ??

    Hum....
    Al
    Hi
    So you have modified the /etc/conky/conky.conf??
    Code:
    own_window yes
    user_space no
    Mine is the default, it may be the own_window one which may be causing
    the problem.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 1 day 7:18, 3 users, load average: 0.08, 0.11, 0.15
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  5. #5
    Join Date
    Jun 2008
    Location
    USA
    Posts
    150

    Default Re: autostart Conky in openSuSE 11 w/ Gnome

    Quote Originally Posted by afencl View Post
    Ok... I'm confused. I have a launcher on my desktop that runs the Conky program (basically runs /usr/bin/conky). If I login and double click this, everything works fine. If I copy this desktop file to ~/.config/autostart and then logout and back in, one of two things happens: 1) the "task bar" along the bottom doesn't appear and conky doesn't run .OR. 2) everything else if fine, but no conky.

    Now, conky DOES flash but seems to be starting before the desktop so when the desktop starts, it covers it up (I'm sort of making that up, but it kind of makes sense-- at least to me).

    I've tried this "by hand" as well as using gnome-session-properties and have played with the "order" on the Current Session tab in that app but still have the same results.

    What am I missing? Is there a better way to do this?

    THANKS in advance.

    Al Fencl
    I had the same problem back when I used to use Ubuntu. What ended up fixing it for me was to delay starting conky till after the desktop was finished loading with a script something like this:

    Code:
    sleep 20 && conky -c .conkyrc-panel-1;
    This script was then placed in autostart. This way you have 20 seconds for the desktop to load.

    Don't know if this will help you or not. Hope so

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •