Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Zypper Update/Installation-Problems

Hybrid View

  1. #1

    Default Zypper Update/Installation-Problems

    Hello all,

    Often when I try to update or install software on my OpenSuSE 11.0-system with zypper, I get the following error:

    Code:
    Problem downloading the package file from the repository:
    
    Can't provide ./rpm/i586/libpulse0-0.9.10-26.5.i586.rpm : Can't copy /var/adm/mount/AP_0x00000001/rpm/i586/libpulse0-0.9.10-26.5.i586.rpm to /var/cache/zypp/packages/openSUSE-11.0-Updates
    Repository 'openSUSE-11.0-Updates' is out of date. Running 'zypper refresh' might help.
    It's not still the "libpulse0"-rpm, which can't be installed. I already have refreshed the zypper-repositories (zypper ref).
    I'm successful getting the failed RPM with wget.

    I have installed this repositories:
    # | Alias | Name | Enabled | Refresh
    --+-----------------------+-----------------------+---------+--------
    1 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
    2 | openSUSE-11.0-Updates | Updates for 11.0 | Yes | Yes
    3 | NVIDIA | NVIDIA | Yes | Yes
    4 | VLC | VLC | Yes | Yes
    5 | repo-oss | openSUSE-11.0-Oss | Yes | Yes
    6 | NVIDIA Repository | NVIDIA Repository | Yes | Yes
    7 | Packman | Packman | Yes | Yes
    8 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | Yes
    9 | repo-debug | openSUSE-11.0-Debug | No | No

    Thanks a lot for your help.
    Kind regards,
    T.

  2. #2
    Join Date
    Aug 2008
    Location
    Neuendorf, Switzerland
    Posts
    109

    Unhappy Re: Zypper Update/Installation-Problems

    I have the same problem.

  3. #3
    Join Date
    Aug 2008
    Location
    Brooklyn, NY
    Posts
    180

    Default Re: Zypper Update/Installation-Problems

    I would guess that you either lost your connection to the repository or the package does not exist at the repository. Does the error recur after 'zypper refresh'?

  4. #4

    Default Re: Zypper Update/Installation-Problems

    The package exists on the OpenSuSE-update-server.
    The error still recurs after a "zypper refresh".

  5. #5
    Join Date
    Aug 2008
    Location
    Zrich
    Posts
    6

    Default Re: Zypper Update/Installation-Problems

    I have the same problem as I already posted some days ago :Problem with "zypper dup" - openSUSE Forums.

    It's really bothering. Also if I choose a package to install in Yast I have to accept several times till it's installed definitively...

    any hints?

  6. #6

    Default Re: Zypper Update/Installation-Problems

    maybe try to use a local mirror for the main repositories ?

    See this previous post : PackageKit with Smart - openSUSE Forums

    The problem is well know, and some work are done actually : See Libzypp/Failover - openSUSE

  7. #7
    Join Date
    Aug 2008
    Location
    Zrich
    Posts
    6

    Default Re: Zypper Update/Installation-Problems

    Quote Originally Posted by Spyhawk View Post
    maybe try to use a local mirror for the main repositories ?

    See this previous post : PackageKit with Smart - openSUSE Forums

    The problem is well know, and some work are done actually : See Libzypp/Failover - openSUSE
    Thanks! that helped me! I switched from the redirector urls to fix mirrors (for me switch.ch) now things work fine. No I export via zypper lr -e <repofile> my settings. I recently installed my system and imported this repo file afte installtion. Now the "zypper dup" works fine

  8. #8

    Default Re: Zypper Update/Installation-Problems

    I think I have this configuration on my linux-box (and this works not fine for me)...but I will verify this.
    Thanks a lot for your answer.

  9. #9

    Thumbs up Re: Zypper Update/Installation-Problems

    Hello all,

    I replaced my repository-urls with the mirror.switch.ch-urls from zagoes....and WOW....now it's working . I had no problems with updating my openSuSE-box.

    But I still do not understand, why the zypper-update with the original-urls isn't working properly.
    Thanks.

  10. #10
    Join Date
    Aug 2008
    Location
    Neuendorf, Switzerland
    Posts
    109

    Default Re: Zypper Update/Installation-Problems

    Solved!

    The Education-Repository must be added:
    Index of /repositories/Education/openSUSE_11.0

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •