Results 1 to 9 of 9

Thread: VMware 1.0.6 problems with using USB Drive in VM

  1. #1

    Exclamation VMware 1.0.6 problems with using USB Drive in VM

    this is a post from yesterday i started and never got answered.
    id appreciate the help.

    i have the version 11.0 suse and im trying to be able to use a USB drive in a VM. Ive changed the **** in fstab, ive changed the stuff in the *.vmx files on my VM's, i added the usb drive and made it present, but when i go to install the usb drive after i installed vmware tools, it doesnt have anything there. i go through VM on the tool bar and choose removable devices and hold my mouse over USB and it says (empty) in the next window over. I'm using version 1.0.6 of VMware server. Is there anything else i can try?

  2. #2
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,434

    Default Re: VMware 1.0.6 problems with using USB Drive in VM

    > i have the version 11.0 suse and im trying to be able to use a USB
    > drive in a VM. Ive changed the **** in fstab, ive changed the stuff in
    > the *.vmx files on my VM's, i added the usb drive and made it present,
    > but when i go to install the usb drive after i installed vmware tools,
    > it doesnt have anything there. i go through VM on the tool bar and
    > choose removable devices and hold my mouse over USB and it says (empty)
    > in the next window over. I'm using version 1.0.6 of VMware server. Is
    > there anything else i can try?


    Try asking here:

    http://communities.vmware.com/community/vmtn/server

  3. #3
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,434

    Default Re: VMware 1.0.6 problems with using USB Drive in VM

    > http://communities.vmware.com/community/vmtn/server
    LOL. Nevermind I see you already have. :-)
    Actually I'm working on this issue myself but under 1.0.4.


  4. #4

    Default Re: VMware 1.0.6 problems with using USB Drive in VM

    ya, ive tried togo through the forums on vmware to see anything else that what i listed. but you know what im talking about the fstab and *.vmx changes right? i just dont know what else.

  5. #5
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,434

    Default Re: VMware 1.0.6 problems with using USB Drive in VM

    > ya, ive tried togo through the forums on vmware to see anything else
    > that what i listed. but you know what im talking about the fstab and
    > *.vmx changes right? i just dont know what else.


    Yes. I've struggled with USB devices and VMware quite a bit.
    I've been using Workstation since version 4 and Server since
    it came out. With Workstation you can work around the issue by
    mounting the device under the host OS and then setup up Host/Guest
    filesystem sharing. Can't do that with generic Server.

    I'm sure it's a permission/device lock that is causing it.
    On mine the device does not show up under USB devices in the VMware host
    menu. Is that what yours does?





  6. #6
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,434

    Default Re: VMware 1.0.6 problems with using USB Drive in VM

    Try this:

    open a shell.
    su to root.
    mount -t usbfs none /proc/bus/usb
    shut down your vm...don't pause it.
    and restart your vm.

    Check and see if your device is listed.

    I'm told you can also add

    usbfs /proc/bus/usb usbfs auto 0 0
    to /etc/fstab but requires a reboot of the host.



  7. #7

    Default Re: VMware 1.0.6 problems with using USB Drive in VM

    ha, so it worked.
    that is very surprising.
    thanks.


    This helped

    open a shell.
    su to root.
    mount -t usbfs none /proc/bus/usb
    shut down your vm...don't pause it.
    and restart your vm.

  8. #8
    rizwanje NNTP User

    Default Re: VMware 1.0.6 problems with using USB Drive in VM

    Hi could you plz explain what does mean Open shell ? and rest of the code and where to write it.

    open a shell ?
    su ? to root

  9. #9
    rizwanje NNTP User

    Default Re: VMware 1.0.6 problems with using USB Drive in VM


    Hi could you plz explain what does mean Open shell ? and rest of the
    code and where to write it.

    open a shell ?
    su ? to root


    --
    rizwanje
    ------------------------------------------------------------------------
    rizwanje's Profile: http://forums.opensuse.org/member.php?userid=16962
    View this thread: http://forums.opensuse.org/showthread.php?t=393934


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •