Results 1 to 5 of 5

Thread: How to use autofs in KDE4?

  1. #1
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Exclamation How to use autofs in KDE4?

    I had KDE3.5 in openSUSE 10.3 before and I used autofs to mount a remote folder from my desktop running NFS server. The trick was to have a link to a URL on the other computer Desktop to the shared folder, as soon as I clicked the link, the NFS folder automounted.

    Now, I have installed KDE4.1 and that trick doest work anymore. When I create a link to URL it creates an icon and appends a .desktop to it and when I click on it - nothing happens.

    Does anyone have autofs with KDE4? I can mount with fstab on boot or manually without a problem, that is theres no problem with mounting or server.

    Heres my auto.misc entry:
    Desktop -fstype=nfs4,rw,hard,intr,nosuid,proto=tcp,retry=10,rsize=32768,wsize=32768 desktop.home:/

    Please help. Thank you.
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  2. #2
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Default Re: How to use autofs in KDE4?

    ILL BE **********!!! I had --timout 60 instead of --timeout 60 in the auto.master, can you believe this?! Now it works again

    And as to the link, I simply placed a Folder View widget and pointed it to /mnt where my Desktop folder is being mounted, so I simply click on the Desktop and it shows all folders from my NFS server. Great!

    Ive already started downloading KDE3.5 when I thought Id give it just one last chance and noticed the stupidest typo, now Im going to leave KDE4 for a while, hope I can sort out some other issues before my patience runs out
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  3. #3
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Exclamation Re: How to use autofs in KDE4?

    Oooooh, was I too quick to be excited...

    It works fine while the NFS server is on. As soon as the NFS server is off and I click on the folder te computer hangs for a minute, then I could kill a dolphin process, then I can resume using the computer but dolphin is dead for good. I can browse my home folder with Konqueror but as soon as I go out to root, it hangs again until I kill it. And autofs will not stop or restart after this.

    I thought that's what the timeout was for? Could anyone help to fix this? How can I make autofs to recover from unavailable server? Thanks.
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  4. #4
    Join Date
    Jun 2008
    Location
    Frisco, TX
    Posts
    1,233

    Default Re: How to use autofs in KDE4?

    On Fri, 2008-08-29 at 00:16 +0000, linuxoidoz wrote:
    > Oooooh, was I too quick to be excited...
    >
    > It works fine while the NFS server is on. As soon as the NFS server is
    > off and I click on the folder te computer hangs for a minute, then I
    > could kill a dolphin process, then I can resume using the computer but
    > dolphin is dead for good. I can browse my home folder with Konqueror but
    > as soon as I go out to root, it hangs again until I kill it. And autofs
    > will not stop or restart after this.
    >
    > I thought that's what the timeout was for? Could anyone help to fix
    > this? How can I make autofs to recover from unavailable server? Thanks.
    >
    >


    Solution... wait a REALLY long time... believe it or not is will come
    back. I filed a bug on this one... I believe it's already fixed for
    11.1. This bug, though less irritating, is also in 10.3. In 10.2,
    the "right" thing is done which is to show the indirect mount point
    with NOTHING underneath. You'll have to enter the directory to
    force the indirect automounts.



  5. #5
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Default Re: How to use autofs in KDE4?

    Thank you, cjcox. I thought it was me. And, yes, it gets out of it in a minute or so.

    But another thing is Im using 'hard,intr' mount as opposed to soft. Not sure if 'soft' is a good adea, I read on the net that files can get corrupted with this option.
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •