Results 1 to 2 of 2

Thread: How to diable ping reply (ICMP) in Suse 11.0, Suse firewall2

  1. #1

    Default How to diable ping reply (ICMP) in Suse 11.0, Suse firewall2

    How to disable ping reply (ICMP) in "Suse 11.0," Suse firewall2 installed
    Acknowledgments:
    Thanks to Malcolmlewis for the inspiration
    Disable Ping Reply Suse 11.0 - openSUSE Forums

    Replacement firewall gui - openSUSE Forums

    This post is for the following situation:

    You've installed “Suse 11.0” on your computer. Although all of your computer's ports are stealth mode, your computer still replies to random ping request.

    Solution 1 of 2

    Google the following items

    #echo 0 > /proc/sys/net/ipv4/icmp_echo_ignore_all
    #echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_all

    Do they work? Probably, I've never tried it.
    Using solution, do I know how to backup the file to be modified? Do I know how to tell you to import and then export this file should you make a mistake with its implementation or in the event that the Googled instructions prove to be invalid? Do I know how to tell you o backup and save your original configuration should something go wrong? The answer to these questions for solution one only, is no. Solution 2 goes without saying and so the answer is yes.

    Solution 2:
    Have I tried it?
    Yes, and it worked like a charm, and here it is. Oh by the way, it easier to execute than the steps or the number of steps indicate.
    Please message me if you find an error and if it helped you, thanks

    Solution 2 of 2

    1) From the desktop, lower left-hand corner click start, the lizard looking icon.

    2) Click the "applications" tab.

    3) Scroll to “system” and then left click it.
    4) The menu changes, now left click “Yast admin settings”

    5) After a an extremely short delay, the “Run
    as Root” dialog appears.

    6) Enter the "root password."

    7) After a short delay, the “Yast Control
    center” Dialog box will appear.

    8) Within the left-hand column of the “Yast
    Control center” Dialog box, select "system"

    9) From near the top of the “Yast Control
    center” Dialog box, select "/etc/sysconfig
    editor."
    The “yast2 dialog box will appear although
    it will take awhile, 2 seconds on my
    system.

    10) In the lefthand column click “Network.”

    11) From the collapsible drop-down menu (menu
    tree for some) click "Firewall."

    12) From the collapsible drop-down menu (menu
    tree for some) click “Suse "Firewall2.”

    13) From the collapsible
    drop-down menu (menu tree for some)
    scroll to “FW_ALLOW_PING_FW”

    Note: You'll be scrolling for quite some time as the “FW_ALLOW_PING_FW” is beyond the halfway point of the collapsible
    drop-down menu (menu tree for some)

    14) In the upper center part of the screen,
    verify that the words “FW_ALLOW_PING_FW”
    are there. Then, slightly below and to the
    far right click the down arrow and
    select “No.”

    15) In the lower right-hand corner, click the
    "finish button." Wait for the ensuing
    computer activity to finish.

    16) Exit these dialog boxes and then restart
    the system.

    Congratulations, your system will no longer reply to random ping request!

    Please message me if you find an error and if it this thread helped you, thanks!

    Also, again, thanks to thanks to Malcolmlewis, Suse forum member, for the inspiration.

  2. #2

    Default Re: How to diable ping reply (ICMP) in Suse 11.0, Suse firewall2

    I don't know, why I am the first reply here, because for SuSe-users, who must or want to use Yast, this is the perfect answer ! Thanks very much suctoaun !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •