I'm trying to install zenmap on openSuse 10.3

I get the following errrs during install:

rpm -vhU http://nmap.org/dist/zenmap-4.68-1.noarch.rpm
Retrieving http://nmap.org/dist/zenmap-4.68-1.noarch.rpm
error: Failed dependencies:
pygtk2 is needed by zenmap-4.68-1.noarch
python-sqlite2 is needed by zenmap-4.68-1.noarch


The repository that comes with openSuse only contains an older version of nmap and the old GUI application (nmap-gtk). I've installed successfully the latest version of nmap with the rpm on their download page, however the zenmap rpm (from the same page) is giving me the above errors.