Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: compiling qt4 version of qucs -> where are the qt4 libs?

  1. #1

    Default compiling qt4 version of qucs -> where are the qt4 libs?

    Hi there, i'm trying to compile the qt4 version of qucs on opensuse 11 64 bit. The ./configure goes well, however when i do "make" i see it checking for qt4 libraries under /usr/lib/qt4, but it doesn't find them and seems to default to qt3 (/usr/lib/qt3) and then exit with a long line of error code. On checking my /usr/lib/qt4 directory i find no files, only one folder called plugins, but all the files that are listed in the make stage when compiling the qt4 version of qucs are not there. I tried looking for them through yast but alas cannot find them. Googling hasn't helped me much either, can anyone please give me a kick in the right direction?

    edit:
    -----------------------------------------
    sorry the absence of qt4 libs is already reffered to when using ./configure, here is a smple of what it says:
    -----------------------------------------
    checking for lrelease-qt4... no
    checking for lrelease... /usr/lib/qt3/bin/lrelease
    checking for lupdate-qt4... no
    checking for lupdate... /usr/lib/qt3/bin/lupdate
    checking for moc-qt4... no
    checking for moc... /usr/lib/qt3/bin/moc
    -----------------------------------------------------------

    kind regards,
    Wernher

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,100
    Blog Entries
    15

    Default Re: compiling qt4 version of qucs -> where are the qt4 libs?

    Quote Originally Posted by itchy8me
    Hi there, i'm trying to compile the qt4 version of qucs on opensuse 11
    64 bit. The ./configure goes well, however when i do "make" i see it
    checking for qt4 libraries under /usr/lib/qt4, but it doesn't find them
    and seems to default to qt3 (/usr/lib/qt3) and then exit with a long
    line of error code. On checking my /usr/lib/qt4 directory i find no
    files, only one folder called plugins, but all the files that are listed
    in the make stage when compiling the qt4 version of qucs are not there.
    I tried looking for them through yast but alas cannot find them.
    Googling hasn't helped me much either, can anyone please give me a kick
    in the right direction?

    kind regards,
    Wernher
    Hi
    One would imagine you to run;
    Code:
    ../configure --libdir=/usr/lib64
    or where ever the 64bit libs are, also try the configure command with
    --help to see other options you may need/can set.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 2:27, 1 user, load average: 0.16, 0.24, 0.25
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  3. #3

    Default Re: compiling qt4 version of qucs -> where are the qt4 libs?

    same problem , canot find the qt4 libs and defaults to qt3 :-s
    the problem is actually that i cannot find the qt4 libs, searching for them in yast doesn't yield much either.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,100
    Blog Entries
    15

    Default Re: compiling qt4 version of qucs -> where are the qt4 libs?

    Quote Originally Posted by itchy8me
    same problem , canot find the qt4 libs and defaults to qt3 :-s
    the problem is actually that i cannot find the qt4 libs, searching for
    them in yast doesn't yield much either.
    Hi
    It's libqt4 you can try from a console session;

    Code:
    sudo zypper in libqt4
    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 2:58, 2 users, load average: 0.16, 0.15, 0.14
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,100
    Blog Entries
    15

    Default Re: compiling qt4 version of qucs -> where are the qt4 libs?

    Quote Originally Posted by Malcolm
    Quote Originally Posted by itchy8me
    same problem , canot find the qt4 libs and defaults to qt3 :-s
    the problem is actually that i cannot find the qt4 libs, searching for
    them in yast doesn't yield much either.
    Hi
    It's libqt4 you can try from a console session;

    Code:
    sudo zypper in libqt4
    It's already been done, if you want a rpm?

    Science
    Repository


    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 3:01, 2 users, load average: 0.01, 0.09, 0.11
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  6. #6

    Default Re: compiling qt4 version of qucs -> where are the qt4 libs?

    ya.. i know theres a rpm.. have it installed allready. I want to build it with the qt4 libraries though (qucs has provided a port allready in sources).

    libqt4 is allready installed:

    $sudo zypper in libqt4
    Reading installed packages...
    'libqt4' is already installed.

    so where would i tell the compiler too look?

  7. #7

    Default Re: compiling qt4 version of qucs -> where are the qt4 libs?

    i don't get it.. shouldn't the lib files just be located under /usr/lib(64)/qt4. tried doing a search for one of the files mentioned in my first post (returned for by ./configure) and it returns diddly squat. where are they?

    just a side note: strangely looking at the folder /usr/lib64/qt3 i see that it is linked against /usr/lib/qt3.. is this kosher?

  8. #8
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    301

    Default Re: compiling qt4 version of qucs -> where are the qt4 libs?

    Hi

    make sure that you have libqt4-devel installed.

    hope this helps

  9. #9

    Default Re: compiling qt4 version of qucs -> where are the qt4 libs?

    yup its also installed

  10. #10

    Default Re: compiling qt4 version of qucs -> where are the qt4 libs?

    well i've tried reinstalling libqt4 and libqt4-devel but still no qt4 libs to be found, here is a part of the error code i recieve when running make after having done a ./autogen and ./configure: (notr its trying to use the qt3 libs because it couldn't find the qt4 libs)

    ----------------------------------------------------------

    g++ -DHAVE_CONFIG_H -I. -I.. -I/usr/lib/qt3/include -DQT_THREAD_SUPPORT -D_REENTRANT -I../qucs -g -O2 -pipe -fno-exceptions -fno-check-new -W -Wall -MT propertygrid.moc.o -MD -MP -MF .deps/propertygrid.moc.Tpo -c -o propertygrid.moc.o propertygrid.moc.cpp
    propertygrid.moc.cpp:17:2: error: #error "This file was generated using the moc from 3.3.8b. It"
    propertygrid.moc.cpp:18:2: error: #error "cannot be used with the include files from this version of Qt."
    propertygrid.moc.cpp:19:2: error: #error "(The moc has changed too much.)"
    In file included from /usr/lib/qt3/include/qmetaobject.h:45,
    from propertygrid.moc.cpp:12:
    /usr/lib/qt3/include/qconnection.h:48: error: function definition does not declare parameters
    In file included from /usr/lib/qt3/include/qglist.h:45,
    from /usr/lib/qt3/include/qptrlist.h:43,
    from /usr/lib/qt3/include/qstrlist.h:46,
    from /usr/lib/qt3/include/qmetaobject.h:46,
    from propertygrid.moc.cpp:12:
    ---------------------------------------------------

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •